Over Heating Issue

i have recently switched to the garuda linux. I am facing over heating issue. Even if i open only one or two application the CPU temperature rises over 80 degree celcius.

parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2c3e9637-10ef-4bc0-90bb-0b245dbe8da9 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Latitude E6420 v: 01 serial: <filter> Chassis: type: 9 
serial: <filter> 
Mobo: Dell model: N/A serial: <filter> BIOS: Dell v: A14 date: 07/11/2012 
Battery:   ID-1: BAT0 charge: 34.6 Wh (73.2%) condition: 47.3/62.2 Wh (76.0%) volts: 11.5 min: 11.1 
model: Sanyo DELL NH6K98C type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP arch: Sandy Bridge family: 6 
model-id: 2A (42) stepping: 7 microcode: 2F cache: L2: 3 MiB 
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19953 
Speed: 2066 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 2066 2: 2420 3: 2770 4: 1692 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0126 class-ID: 0300
Device-2: Ricoh Laptop_Integrated_Webcam_FHD type: USB driver: uvcvideo bus-ID: 1-1.5:3
chip-ID: 05ca:181c class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1")
Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 21.1.6 compat-v: 3.0
direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.13.9-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e v: kernel port: 4080
bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
vendor: Dell Inspiron M5010 / XPS 8300 driver: wl v: kernel modules: bcma port: 4040
bus-ID: 02:00.0 chip-ID: 14e4:4727 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IF-ID-1: wwp0s29u1u6i6 state: down mac: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 4060
bus-ID: 00:1f.2 chip-ID: 8086.282a rev: 04 class-ID: 0104
Drives:    Local Storage: total: 223.57 GiB used: 45.56 GiB (20.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: B1D1 scheme: MBR
Partition: ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 45.56 GiB (20.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 45.56 GiB (20.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 45.56 GiB (20.4%)
fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 45.56 GiB (20.4%)
fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.68 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 84.0 C mobo: 37.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 3817
Info:      Processes: 220 Uptime: 3m wakeups: 2 Memory: 5.68 GiB used: 2.69 GiB (47.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1199 lib: 300
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

How many years has it been since you last cleaned your laptop
And applied thermal paste ?

2 Likes

Best solution - Apply themal paste(Not so practical in the lockdown situation, because of all the shop clousures. You can order it online but be careful as you might screw up something when opening your laptop)

2nd - Delete the package called performance-tweaks and install powersaving-tweaks.
Install packages like auto-cpufreq and thermald
Get a kernel not aimed at performance. linux-zen is pointed for desktop users which you arent. Install the linux-lts or linux kernel.

Give the following a read :-

Seeing your inxi, you are rocking a 2nd generation dual core CPU. KDE wouldn't be a good choice.

Last year i have cleaned the laptop and also applied the thermal paste

Is the 2nd generation i5 processor is not good for this OS?, i am little confused about the last sentence. Please explain

Yea it's bad for thr Dragonized version, go for some lighter DE like xfce, Wayland etc

1 Like

You don't build a sportscar with an underpowered engine.

1 Like

It would be fine if you just scale back the effects. Although, that probably isn't the cause of the overheating.

2 Likes

How to scale back effects?, I really wants to use this OS it looks amazing and has many features that boosts productivity. i mainly use this PC for coding.

Use a better machine or a lighter DE or WM. That should be rather obvious.

1 Like

Did you try the fixes I listed?

I am not in front of my PC right now but in system settings under behavior I think desktop effects is in there. Start by unchecking everything but blur and see if that improves performance.

You can also uncheck blur but that will have a more significant impact on visuals so don't do that unless you have to.

Right click on the desktop and change the background image from inactive blur to image.

Those changes should have a decent impact on performance.

1 Like

This is not correct. The zen kernel simply increases system responsiveness though I have not seen any difference in any of my use cases.

Yes, I tried and it reduced the avg temperature from 90 degree to 60 degree. Thanks a lot all you guys for the quick responses and guidance. But i still wants to know about the optimization and how can i make Garuda Linux to run on low end devices such as mine i5 second generation, @dalto please if you know anything about the setting as you mentioned [ Over Heating Issue - #12 by dalto ] let us know in brief.

@regularCoder I have tried some of the solutions such as switching to powersaving-tweaks and auto-cpufreq it solved my problem up to some extent but i believe there is still some settings are there that we can change and run the OS on my low end device. Thanks for the support.

Alright good to know.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.