Os-prober detects Garuda as Debian

I've been reading the console output from the latest update a little closer, since the kernel update breaks my Garuda install and one of the odd messages i came across is the output of os-prober:

/dev/mapper/luks-6ec60199-2eb3-4b32-835c-0f29f002ab25:Debian GNU/Linux 11 (bullseye):Debian:linux:btrfs:UUID=1733e231-61d3-4c17-89b0-0bdd9f044070:[email protected]
/var/lib/docker/btrfs/subvolumes/5f31022533ec8de3c1be7909bb8baae44049d759e0937919ce44efd7645f2e91

This won't fix my install, but I still wonder how os-prober could be so wrong about the OS on my NVME.

It looks like it's related to a Docker container (not your OS).

2 Likes

It's the only output os-prober provides, so it has to be Garuda and the UUID also matches the Garuda install, since there is no other OS. I don't have any Debian containers in docker.

Which one, or you mean the grub bug?

All in all, maybe you could be so kind to post garuda-inxi?

sudo os-prober
/dev/nvme0n1p6:Garuda Linux:Garuda:linux:btrfs:UUID=cc8c3427-2bdc-407e-ae93-4105b6795059:[email protected]

It's a different issue than the grub bug. A while ago a kernel update broke my Garuda install, so I switched from zen to lts and everything was fine again. Then came along the additional grub entry for the recovery mode. So when grub now selected entry nr 3 from the list it wasn't lts anymore, but zen (recovery mode) and the total entries are now 6 and not 4. So zen still doesn't work for me, but at least lts works now that the correct entry is selected in grub.

garuda-inxi:

System:
  Kernel: 5.15.71-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=1733e231-61d3-4c17-89b0-0bdd9f044070 rw [email protected]
    quiet
    cryptdevice=UUID=6ec60199-2eb3-4b32-835c-0f29f002ab25:luks-6ec60199-2eb3-4b32-835c-0f29f002ab25
    root=/dev/mapper/luks-6ec60199-2eb3-4b32-835c-0f29f002ab25 quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: GNOME v: 42.5 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 15 9510 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 01V4T3 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.9.0 date: 03/17/2022
Battery:
  ID-1: BAT0 charge: 72.9 Wh (86.5%) condition: 84.3/84.3 Wh (100.0%)
    volts: 12.3 min: 11.4 model: SMP DELL 70N2F95 type: Li-poly
    serial: <filter> status: discharging
CPU:
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 built: 2020 process: Intel 10nm
    family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 897 high: 1150 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 919 2: 1123 3: 794
    4: 801 5: 801 6: 927 7: 800 8: 778 9: 800 10: 872 11: 1150 12: 818
    13: 862 14: 1031 15: 905 16: 986 bogomips: 73728
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0 chip-ID: 8086:9a60
    class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell
    driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-08) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max:
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25a0 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:3 chip-ID: 0c45:672e class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: eDP-1 model: Sharp 0x1515 built: 2021 res: 1920x1200 hz: 60
    dpi: 145 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 1920x1200
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.71-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 594.06 GiB (62.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
    NVMe WDC 1024GB size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 11170012 temp: 36.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 936.68 GiB size: 936.68 GiB (100.00%) used: 594.04 GiB
    (63.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-6ec60199-2eb3-4b32-835c-0f29f002ab25
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 18 MiB
    (6.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.68 GiB size: 936.68 GiB (100.00%) used: 594.04
    GiB (63.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-6ec60199-2eb3-4b32-835c-0f29f002ab25
  ID-4: /var/log raw-size: 936.68 GiB size: 936.68 GiB (100.00%) used: 594.04
    GiB (63.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-6ec60199-2eb3-4b32-835c-0f29f002ab25
  ID-5: /var/tmp raw-size: 936.68 GiB size: 936.68 GiB (100.00%) used: 594.04
    GiB (63.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-6ec60199-2eb3-4b32-835c-0f29f002ab25
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.36 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.89 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-892c9b70-a1a2-461e-8734-387156579e88
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 370 Uptime: 9m wakeups: 1866 Memory: 15.36 GiB used: 2.81 GiB
  (18.3%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1446
  libs: 361 tools: octopi,pamac,paru pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.21
Garuda (2.6.8-1):
  System install date:     2022-05-22
  Last full system update: 2022-09-29
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

OS-prober does not have to provide an output for each bootable entry, or any for that matter. It only offers an entry it is able to detect according to its configuration.

The UUID identifies the disk. If that is the disk where Garuda is installed, it would make sense that software installed on the system (like Docker, or anything else) would share the same UUID.

Are you sure about that?

Docker containers contain a lot of their own needed infrastructure; you could have installed a Docker container that uses a Debian stack. You honestly would have no idea unless you looked at the guts of whatever you installed.

6 Likes

Interesting. I was under the impression, that os-prober finds all installed OS, but I was wrong. I have removed all docker images and now the os-prober output is empty.
Thank you, @BluishHumility!

I thought so as well. Weird...
Did grub menu have any new entry for Debian after that, or did you explicitly run os-prober yourself?

1 Like

I can confirm this is purely a result of Docker. Nothing about it will alter the way grub behaves, all is fine.

3 Likes

Grub didn't show any Debian entries. Not before and not after I removed all docker images. And yes, I did run os-proper explicitly myself after discovering the the Debian message in the update log as part of "mkinitcpio -P"

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.