Orphaned qwikaccess-git and librewish git account 404 error?

Hi folks,

So, in recent updates, I run update -a and recently started getting notification that qwikaccess-git is orphaned. So, I checked the aur for it, and found that the upstream github account librewish is completely gone, or inaccessible to the public (or even logged in).

This is what I get when I run updates:

--> Updating AUR packages with paru..
:: Looking for AUR upgrades...
:: Looking for devel upgrades...
:: orphans: qwikaccess-git

When trying to load the upstream github repo, I'm getting a 404 error, and the entire /librewish/ account seems to be gone.

I've attempted to manually clone this aur repo and try to run makepkg -s to see what would happen:

> git clone https://aur.archlinux.org/qwikaccess-git.git
Cloning into 'qwikaccess-git'...
remote: Enumerating objects: 28, done.
remote: Counting objects: 100% (28/28), done.
remote: Compressing objects: 100% (27/27), done.
remote: Total 28 (delta 1), reused 28 (delta 1), pack-reused 0
Receiving objects: 100% (28/28), 9.77 KiB | 9.77 MiB/s, done.
Resolving deltas: 100% (1/1), done.

> makepkg -s
==> Making package: qwikaccess-git 0.0.1.r65.ae84897-1 (Wed 30 Nov 2022 01:32:43 PM EST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning qwikaccess git repo...
Cloning into bare repository '/home/[redacted]/aur_projects/qwikaccess-git/qwikaccess'...
Username for 'https://github.com': [redacted]
Password for 'https://[redacted]@github.com':
remote: Support for password authentication was removed on August 13, 2021.
remote: Please see https://docs.github.com/en/get-started/getting-started-with-git/about-remote-repositories#cloning-with-https-urls for information on currently recommended modes of authentication.
fatal: Authentication failed for 'https://github.com/librewish/qwikaccess.git/'
==> ERROR: Failure while downloading qwikaccess git repo
    Aborting...

The PKGBUILD just downloads from the git repo, which now no longer seemingly exists. I tried searching the forum to learn more about the missing librewish account - and it appears that all reference to librewish on github and twitter were removed. There were old cached content on twitter that seemed to indicate that librewish is a founder of Garuda Linux, so just wanted to see what's up.

2 Likes

Librewish is taking a much deserved break from the project in the short term. With having started a new job in the IT field, time constraints were preventing him from being able to participate full time with Garuda as he had done in the past. Librewish is concentrating all his efforts on his new career for now.

We all wish him the best of luck with his new job. Hopefully, when the demands of his new job become less onerus he can return to participating again on the project in the future. I hope everyone can understand why the Garuda project had to take a backseat to establishing himself in his new career.

With regards to orphaned packages, I'm sorry but I wasn't aware that parts of the project he was maintaining had been left dangling. I'll have to pass this issue along to the developers as this is out of the scope of my participation with Garuda. Hopefully the issue will be addressed soon.

10 Likes

Congrats to librewish! May he have a fruitful and successful tenure at his new job!

No worries at all, I was not aware, and was just curious about the error message, as it's not listed as orphaned in the aur - and found myself down the rabbit hole to discovering they've all mysteriously vanished LOL

Cheers and thank you!

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.