Opensnitch Offered by Garuda Assistant Doesn't Install Correctly

The Opensnitch version offered by the Garuda assistant doesn't seem to install correctly.

  1. The Opensnitch daemon doesn't start when the main GUI is launched, I have to enter commands found here to start the daemon and the opensnitch service. After these are entered blocking resumes as normal. Nothing I tried in the GUI would start outbound connection monitoring.
  2. Outbound connection prompting doesn't survive a reboot. (I gave up troubleshooting here as setting the autostart option in the GUI, didn't function and I figured I would try and get help from more experienced users).
  1. That's normal, you need to start the service lol.
  2. Connections doesn't survive reboots.

Edit: as for the autostart, just enable the service...

1 Like

Sorry, I meant the opensnitch prompt when a program tries to connect. I ran the command listed in that link to start the service and everything works fine until I restart, then I have to do it again.

As I said, enable the service...

Stacer is a simple way to enable the service - turn on opensnitchd:

1 Like

Thank you! I'll try that

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.