ONLYOFFICE Appimage is not working in XFCE

Hello, I am using Garuda Linux (XFCE Desktop) since about 15 days.
I was previously using Gnome 44 with Garuda but decided to switch.
The software I want to use, ONLYOFFICE (v 7.4.1) (an alternative office suite) package called onlyoffice-bin from chaotic aur repository, Is dependancy deadlocked with the package ttf-google-fonts-git as it already provides one font ttf-carlito ,
Which is required by ONLYOFFICE as a separately installed Dependancy.
So instead To work around this I downloaded an AppImage instead, but even with Appimage Launcher, it is not working, (after clicking on it, nothing happens).

I faced same issue in Gnome previously (dependancy deadlock), but there, Onlyoffice AppImage worked and launched properly.

Can you assist me findong solution to this problem?

here’s garuda-inxi output from my system.

╭─mihirvp@mihirvp in ~ took 9ms
 ╰─λ garuda-inxi
  Kernel: 6.1.54-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=5128666b-c28b-46a6-b67b-b9de240be2eb rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=8cb7d437-97a7-41c8-b51e-43946f9339fe loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81SY v: Lenovo Legion Y540-15IRH-PG0
    serial: <superuser required> Chassis: type: 10 v: Lenovo Legion
    Y540-15IRH-PG0 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN
    serial: <superuser required> UEFI: LENOVO v: BHCN45WW date: 05/24/2022
  ID-1: BAT0 charge: 27.3 Wh (60.0%) condition: 45.5/52.5 Wh (86.8%)
    volts: 11.8 min: 11.2 model: SMP L17M3PG1 type: Li-poly serial: <filter>
    status: not charging cycles: 113
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3622 high: 4202 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4181 2: 4197 3: 4194
    4: 800 5: 800 6: 4202 7: 4188 8: 4196 9: 4200 10: 4194 11: 4120 12: 4200
    bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-08) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1f91
    class-ID: 0300
  Device-2: Lite-On Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:2 chip-ID: 04ca:7070
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 143 s-size: 341x191mm (13.43x7.52")
    s-diag: 391mm (15.39")
  Monitor-1: DP-4 res: 1920x1080 hz: 60 dpi: 142
    size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  API: ALSA v: k6.1.54-1-lts status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:4
    chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c010c
  Local Storage: total: 1.16 TiB used: 35.77 GiB (3.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKKW010T8L
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: L12C temp: 30.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Lexar model: 256GB SSD
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 610 scheme: GPT
  ID-1: / raw-size: 221.09 GiB size: 221.09 GiB (100.00%)
    used: 35.76 GiB (16.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 580 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 221.09 GiB size: 221.09 GiB (100.00%)
    used: 35.76 GiB (16.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 221.09 GiB size: 221.09 GiB (100.00%)
    used: 35.76 GiB (16.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 221.09 GiB size: 221.09 GiB (100.00%)
    used: 35.76 GiB (16.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  ID-2: swap-2 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 62.0 C pch: 54.0 C mobo: N/A gpu: nvidia
    temp: 48 C
  Fan Speeds (rpm): N/A
  Processes: 339 Uptime: 1h 34m wakeups: 6143 Memory: total: 16 GiB
  available: 15.53 GiB used: 3.38 GiB (21.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1444 libs: 374 tools: octopi,pamac,paru Shell: Bash
  v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-09-09
  Last full system update: 2023-09-21
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

My search in forum.

Hi, I read few of the posts.
I currently have not installed the explicit ttf-carlito package (it conflicts with ttf-googlefonts-git).
The ttf-google-fonts-git package mentioned in above post is not the one I have installed, rather an updated package from chaotic-aur repository : ([ttf-google-fonts-git from Chaotic AUR].

which one of these can be a problem?
– AppImage not working
– Problem with AppImage Launcher
– Problem with XFCE not working with Appimages
– LTS kernel : (previously I was using Zen kernel with Gnome where Appimage worked)

IDK onlyoffice, try libreoffice :slight_smile:

Xfce and LTS kernel shouldn’t be the problem.
Appimage had an issue a few months ago for which it was not launching unless you downgraded squashfuse, but that’s solved now.
So, I’d point to appimage launcher.
Have you just installed it? If so, please reboot before using it.

1 Like

Hello, Sorry for the late reply.
Yes, I have Installed Appimage Launcher Properly.
I have rebooted System.
I got the Simplenote Appimage working Just fine. but even after multiple downloads and integration, the ONLYOFFICE Appimage seems to be not working.
Can you still help me with this?
sidenote. after clicking on the ONLYOFFICE Appimage, nothing shows up in XFCE Task manager or HTOP.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.