Only half of the screen is working

Hello, today I tried to set my monitor refresh rate to 60 Hz instead of 144 to optimize battery, but only half of the screen was visible when I set my monitor to 60 Hz.

The half which isn't working is black.

sudo garuda-inxi
System:
Kernel: 5.17.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
root=UUID=a7e2f5c7-fe48-4582-8a96-652a235481a9 rw [email protected]
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
mitigations=off amd_iommu=on iommu=pt
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: Razer product: Blade 14 - RZ09-0370 v: 1.04
serial: <filter> Chassis: type: 10 serial: N/A
Mobo: Razer model: PI411 v: 4 serial: N/A UEFI: Razer v: 1.06
date: 06/07/2021
Battery:
ID-1: BAT0 charge: 27.1 Wh (44.5%) condition: 60.9/61.6 Wh (98.8%)
volts: 16.3 min: 15.4 model: Razer Blade type: Unknown serial: <filter>
status: charging
CPU:
Info: model: AMD Ryzen 9 5900HX with Radeon Graphics socket: FP6 bits: 64
type: MT MCP arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3300 min/max: 1200/4889 boost: disabled
base/boost: 3300/4650 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3300 2: 3300 3: 3300 4: 3300
5: 3300 6: 3300 7: 3300 8: 3300 9: 3300 10: 3300 11: 3300 12: 3300
13: 3300 14: 3300 15: 3300 16: 3300 bogomips: 105442
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
usercopy barriers only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Razer USA
driver: nvidia v: 510.68.02 alternate: nouveau,nvidia_drm pcie: gen: 1
speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
Device-2: AMD Cezanne vendor: Razer USA driver: amdgpu v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: none bus-ID: 04:00.0 chip-ID: 1002:1638
class-ID: 0300
Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
bus-ID: 3-4:2 chip-ID: 13d3:56d5 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Sharp LQ140M1JW49 built: 2020 res: 1920x1080
hz: 144 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.5-arch1-1)
v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: NVIDIA vendor: Razer USA driver: snd_hda_intel v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Razer USA
driver: snd_rn_pci_acp3x v: kernel
alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_sof_amd_renoir
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Razer USA
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-arch1-1 running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2725
class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-3:2 chip-ID: 8087:0032 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 465.03 GiB (48.8%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB1T0HBLR-00000 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EXF7201Q temp: 38.9 C scheme: GPT
SMART: yes health: PASSED on: 7d 1h cycles: 1,055
read-units: 13,000,777 [6.65 TB] written-units: 10,383,969 [5.31 TB]
Partition:
ID-1: / raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
used: 465.03 GiB (49.6%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
used: 465.03 GiB (49.6%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
used: 465.03 GiB (49.6%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 936.96 GiB size: 936.96 GiB (100.00%)
used: 465.03 GiB (49.6%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.61 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.04 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 482 Uptime: 13m wakeups: 1 Memory: 15.04 GiB
used: 4.36 GiB (29.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1905 lib: 507
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-02-11
Last full system update: 2022-05-07 ↻
Is partially upgraded:   No
Relevant software:       tlp NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

The GPU which I'm currently using is the CPU integrated one so no Nvidia driver involved.

This might sound very stupid but did you at least reboot after the change to see if it seems permanent?

3 Likes

Yes, I have tried to reboot

1 Like

That's an odd problem--pretty much the opposite of most refresh rate issues you see in the forum.

What was your method for changing the refresh rate?

5 Likes

To change the refresh rate I'm using KDE monitor settings.
If I also change the resolution while my monitor is set on 60hz the problem changes creating strange glitches on the screen.

You probably have a faulty display. Or there may be a problem with the display cable. I recommend contacting a service center. I have encountered a similar problem, in the end it was a hardware problem and was solved by replacing the screen.

1 Like

Are there any display-related settings in your BIOS menu?

1 Like

Is your bios up to date?

Have you tested multiple different kernels?

Have you tested different live disks to see if this issue is present there?

3 Likes

No, there is nothing about the display in my BIOS menu.

Yes, furthermore, the problem isn't present on Windows, so I think that the bios isn't the problem

Yes, I have, and the same problem is present.

I think that the problem is related to the fact that windows razer uses its own application (razer central) to change the refresh rate.

Actually, this is not the problem, but the solution for WinOS. The problem is your Laptop hardware/firmware.

You skipped one advice. Please do this before anything else. There is no reason we try to fix something that is not fixable by design :wink:

After the above, if no solution found, produce more actual info:
Assuming the monitor is at 144hz, do the changes that create the issue and then reset to the old setup.
Post xorg log for inspection. (to a pastebin service)
Also get output before and after changes (to a pastebin service) for

xrandr --verbose
2 Likes

It might be worth trying some other refresh rates, too. Try 48 Hz, 58 Hz, 59 Hz and see if you get different results.

2 Likes

Does this do this runnong with the live usb? As everything will be default?

4 Likes

Why do you Cherry pick the questions you choose to answer?

Windows is 100% irrelevant, as it does not relate to Linux. The computer I am writing this on has a bios that USB does not work in Linux, but works fine in Windows. The manufacturer (Gigabyte) figured Linux was irrelevant, so they never bothered to release a bios update to correct the known issues with Linux. I don't know how many times I have to repeat "Linux is not Windows" before people get this through their head.

Sorry to be critical, but 2/3 of my questions you said you'd done, and the third you ignored. Basically everything I wrote was a complete waste of my time.

4 Likes

WQHD-Display, 165 Hz

WQHD-Display (2.560 x 1.440 Pixel)

:person_shrugging:

2 Likes

Simply because I was not at home. After I tried it and it made no difference

I don't understand the meaning of this message :sweat_smile:

If you keep ignoring the questions and advice given, we can't help any more, so we will close this topic.

Last chance:
Answer with detail. Your understanding about what you are saying means to other multi-language, multiple technical level of experience people, is not what actually others understand from your description. Especially answers like "no work", "no dice", "nothing good" and similar are offending to others that try to help you without adequate information.

Contact your hardware vendor support and get answers to your issue.

One more day of patience...

7 Likes

These types of answers are inadequate if you actually desire to find a resolution to your issue. You need to provide far more detail. When asked to do something your feedback needs to be more in depth than "didn't work".

I guess you are saying you had the same issue on the live disk? You need to provide more information than this.

Which Garuda live disk did you use?

If you used a Garuda KDE live disk I would highly suggest testing a Garuda Gnome live disk. If you test a Garuda Gnome live disk and the same issue is present, then I would very highly suggest testing an Ubuntu live disk.

Please be more thorough when answering questions. When 2 different forum assistants ask you to perform the same operation, (testing a live disk) and you provide no response this is being very unhelpful. Rather than ignoring both of the suggestions, you should have provided a response. Both assistants would have fully understood why you couldn't, if you'd simply stated you didn't have access to your computer ATM. Simply stating you would test out our recommendations when you have access to your computer is the proper way of handing those types of situations, rather than just ignoring people's suggestions. Ignoring suggestions and not providing proper feedback is a sure recipe for never getting any more assistance as this alienates assistants and only makes them not want to give you any more help.

I'm not trying to be rude to you, but if you want assistance, you are going about it all wrong.

7 Likes