One on my usb port is not working properly ( kernel: usb 3-1: device not accepting address 8, error -71)

My laptop was working properly a week ago but suddenly one of the USB port stop recognising any device I plug in. I want to connect a USB-stick for my headset (the light turns on) but the computer doesn't read it

Here are my garuda -inxi:

╭─[email protected] in ~ took 6ms
 ╰─λ garuda-inxi
System:
  Kernel: 6.1.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8ccf1418-878f-4445-94cd-fa59cea87218 rw single
    [email protected]
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Swift SF316-51 v: V1.10
    serial: <superuser required>
  Mobo: TGL model: Sangria_TL v: V1.10 serial: <superuser required>
    UEFI: Insyde v: 1.10 date: 09/16/2021
Battery:
  ID-1: BAT1 charge: 46.0 Wh (100.0%) condition: 46.0/56.0 Wh (82.2%)
    volts: 17.3 min: 15.4 model: SMP AP18C7M type: Li-ion serial: <filter>
    status: full cycles: 43
CPU:
  Info: model: 11th Gen Intel Core i5-11300H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xA6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 2269 high: 3100 min/max: 400/4400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3100 2: 3100 3: 400
    4: 3100 5: 3100 6: 1101 7: 3100 8: 1152 bogomips: 49766
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics]
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-12.1
    process: Intel 10nm built: 2020-21 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:9a49
    class-ID: 0300
  Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-5:2
    chip-ID: 0408:a094 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x160b built: 2020 res: 1920x1080
    hz: 60 dpi: 137 gamma: 1.2 size: 355x199mm (13.98x7.83") diag: 407mm (16")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    vendor: Acer Incorporated ALI driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound API: ALSA v: k6.1.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Drives:
  Local Storage: total: 476.94 GiB used: 135.62 GiB (28.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 3400 MTFDKBA512TFH
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P7MA000 temp: 49.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 459.67 GiB size: 459.67 GiB (100.00%)
    used: 135.62 GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 459.67 GiB size: 459.67 GiB (100.00%)
    used: 135.62 GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 459.67 GiB size: 459.67 GiB (100.00%)
    used: 135.62 GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 459.67 GiB size: 459.67 GiB (100.00%)
    used: 135.62 GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.97 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  Src: /sys System Temperatures: cpu: 30.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 254 Uptime: 5m wakeups: 300 Memory: 15.42 GiB
  used: 2.88 GiB (18.7%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1273 libs: 332 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2022-08-31
  Last full system update: 2023-01-24
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:            plymouth-deactivate.service


This is the error log I'm geting with sudo dmesg | grep -i usb:


╭─[email protected] in ~ as 🧙 took 1ms
 ╰─λ sudo dmesg | grep -i usb
[    0.397450] ACPI: bus type USB registered
[    0.397450] usbcore: registered new interface driver usbfs
[    0.397450] usbcore: registered new interface driver hub
[    0.397450] usbcore: registered new device driver usb
[    0.758987] usbcore: registered new interface driver usbserial_generic
[    0.758989] usbserial: USB Serial support registered for generic
[    3.582726] xhci_hcd 0000:00:0d.0: new USB bus registered, assigned bus number 1
[    3.584006] xhci_hcd 0000:00:0d.0: new USB bus registered, assigned bus number 2
[    3.584008] xhci_hcd 0000:00:0d.0: Host supports USB 3.1 Enhanced SuperSpeed
[    3.584039] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 6.01
[    3.584041] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.584043] usb usb1: Product: xHCI Host Controller
[    3.584044] usb usb1: Manufacturer: Linux 6.1.7-zen1-1-zen xhci-hcd
[    3.584045] usb usb1: SerialNumber: 0000:00:0d.0
[    3.594346] hub 1-0:1.0: USB hub found
[    3.601332] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 6.01
[    3.601335] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.601337] usb usb2: Product: xHCI Host Controller
[    3.601338] usb usb2: Manufacturer: Linux 6.1.7-zen1-1-zen xhci-hcd
[    3.601339] usb usb2: SerialNumber: 0000:00:0d.0
[    3.601472] hub 2-0:1.0: USB hub found
[    3.602718] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
[    3.604142] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 4
[    3.604144] xhci_hcd 0000:00:14.0: Host supports USB 3.1 Enhanced SuperSpeed
[    3.604174] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 6.01
[    3.604176] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.604177] usb usb3: Product: xHCI Host Controller
[    3.604178] usb usb3: Manufacturer: Linux 6.1.7-zen1-1-zen xhci-hcd
[    3.604179] usb usb3: SerialNumber: 0000:00:14.0
[    3.607605] hub 3-0:1.0: USB hub found
[    3.611978] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 6.01
[    3.611981] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.611982] usb usb4: Product: xHCI Host Controller
[    3.611983] usb usb4: Manufacturer: Linux 6.1.7-zen1-1-zen xhci-hcd
[    3.611985] usb usb4: SerialNumber: 0000:00:14.0
[    3.612061] hub 4-0:1.0: USB hub found
[    3.612296] usb: port power management may be unreliable
[    3.852407] usb 3-5: new high-speed USB device number 2 using xhci_hcd
[    3.990201] usb 3-5: New USB device found, idVendor=0408, idProduct=a094, bcdDevice= 0.02
[    3.990208] usb 3-5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.990211] usb 3-5: Product: HD User Facing
[    3.990213] usb 3-5: Manufacturer: SunplusIT Inc
[    4.106531] usb 3-7: new high-speed USB device number 3 using xhci_hcd
[    4.240470] usb 3-7: New USB device found, idVendor=1c7a, idProduct=0575, bcdDevice=10.72
[    4.240478] usb 3-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    4.240481] usb 3-7: Product: EgisTec EH575
[    4.240483] usb 3-7: Manufacturer: EgisTec
[    4.240486] usb 3-7: SerialNumber: 07B35E7E
[    4.357524] usb 3-10: new full-speed USB device number 4 using xhci_hcd
[    4.486653] usb 3-10: New USB device found, idVendor=8087, idProduct=0026, bcdDevice= 0.02
[    4.486660] usb 3-10: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    5.924255] typec port0: bound usb3-port2 (ops connector_ops)
[    5.924263] typec port0: bound usb2-port1 (ops connector_ops)
[    5.994328] usbcore: registered new interface driver btusb
[    6.199861] usb 3-5: Found UVC 1.00 device HD User Facing (0408:a094)
[    6.217517] input: HD User Facing: HD User Facing as /devices/pci0000:00/0000:00:14.0/usb3/3-5/3-5:1.0/input/input12
[    6.220523] usbcore: registered new interface driver uvcvideo
[   77.567533] usb 3-1: new full-speed USB device number 5 using xhci_hcd
[   77.681607] usb 3-1: device descriptor read/64, error -71
[   77.900603] usb 3-1: device descriptor read/64, error -71
[   78.123552] usb 3-1: new full-speed USB device number 6 using xhci_hcd
[   78.237632] usb 3-1: device descriptor read/64, error -71
[   78.460607] usb 3-1: device descriptor read/64, error -71
[   78.569646] usb usb3-port1: attempt power cycle
[   78.949549] usb 3-1: new full-speed USB device number 7 using xhci_hcd
[   78.949757] usb 3-1: Device not responding to setup address.
[   79.153744] usb 3-1: Device not responding to setup address.
[   79.361543] usb 3-1: device not accepting address 7, error -71
[   79.475409] usb 3-1: new full-speed USB device number 8 using xhci_hcd
[   79.475667] usb 3-1: Device not responding to setup address.
[   79.681776] usb 3-1: Device not responding to setup address.
[   79.889549] usb 3-1: device not accepting address 8, error -71
[   79.889704] usb usb3-port1: unable to enumerate USB device

I tried to change the usbcore.autosuspend but didn't work and since doesn't matter is a plug the USB-stick before or after rebooting, I don't think is actually the problem but I couldn't find any solution on the web and that's why I'm asking for assistance.

Thank you.

I would try the live usb of garuda and see if the usb port is recognized.
It may be a hardware fault

3 Likes

I thought the same, it could be the hardware.I just tried to reinstall all packages with the garuda assitant and no results. Is the live usb of garuda a software?

Not sure what you mean by that?
But to clarify,
Use the usb install image that you used to install garuda and just run it as a live environment to check your hardware (usb) ports are all detected.

3 Likes

Okay, now I get it! thanks I will try it if it doesn't work I will let you know in a couple minutes.

Post

lsusb

as

text

with pluged and unpluged stick.

4 Likes

This is the lsusb (usb pluged)


lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 1c7a:0575 LighTuning Technology Inc. EgisTec EH575
Bus 003 Device 002: ID 0408:a094 Quanta Computer, Inc. HD User Facing
Bus 003 Device 004: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

this is the lsusb (unpluged)


lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 1c7a:0575 LighTuning Technology Inc. EgisTec EH575
Bus 003 Device 002: ID 0408:a094 Quanta Computer, Inc. HD User Facing
Bus 003 Device 004: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

as you can see there's no difference but when I plug it in the other usb port you can see in line four that the usb for the hyperX cloud II appears, that makes me think that the laptop has a hardware malfunction.


lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 1c7a:0575 LighTuning Technology Inc. EgisTec EH575
Bus 003 Device 002: ID 0408:a094 Quanta Computer, Inc. HD User Facing
Bus 003 Device 035: ID 0951:1718 Kingston Technology HyperX Cloud II Wireless
Bus 003 Device 004: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have tried to run live with a ISO in a pendrive and still didn't work but if you have any suggestion I will tried.

Thanks anyway :slight_smile:

I think the usb port maybe broken

3 Likes

With this information, no one can help you.

2 Likes

Thank you @TilliDie and @SGS both!

1 Like

Typically it is possible to disable USB ports in the BIOS menu. It would be odd for this to be configured accidentally, as you kind of have to go out of your way to manipulate BIOS settings. Still, before you give up it would be worth checking.

4 Likes

Probably a very slight chance of helping, but it never hurts to test other kernels in case a new kernel regression has been introduced. Try the LTS and mainline kernels, just on the off chance they may help.

1 Like