On boot i get error hidden.mod not found and stystem is behaving a bit different

on booting i get the following error

ERROR:file'@/boot/grub/x86_64-efi/part_mdosGRUB_TIMEOUT_STYLE=hidden.mod' not found.

After installing Garuda I used it for few months and then i tried editing grub and ended up in grub rescue :sweat_smile:.
i somehow fixed it with loading kernel from rescue,since then i get the error while booting
i think i messed up mounting part while in grub rescue and the system experience got different
for example when i used command cd /

permission denied

output :

Kernel: 6.2.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 rw [email protected]
quiet splash intel_pstate=disable
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Convertible System: HP product: HP Pavilion x360 Convertible
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 31
serial: <superuser required>
Mobo: HP model: 81A9 v: 57.53 serial: <superuser required> UEFI: Insyde
v: F.40 date: 11/09/2020
ID-1: BAT0 charge: 26.8 Wh (71.5%) condition: 37.5/37.5 Wh (100.0%)
volts: 11.6 min: 11.4 model: 333-42-42 BI03041XL type: Li-ion
serial: <filter> status: discharging
Info: model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake
note: check gen: core 7 level: v3 note: check built: 2017
process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 9
microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 3100 min/max: 400/2601 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 3100 2: 3100 3: 3100
4: 3100 bogomips: 21599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916
class-ID: 0300
Device-2: Sunplus Innovation HP Wide Vision HD type: USB driver: uvcvideo
bus-ID: 1-8:3 chip-ID: 1bcf:2c83 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x052d built: 2016 res: 1920x1080
hz: 60 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5") diag: 337mm (13.3")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 620 (KBL
GT2) direct-render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
API: ALSA v: k6.2.10-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.68 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-6:2 chip-ID: 8087:0aa7 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 223.57 GiB used: 31.59 GiB (14.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: B1H5 scheme: GPT
ID-1: / raw-size: 175.41 GiB size: 175.41 GiB (100.00%)
used: 31.57 GiB (18.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 20.2 MiB (6.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 175.41 GiB size: 175.41 GiB (100.00%)
used: 31.57 GiB (18.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 175.41 GiB size: 175.41 GiB (100.00%)
used: 31.57 GiB (18.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 175.41 GiB size: 175.41 GiB (100.00%)
used: 31.57 GiB (18.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.63 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 90.0 C pch: 81.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 220 Uptime: 33m wakeups: 1 Memory: 7.63 GiB
used: 3.61 GiB (47.2%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: 2950 pm: pacman pkgs: 2943
libs: 489 tools: octopi,paru pm: flatpak pkgs: 7 Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-12
Last full system update: 2023-04-14
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:            nginx.service reflector.service


lsblk -a 


sda      8:0    0 223.6G  0 disk
├─sda1   8:1    0   300M  0 part /boot/efi
├─sda2   8:2    0 175.4G  0 part /var/log
├─sda3   8:3    0   8.8G  0 part [SWAP]
├─sda4   8:4    0  29.7G  0 part
└─sda5   8:5    0   9.3G  0 part
zram0  254:0    0   7.6G  0 disk [SWAP]

i have garuda (main os) and aarch linux i have edited grub to boot to aarch from garuda's grub and also usb menuentry to boot from USB

Try restoring a snapshot from before this happened in the advanced boot options of the Grub menu.


i booted into oldest snapshost possible but the issue wasn'nt resolved..

Please explain in as much detail as you can what you mean by this.


Use search function.

chroot, install grub, update grub.

1 Like

i have chrooted with live media and reinstalled grub

i meant i had made several grub customisations and when i added a line to hide the boot process since windows logo used to pop up while booting garuda i ended up in grub rescue . i fixed it by chrooting then this error pops up whenever i boot .
i have also removed the line i added to /ec/default/grub
please tell me if any output is required i'll provide it as soon as possible

You added a line to what file?

What did the line say?

Chrooting alone doesn't fix anything. What did you do inside the chroot to fix it?

1 Like

i edited grub at /etc/deafult/
it dont rember the line but it was to hide display
my current grub file i:

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable"

# Preload both GPT and MBR modules so that they are not missed

# Uncomment to enable booting from LUKS encrypted devices

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

# Uncomment to disable submenus in boot menu

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.

# This config file imports drop-in files from /etc/default/grub.d/.
for garuda_grub_d in ${sysconfdir}/default/grub.d/*.cfg ; do if [ -e "${garuda_grub_d}" ]; then source "${garuda_grub_d}"; fi; done

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable"

You have this line in /etc/default/grub twice, once on line 6 and again on the bottom line. Go ahead and delete the one on the bottom.

It sounds like you changed other things besides this one line:

Try to be more specific. There is still a lot of missing information here.

Show what is in /etc/grub.d/ when you have a chance.

ls /etc/grub.d/
1 Like
ls /etc/grub.d/
00_header     30_os-prober      40_custom           60_memtest86+
10_linux      30_uefi-firmware  41_custom           61_custom_leave_options
20_linux_xen  35_fwupd          41_snapshots-btrfs  README

40_custom is for booting to usb drive
code :

exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Boot from USB" {
    search --no-floppy --fs--uuid AE93-7130 --set=root
    set root=$search_fs_uuid
    chainloader +1}


Generating grub configuration file ...
Found theme: /usr/share/grub/themes/tela/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Bodhi 6.0 (20.04) on /dev/sda4
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-04-14 17:11:10 | @/.snapshots/447/snapshot | post | arch-install-scripts                                                     |
Found snapshot: 2023-04-14 17:11:04 | @/.snapshots/446/snapshot | pre  | pacman -S extra/arch-install-scripts                                     |
Found snapshot: 2023-04-14 13:06:11 | @/.snapshots/445/snapshot | post | stress             |
Found snapshot: 2023-04-14 13:06:08 | @/.snapshots/444/snapshot | pre  | pacman -S stress   |
Found snapshot: 2023-04-14 12:53:05 | @/.snapshots/443/snapshot | post | python-aiohttp python-terminaltables                                     |
Found snapshot: 2023-04-14 12:53:01 | @/.snapshots/442/snapshot | pre  | pacman -Su         |
Found snapshot: 2023-04-13 22:56:14 | @/.snapshots/441/snapshot | post | a2ps proton-ge-custom                                                    |
Found snapshot: 2023-04-13 22:56:01 | @/.snapshots/440/snapshot | pre  | pacman -Su         |
Found snapshot: 2023-04-13 20:16:40 | @/.snapshots/439/snapshot | post | candy-icons-git chaotic-mirrorlist gunicorn gupnp-igd lib32-openal libni |
Found snapshot: 2023-04-13 20:16:35 | @/.snapshots/438/snapshot | pre  | pacman -Syu        |
Found 10 snapshot(s)
Unmount /tmp/grub-btrfs.LVwpBzqS0F .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin

kate /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4E15-2982                            /boot/efi      vfat    defaults,noatime 0 2
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=7fc7b7c9-1156-461d-8b25-c94450f554d2 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=97df0fc2-f84d-41c5-97b4-a62dd0a3a08b none swap defaults 0 0

df :

Filesystem     1K-blocks     Used Available Use% Mounted on
devtmpfs            4096        0      4096   0% /dev
tmpfs            4002476   117468   3885008   3% /dev/shm
tmpfs            1600992     1600   1599392   1% /run
/dev/sda2      183931904 33150756 148669228  19% /
/dev/sda2      183931904 33150756 148669228  19% /home
/dev/sda2      183931904 33150756 148669228  19% /root
/dev/sda2      183931904 33150756 148669228  19% /srvFilesystem     1K-blocks     Used Available Use% Mounted on
devtmpfs            4096        0      4096   0% /dev
tmpfs            4002476   117468   3885008   3% /dev/shm
tmpfs            1600992     1600   1599392   1% /run
/dev/sda2      183931904 33150756 148669228  19% /
/dev/sda2      183931904 33150756 148669228  19% /home
/dev/sda2      183931904 33150756 148669228  19% /root
/dev/sda2      183931904 33150756 148669228  19% /srv
tmpfs            4002476     2980   3999496   1% /tmp
/dev/sda2      183931904 33150756 148669228  19% /var/cache
/dev/sda2      183931904 33150756 148669228  19% /var/tmp
/dev/sda2      183931904 33150756 148669228  19% /var/log
/dev/sda1         306572    20728    285844   7% /boot/efi
tmpfs             800492       72    800420   1% /run/user/1000
tmpfs            4002476     2980   3999496   1% /tmp
/dev/sda2      183931904 33150756 148669228  19% /var/cache
/dev/sda2      183931904 33150756 148669228  19% /var/tmp
/dev/sda2      183931904 33150756 148669228  19% /var/log
/dev/sda1         306572    20728    285844   7% /boot/efi
tmpfs             800492       72    800420   1% /run/user/1000

This looks good actually. Did you reinstall Grub first?

Something like this:

grub-install --target=x86_64-efi --efi-directory=*esp* --bootloader-id=GRUB

Or see what options you may need here: GRUB - ArchWiki

Then update Grub again, exit the chroot and reboot to test again.

You have these two statements on one line, but I think grub expects only one per line.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.