Old snapshots/backups found on every boot

Hello, please see the output of garuda-inxi at the bottom of this post. Whenever I boot I get a notification that old snapshots have been found.

2022-12-11T21:44:40,637897768+01:00

This occurs even if I delete any more than two weeks old and reboot. If I run

export XDG_CURRENT_DESKTOP
  sudo -E btrfs-assistant-bin

and navigate to the Snapper tab, I am able to delete old snapshots. Output of

> sudo btrfs sub list /
ID 256 gen 100635 top level 5 path @_backup_20221909140226161
ID 257 gen 100689 top level 5 path @home
ID 258 gen 100674 top level 5 path @root
ID 259 gen 7010 top level 5 path @srv
ID 260 gen 100674 top level 5 path @cache
ID 261 gen 100689 top level 5 path @log
ID 262 gen 100674 top level 5 path @tmp
ID 263 gen 100682 top level 662 path .snapshots
ID 662 gen 100689 top level 5 path @
ID 867 gen 100634 top level 263 path .snapshots/600/snapshot
ID 868 gen 100637 top level 263 path .snapshots/601/snapshot
ID 869 gen 100641 top level 263 path .snapshots/602/snapshot
ID 870 gen 100642 top level 263 path .snapshots/603/snapshot`

I today ran sudo grub-install also to no effect, should that be worth anything.

System:
  Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=17ceaa88-b5db-494e-98cc-9c25749bf034 rw [email protected]
    quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=9aac1dcd-b6e2-4126-b1a9-56b6116f8582 loglevel=3
    mem_sleep_default=deep intel_pstate=disable ibt=off
  Desktop: sway v: 1.7 info: waybar vt: 1 dm: greetd Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9380 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0KTW76 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.16.1 date: 10/07/2021
Battery:
  ID-1: BAT0 charge: 24.3 Wh (52.1%) condition: 46.6/52.0 Wh (89.7%)
    volts: 8.3 min: 7.6 model: LGC-LGC6.73 DELL H754V8C type: Li-ion
    serial: <filter> status: charging
CPU:
  Info: model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Whiskey Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1825 high: 2001 min/max: 400/2001 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 1800 2: 1800
    3: 1801 4: 1800 5: 2001 6: 1800 7: 1800 8: 1800 bogomips: 31999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0
    chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 0c45:6723 class-ID: 0e02
  Display: wayland server: Xwayland v: 22.1.5 compositor: sway v: 1.7
    driver: gpu: i915 display-ID: 1
  Monitor-1: eDP-1 model: AU Optronics 0x5b2d built: 2018 res: 1920x1080
    hz: 60 dpi: 166 gamma: 1.2 scale: 1 size: 293x162mm (11.54x6.38")
    diag: 335mm (13.2") ratio: 16:9 modes: 1920x1080
  Message: No known Wayland EGL/GBM data sources. API: EGL/GBM
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.61 running: yes
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:003e
    class-ID: 0280 temp: 45.0 C
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
Bluetooth:
  Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3
    chip-ID: 0489:e0a2 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 138.06 GiB (28.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC401 NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 80007E00 temp: 44.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 459.83 GiB size: 459.83 GiB (100.00%)
    used: 138.01 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 54 MiB (18.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 459.83 GiB size: 459.83 GiB (100.00%)
    used: 138.01 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 459.83 GiB size: 459.83 GiB (100.00%)
    used: 138.01 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 459.83 GiB size: 459.83 GiB (100.00%)
    used: 138.01 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 15.28 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 54.0 C pch: 50.0 C mobo: 43.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
  Processes: 262 Uptime: 10m wakeups: 9 Memory: 15.28 GiB
  used: 3.31 GiB (21.7%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2188
  pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 903 libs: 191
  pm: pacman pkgs: 1261 libs: 306 tools: pamac,paru pm: appimage pkgs: 0
  pm: flatpak pkgs: 6 pm: snap pkgs: 18 Shell: fish v: 3.5.1
  running-in: alacritty inxi: 3.3.23
Garuda (2.6.10-1):
  System install date:     2021-12-08
  Last full system update: 2022-12-11
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

Sway is sway and sway doesn't show notification buttons.

sudo snapper-tools delete-old

3 Likes

If you want to see what the old snapshot is before you delete it, run:

sudo snapper-tools find-old

I had this come up on a Sway install recently as well. The old snapshot was from a restore, and Btrfs Assistant had no record of it for whatever reason--same as yours.

By the way:

You should be able to start Btrfs Assistant from the GUI launcher now. It didn't work on Sway for a while (as I see you are aware), but it was fixed back in October.

3 Likes

Hi, thanks so much for the tip around using snapper-tools. I just tried launching BTRFS Assistant from wofi and it didn't launch. If I try from the CLI:

x btrfs-assistant-launcher
Authorization required, but no authorization protocol specified

qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

/usr/bin/btrfs-assistant: line 42: 40746 Aborted                 (core dumped) btrfs-assistant-bin ${params}

This is despite it popping up a password prompt for elevated privileges.

1 Like

Oh that's weird. There was a typo in btrfs-assistant-launcher that was preventing it from working with Sway, but Dalto fixed it a while ago. :thinking: Perhaps only the git version is fixed at the moment.

It's an easy fix if you'd like to take a crack at it yourself--only one letter to change.

micro /usr/bin/btrfs-assistant-launcher

The first line of code should say:

if [[ -z ${SWAYSOCK} ]]; then

If yours says "SWAYLOCK" instead of "SWAYSOCK", just change the L to an S. Save the file and try launching from wofi again. :slightly_smiling_face:

1 Like

I was scratching my head because I vaguely recalled this SWAYSOCK thing, but the fix is there and the assistant still doesn't run from the launcher. Some others too, they still need sudo -E.
Actually, I used to think something did not update because I made a mess (I get some packages listed as orphans which aren't) so I was waiting to fix that before looking into the matter.

1 Like

I changed SWAYLOCK to SWAYSOCK and it didn't make a difference :frowning:

I am surprised to hear you guys say that. It is still working on both of my Sway machines, (although now that I think of it it has stopped taking the Qt theme again). I can't recall changing anything else related to getting it to work...:thinking:

1 Like

I wonder if /usr/lib/garuda/pkexec-gui btrfs-assistant works :eyes:

It works over here. :slightly_smiling_face:

Mine is launching fine from wofi though, so maybe I'm not the one to ask. :man_shrugging:

Edit:

I was thinking about this, and I realized I am exporting a bunch of environment variables in a script that runs immediately before Sway launches. It's something I set up a while ago to get Flameshot working again.

#!/bin/bash
export SDL_VIDEODRIVER=wayland
export _JAVA_AWT_WM_NONREPARENTING=1
export QT_QPA_PLATFORM=wayland
export XDG_CURRENT_DESKTOP=sway
export XDG_SESSION_DESKTOP=sway
exec sway

I started thinking maybe one or some of those variables are affecting Btrfs Assistant or the launcher, enabling them to run when it sounds like it is broken for others.

To test, I launched Sway without using the script that sets the extra variables for Flameshot, and sure enough: Btrfs Assistant no longer launches from wofi. :thinking:

/usr/lib/garuda/pkexec-gui btrfs-assistant works either way though, extra variables or not. :grinning:

1 Like

Weird, I already had all those variables with the same values, but the btrfs-assistant still does not run from the launcher. I don't remember if I set them somewhere or not.
I also saved that script as runsway.sh, owner root and executable, and used it as the greeter command, just in case. No change.

/usr/lib/garuda/pkexec-gui btrfs-assistant works, but unlike sudo -E btrfs-assistant-bin results in default light colors (likely because there is no configuration for the root user).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.