Okay so EFI is broken or what?

System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
    systemd.show_status=1 ibt=off driver=free nouveau.modeset=1
    i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Apple product: MacBookAir7,1 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-9F18E312C5C2BF0B
    serial: <superuser required>
  Mobo: Apple model: Mac-9F18E312C5C2BF0B v: MacBookAir7,1
    serial: <superuser required> UEFI: Apple v: 476.0.0.0.0 date: 09/06/2022
Battery:
  ID-1: BAT0 charge: 34.7 Wh (99.4%) condition: 34.9/38.8 Wh (90.0%)
    volts: 8.5 min: 7.6 model: SMP bq20z451 type: Li-ion serial: N/A
    status: full cycles: 354
CPU:
  Info: model: Intel Core i5-5250U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 757 high: 866 min/max: 500/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 845 2: 500 3: 866
    4: 819 bogomips: 12801
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1626
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: Apple Color LCD built: 2011 res: 1366x768 hz: 60
    dpi: 136 gamma: 1.2 size: 256x144mm (10.08x5.67") diag: 294mm (11.6")
    ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 6000 (BDW GT3) v: 4.6 Mesa
    22.2.1 direct render: Yes
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
    driver: bcma-pci-bridge v: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF-ID-1: enp0s20u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
  Device-1: T & A Mobile Phones A509DL type: USB driver: rndis_host v: kernel
    bus-ID: 1-2:5 chip-ID: 1bbb:0173 class-ID: 0a00 serial: <filter>
  Device-2: Apple Bluetooth USB Host Controller type: USB driver: btusb
    v: 0.8 bus-ID: 1-3.3:10 chip-ID: 05ac:828f class-ID: fe01
  Report: ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 120.24 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SD0128F
    size: 113 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 821 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 7.24 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1.01 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  Message: No partition data found.
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.73 GiB used: 854.8 MiB (22.4%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 68.0 C pch: 72.5 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 188 Uptime: 46m wakeups: 2 Memory: 3.73 GiB used: 2.81 GiB
  (75.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1176 libs: 303
  tools: octopi,paru Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
  System install date:     2022-10-25
  Last full system update: 2022-10-25 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service 

===================================================

i try over and over to install this on this mac 2015 and getting no luck,

the EFI fails to install

from what i see
i have more then 1 options in my EFI that is full or something but i can't remove it at all
i have a lot of list in my efi bootmgr

sudo efibootmgr -b 0001 -B
Could not delete variable: Invalid argument

Installing for x86_64-efi platform.

Could not prepare Boot variable: Invalid argument

grub-install: error: efibootmgr failed to register the boot entry: Input/output error.
no info at all about it

======================================

info: NAME FSTYPE FSVER LABEL        UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                           0   100% /run/miso/sfs/livefs
loop1
squash 4.0                                                           0   100% /run/miso/sfs/mhwdfs
loop2
squash 4.0                                                           0   100% /run/miso/sfs/desktopfs
loop3
squash 4.0                                                           0   100% /run/miso/sfs/rootfs
sda
├─sda1
│    vfat   FAT32              6A9A-66C9                             299.1M     0% /tmp/calamares-root-quw7x2ir/boot/efi
├─sda2
│    btrfs                     4edbb6d4-6e16-424c-bfc7-67b1d4fd8572   96.7G     6% /tmp/calamares-root-quw7x2ir/var/tmp
│                                                                                  /tmp/calamares-root-quw7x2ir/var/log
│                                                                                  /tmp/calamares-root-quw7x2ir/var/cache
│                                                                                  /tmp/calamares-root-quw7x2ir/srv
│                                                                                  /tmp/calamares-root-quw7x2ir/root
│                                                                                  /tmp/calamares-root-quw7x2ir/home
│                                                                                  /tmp/calamares-root-quw7x2i
│                                                                                  r
└─sda3
swap   1     swap         9d9744e3-06c9-4d1f-95d4-0ca68aa98a9d
sdb  iso966 Jolie GARUDA_DR460NIZED_TALON
2022-10-19-02-24-22-00                     0   100% /run/miso/bootmnt
├─sdb1
│    iso966 Jolie GARUDA_DR460NIZED_TALON
│                              2022-10-19-02-24-22-00
└─sdb2
vfat   FAT12 MISO_EFI     E328-6EBB
zram0

this is the installer error now: The bootloader could not be installed. The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
returned error code 1.

does not tell me why

1 Like

Are you doing a full wipe/install, or are you trying to save what is on the EFI partition and set up a dual-boot?

1 Like

its a full/wipe from mac air 2015, and its non-dual booting...
the EFI does not want to install at all and when the installer hits 97% i get this
The bootloader could not be installed. The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
returned error code 1.

Try to reformat the disk from parted or Gparted in the live environment, and see if you get any errors or additional clues as to what is wrong. If the reformat goes fine, try the installation again.

3 Likes

i did, its the same issue, as for formatting no errors shows up, its the installer part that fails for odd reasons.. as for Gpart it wont even let me install it from liveOS, (USB) i have to use like KDE and now sure why that is

Have you gone through your BIOS settings?

  • Disable fast boot
  • Disable secure boot
  • Set to UEFI only
  • SATA controller is set to AHCI mode
2 Likes

its a mac intel 2015 there no bios at all, garuda linux was working up to the point when i had to switch back to mac osx and update its firmware, but even that, the other Linux (biglinux) is working just fine on the installer, so idk whats the issue

yep even with gParted i still get this error: The bootloader could not be installed. The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
returned error code 1.

okay so, i had to use Garuda KDE Gaming, which works fine lol.. but the main one does not so.. am on the gamer now and seems fine..

I'm glad you got it working, but I have to say that is a very puzzling result. I wonder what the difference is between the two ISOs that made it work? :thinking:

1 Like

I Have the same issue with my MacPro 5.1.
I am using Garuda from month without any issues. A few days ago problems begins at boot.
Then i restored snapshot, i was working then after reboot block again at startup.

So i decided to wipe the dedicated SSD and reinstall Garuda.

As it's a MacPro, there is no bios menu to change settings.

I've try Garuda KDE and Gaming edition maybe 10 times. Same issue with both distribution :

Bootloader installation error
Details:
The bootloader could not be installed. The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
returned error code 1.

Then i try this morning to install Manjaro KDE to see if it's on my computer. No issue at all to install it.

Then i tried again with Garuda KDE but issue persist.

fdisk -l
fdisk: cannot open /dev/sdb: Permission denied
fdisk: cannot open /dev/sda: Permission denied
fdisk: cannot open /dev/sdc: Permission denied
fdisk: cannot open /dev/loop0: Permission denied
fdisk: cannot open /dev/loop1: Permission denied
fdisk: cannot open /dev/loop2: Permission denied
fdisk: cannot open /dev/loop3: Permission denied
fdisk: cannot open /dev/zram0: Permission denied
McFly: Importing shell history for the first time. This may take a minute or two...done.

lsblk -o name,type,fstype,size,uuid,mountpoint
NAME   TYPE FSTYPE     SIZE UUID                                 MOUNTPOINT
loop0  loop squashfs  15.6M                                      /run/miso/sfs/livefs
loop1  loop squashfs 429.4M                                      /run/miso/sfs/mhwdfs
loop2  loop squashfs   1.1G                                      /run/miso/sfs/desktopfs
loop3  loop squashfs   680M                                      /run/miso/sfs/rootfs
sda    disk          931.5G
├─sda1 part vfat       200M 67E3-17ED
└─sda2 part apfs     931.3G 49ce2d10-2ddd-4275-9b75-f3f225ec4c55
sdb    disk          465.8G
├─sdb1 part vfat       300M D28F-0217                            /tmp/calamares-root-d_th6rzt/boot/efi
├─sdb2 part btrfs    452.6G 0e13d8d4-b944-4929-b12a-9f1e1b113e9f /tmp/calamares-root-d_th6rzt/var/tmp
└─sdb3 part swap      12.8G 11a10bff-aefc-48d4-a808-119cf3e5befc
sdc    disk iso9660   57.3G 2022-10-19-02-24-22-00               /run/miso/bootmnt
├─sdc1 part iso9660    2.4G 2022-10-19-02-24-22-00
└─sdc2 part vfat         4M E328-6EBB
zram0  disk           11.7G                                      [SWAP]

Do you think the issue is inside the ISO? As it was working perfectly before.

I was using garuda-dr460nized-linux-zen-221019.so

Let's try with the latest version I found : garuda-dr460nized-linux-zen-221028.iso from Garuda Linux ISO Builds.

Not working - installation don't start :
Calamari could not load modules [email protected]

I'll try garuda-dr460nized-gaming-linux-zen-220909.iso to see

I had the exact same issue with Garuda Gnome 221019 on a MacBook Pro 10,2.

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force

returned error code 1.

Installing Garuda Gnome from the 220808 ISO works normally.

Thank you for your reply @RockyC
By my side installation was successful with garuda-dr460nized-gaming-linux-zen-220909.iso and any bootloader issues.

Now i am fighting with Nvidia drivers who block the system boot after installation.
Hopefully, snapshots help a lot!

I did not have theses kind of issues on my previous installation on the same system.
It seems that something is broken with Mac Hardware.

FYI

https://mirrors.fossho.st/garuda/iso/garuda/gnome/221026/

1 Like

I'm just glad that I didn't erase my old Ventoy USB. I don't have nvidia graphics on my MBP, thankfully, but I did notice that my Broadcom 4360 Wi-Fi card doesn't have a kernel driver in Linux 6.0, so I am at this very moment building linux-zen-515lts.

I am facing the exact same problem.

Also on a Macbook Pro (A1278) from 2015 with garuda-dr460nized-linux-zen-221019.iso.

The search for a solution has brought me here. Unfortunately I can't find version 220909 to download (anymore) otherwise I would have tried it with that.

However, what I figured out is that it has to do with efibootmgr. I tried to create the entry in the NVRAM with efibootmgr but it always comes up with the error message: Could not prepare Boot variable: Invalid argument.

It doesn't matter what parameters I give to efibootmgr it always returns an error message. The only thing I could do with efibootmgr was to delete entries, but it was impossible to change or create an entry. I also tried with the previous version of efibootmgr because my suspicion was that the 220909 might still be using version 17 but I can't get anywhere with the older version either.

Maybe someone has a download link for me on a dr460nized 220909? I could not find a working one as I said and is there someone from the garuda team who is looking into the problem?

Yes :muscle: I made it.
As said before, the problem is that efibootmgr of Garuda Linux is not able to configure the UEFI NVRAM entry.

However, this does not necessarily have to be done via the Garudu Linux.

So I put a Debian Live System on a USB stick and booted from it. From there I made the NVRAM entry with the efibootmgr which worked right away and it also booted the grub boot loader. Since grub was not configured yet, I put the Garuda USB stick again to fix the boot mananger configuration and now the Macbook Pro boots the Garuda Dragonized 221019.
:muscle: :man_dancing: :1st_place_medal: :blush:

2 Likes