Odd transparency issue on Garuda installer

This is a very minor issue and I only noticed it because I got a new mini PC. It’s possible it could also just be my hardware… ^^;
Sorry if this is the wrong section btw - feel free to move it if it’s not correct.

I’m trying to install Qtile, and during the installation process, I noticed that the background on one of the screens (windows?) was completely transparent, making the text quite hard to read in some areas.

Is it possible that Picom is the issue here, as there’s no blur in any transparent windows? I remember back on my XPS 15 when I originally installed Qtile on it, it came with a version of Picom that no longer exists in the AUR. picom-libvaughan-git or something like that.
I think since the rest of the installer has an opaque background though, it should be left opaque all the way through… :thinking:

I tried on both the open source and proprietary NVIDIA drivers, but that obviously had no effect because there’s no NVIDIA in this PC (yet) :rofl: - I’m gonna chuck an RTX 4060 eGPU on it once I get the adapter and PSU.

The ISO this happened on is garuda-qtile-linux-zen-231029.iso.

garuda-inxifrom live ISO:

  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda root=miso:LABEL=GARUDA_QTILE_RAPTOR quiet
    systemd.show_status=1 ibt=off systemd.unified_cgroup_hierarchy=1
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: Qtile v: 0.23.0 wm: LG3D vt: 2 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Mini-pc System: Micro (HK) Tech product: Venus series v: N/A
    serial: <superuser required>
  Mobo: Shenzhen Meigao Equipment model: F7BSC serial: <superuser required>
    UEFI: American Megatrends LLC. v: 1.07 date: 09/01/2023
  Info: model: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics bits: 64
    type: MT MCP arch: Zen 4 gen: 5 level: v4 note: check built: 2022+
    process: TSMC n5 (5nm) family: 0x19 (25) model-id: 0x74 (116) stepping: 1
    microcode: 0xA704103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 469 high: 1505
    min/max: 400/5263:6228:5583:5743:5423:5903:6067 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400
    14: 400 15: 1505 16: 400 bogomips: 127747
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Phoenix1 driver: amdgpu v: kernel arch: RDNA-3 code: Phoenix
    process: TSMC n4 (4nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, DP-6, DP-7,
    HDMI-A-2 bus-ID: c4:00.0 chip-ID: 1002:15bf class-ID: 0300 temp: 36.0 C
  Display: x11 server: X.Org v: 21.1.9 compositor: Picom v: git-b700a
    driver: X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Dell P2423D serial: <filter>
    built: 2023 res: 2560x1440 hz: 60 dpi: 123 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV GFX1103_R1) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:15bf surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: c4:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_ps
    v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: c4:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: c4:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE driver: r8169 v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: f000 bus-ID: 01:00.0 chip-ID: 10ec:8125
    class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
    driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:6 chip-ID: 8087:0032
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
    lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 1.04 TiB used: 3.4 GiB (0.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PGP41024Q-A0
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: ELFK0S.6 temp: 33.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: Ultra USB 3.0
    size: 114.56 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 60.54 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 39.5 C mobo: N/A gpu: amdgpu temp: 37.0 C
  Fan Speeds (rpm): N/A
  Processes: 370 Uptime: 14m wakeups: 2 Memory: total: 60 GiB note: est.
  available: 60.54 GiB used: 3.56 GiB (5.9%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1144 libs: 345 tools: paru Shell: fish v: 3.6.1
  running-in: alacritty inxi: 3.3.30
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
  System install date:     2024-01-05
  Last full system update: 2024-01-05 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            snapper-cleanup.service

Hmm, I have seen that before actually. If you are willing to test, try opening Kvantum Manager and edit the active theme. See if you can find a transparency attribute that has been enabled which causes the issue. If you can figure out what it is, I’ll put in a merge request to change that attribute.


Hmm… I toggled all the transparency attributes available and even added garuda-welcome to the opaque apps list, but those areas still stayed completely transparent. :thinking:
Solid Kvantum themes also have the same thing happening - sure there’s no translucency but the area is still 100% transparent.

I’m dealing with some Windows dual boot shenanigans so I’m happy to continue trying other ideas :+1:


Oh gotcha…maybe it’s not Kvantum at all; the reason I thought of that is because at some point Sway had a similar thing happening in Calamares (though not quite so dramatic as that screenshot) and I fixed it by removing the transparency from Kvantum.

Same thing if you change the Kvantum theme altogether?

If you launch Calamares from the command line with the pkexec wrapper, does it still have the issue?

/usr/lib/garuda/pkexec-gui calamares

Haha no problem :slight_smile:
In this case, it doesn’t seem related to Kvantum - I tried several themes and the issue was still present.

Using that command, the transparent areas are no longer there :partying_face: but Calamares then ignores the theme altogether.

Can you post this output from the live environment?

MANPAGER=sh -c 'col -bx | bat -l man -p'

Sorry for the delay, was busy getting things set up again ^^;

About this:

It turns out that Picom does have those features in picom, but the problem is that the autostart script includes --experimental-backends which causes blur and rounded corners not to work. I’ll see if I can submit a PR for that.

edit: done.

Fixes Alacritty’s warning about .yaml file deprecation too. Feel free to snatch that and use in any other spins that use Alacritty :slight_smile:


Looks good to me. @RohitSingh can you take a look when you have a chance?

This topic was automatically closed after 14 days. New replies are no longer allowed.