Octopi: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory

Kernel: 6.7.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=55b68260-2ead-4148-8082-c0342f4e45ea rw rootflags=subvol=@
quiet resume=UUID=4547ab99-b3de-437e-a817-32b08372f1eb loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A16 FA617XT_FA617XT
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FA617XT v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: FA617XT.309
date: 05/02/2023
Battery:
ID-1: BAT0 charge: 54.6 Wh (62.0%) condition: 88.1/90.0 Wh (97.9%)
power: 24.6 W volts: 15.2 min: 15.9 model: AS3GWYF3KC GA50358 type: Unknown
serial: <filter> status: discharging
CPU:
Info: model: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics bits: 64
type: MT MCP arch: Zen 4 gen: 5 level: v4 note: check built: 2022+
process: TSMC n5 (5nm) family: 0x19 (25) model-id: 0x74 (116) stepping: 1
microcode: 0xA704103
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 618 high: 3900
min/max: 400/5423:6228:6067:5903:5743:5263:5583 scaling:
driver: amd-pstate-epp governor: performance cores: 1: 400 2: 400 3: 3900
4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400
14: 400 15: 400 16: 400 bogomips: 127755
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600]
vendor: ASUSTeK driver: amdgpu v: kernel arch: RDNA-3 code: Navi-33
built: 2023+ pcie: gen: 4 speed: 16 GT/s lanes: 8 ports: active: none
empty: DP-1,HDMI-A-1,eDP-1 bus-ID: 03:00.0 chip-ID: 1002:7480
class-ID: 0300
Device-2: AMD Phoenix1 vendor: ASUSTeK driver: amdgpu v: kernel
arch: RDNA-3 code: Phoenix process: TSMC n4 (4nm) built: 2023+ pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: eDP-2 empty: DP-2, DP-3, DP-4,
DP-5, DP-6, DP-7, DP-8, DP-9 bus-ID: 68:00.0 chip-ID: 1002:15bf
class-ID: 0300 temp: 39.0 C
Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:2 chip-ID: 2b7e:b685
class-ID: 0e02
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu,amdgpu display-ID: 0
Monitor-1: eDP-2 res: 1707x1067 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: radeonsi device: 2 drv: swrast surfaceless: drv: radeonsi
wayland: drv: radeonsi x11: drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
gfx1103_r1 LLVM 17.0.6 DRM 3.57 6.7.9-zen1-1-zen) device-ID: 1002:15bf
memory: 500 MiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 9 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV GFX1103_R1) driver: mesa radv v: 24.0.3-arch1.1
device-ID: 1002:15bf surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: AMD Radeon RX 7700S (RADV NAVI33)
driver: mesa radv v: 24.0.3-arch1.1 device-ID: 1002:7480
surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.3-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Navi 31 HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 03:00.1
chip-ID: 1002:ab30 class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 68:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: snd_pci_ps v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 68:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 68:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network
vendor: AzureWave driver: rtw89_8852be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0 chip-ID: 10ec:b852
class-ID: 0280
IF: wlp6s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
rev: 1.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1:2 chip-ID: 13d3:3571
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
Local Storage: total: 2.75 TiB used: 20.78 GiB (0.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Western Digital
model: WD BLACK SN770 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 731100WD temp: 52.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN560 SDDPNQE-1T00-1002 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 74104000 temp: 49.9 C scheme: GPT
Partition:
ID-1: / raw-size: 901.13 GiB size: 901.13 GiB (100.00%)
used: 17.91 GiB (2.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:4
ID-2: /boot/efi raw-size: 3.91 GiB size: 3.9 GiB (99.80%)
used: 584 KiB (0.0%) fs: vfat dev: /dev/nvme1n1p2 maj-min: 259:3
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 2.87 GiB (0.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:5
ID-4: /var/log raw-size: 901.13 GiB size: 901.13 GiB (100.00%)
used: 17.91 GiB (2.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:4
ID-5: /var/tmp raw-size: 901.13 GiB size: 901.13 GiB (100.00%)
used: 17.91 GiB (2.0%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 14.84 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
ID-2: swap-2 type: partition size: 48.83 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p1 maj-min: 259:2
Sensors:
System Temperatures: cpu: 47.4 C mobo: N/A
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 39.0 C watts: 18.10 device: amdgpu temp: 46.0 C
mem: 52.0 C fan: 0 watts: 17.00
Info:
Memory: total: 16 GiB note: est. available: 14.85 GiB used: 4.66 GiB (31.4%)
Processes: 428 Power: uptime: 1h 22m states: freeze,mem,disk
suspend: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 5.93 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1921 pm: pacman pkgs: 1910 libs: 544 tools: octopi,paru
pm: flatpak pkgs: 11 Compilers: gcc: 13.2.1 Shell: garuda-inxi default: fish
v: 3.7.0 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-03-11
Last full system update: 2024-03-15 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

My first time posting, hopefully im doing this right by posting the inxi, so yeah I cant get octopi to run as it seems the dependency version 13 is missing, but that seems to be due to having version 14 installed currently (pacman -Qi libalpm.so) is how i found that out. I’ve only ever updated packages via garuda-update, I did use the garuda assistant to remove orphans and clear package cache and and caches after i tried removing waydroid to try and clean things up. It did still leave some waydroid files behind i had to go and cleanup by hand, not sure if this is related though, also, i am currently as of writing this, fully updated via garuda update. And yes, i spent a good 45 minutes investigating the internet and the forums, but im assuming the creator of octopi has to update package or build against the newer dependency, but idk, im an ex windows 10 user trying to jump ship with an open mind.

Any help or reassurance is appreciated. In retrospect, now I understand why everyone says to learn terminal, if your GUI pkg manager breaks you gotta be able to use the terminal in the meantime.

1 Like

Looks like you aren’t the only one with this issue: AUR (en) - octopi

Exactly this. As the update to pacman itself has been causing issues with packages requiring libalpm and haven’t yet built against the new version.
You can see it causing other related issues here:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.