Occasional Freezing

Hey guys! TIll now i am imprerss by garuda linux i still am but there is a wierd bug which makes all windows freeze my cursours keep moving ut every window freezes the keyboard's caps etc keys also turn on normally when pressed if the pc is freeezed

System:    Kernel: 5.12.11-168-tkg-bmq x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq  
root=UUID=5406c160-0b2d-4bc1-8be7-96508b47db1c rw rootflags=subvol=@ splash quiet
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: LENOVO product: 80TJ v: Lenovo ideapad 110-15ACL serial: <filter> Chassis:  
type: 10 v: Lenovo ideapad 110-15ACL serial: <filter>  
Mobo: LENOVO model: Nano 5A8 v: SDK0J40679 WIN serial: <filter> UEFI: Lenovo v: 1QCN32WW  
date: 08/18/2016  
Battery:   ID-1: BATT charge: 1.9 Wh (32.2%) condition: 5.9/23.8 Wh (25.0%) volts: 11.7 min: 10.8  
model: LENOVO LCFC type: Unknown serial: <filter> status: Charging  
CPU:       Info: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics bits: 64 type: MCP  
arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 microcode: 7030105 cache: L2: 2 MiB  
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 17587  
Speed: 2340 MHz min/max: 1000/2200 MHz boost: enabled Core speeds (MHz): 1: 2340 2: 2321  
3: 2327 4: 2302  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo driver: radeon v: kernel  
alternate: amdgpu bus-ID: 00:01.0 chip-ID: 1002:9851 class-ID: 0300  
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile]  
vendor: Lenovo driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0 chip-ID: 1002:6660  
class-ID: 0380  
Device-3: IMC Networks EasyCamera type: USB driver: uvcvideo bus-ID: 2-1.2:4 chip-ID: 13d3:a745  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: ati,radeon  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")  
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")  
OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.12.11-168-tkg-bmq LLVM 12.0.0) v: 4.5 Mesa 21.1.2  
direct render: Yes  
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel v: kernel  
bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403  
Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:14.2  
chip-ID: 1022:780d class-ID: 0403  
Sound Server-1: ALSA v: k5.12.11-168-tkg-bmq running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: no  
Sound Server-4: PipeWire v: 0.3.30 running: yes  
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo  
driver: ath10k_pci v: kernel port: 2000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280  
IF: wlp2s0 state: up mac: <filter>  
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo driver: r8169 v: kernel  
port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200  
IF: enp3s0 state: down mac: <filter>  
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 2-1.1:3 chip-ID: 0cf3:e360  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>  
Drives:    Local Storage: total: 223.58 GiB used: 39.91 GiB (17.9%)  
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDS240G2G0A-00JH30 size: 223.58 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter>
rev: 0000 scheme: GPT
Partition: ID-1: / raw-size: 74.98 GiB size: 74.98 GiB (100.00%) used: 39.88 GiB (53.2%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 36.2 MiB (7.1%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 74.98 GiB size: 74.98 GiB (100.00%) used: 39.88 GiB (53.2%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 74.98 GiB size: 74.98 GiB (100.00%) used: 39.88 GiB (53.2%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 74.98 GiB size: 74.98 GiB (100.00%) used: 39.88 GiB (53.2%) fs: btrfs
dev: /dev/sda4 maj-min: 8:4
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.67 GiB used: 19.8 MiB (1.2%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.67 GiB used: 19.8 MiB (1.2%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.67 GiB used: 19.8 MiB (1.2%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.67 GiB used: 19.8 MiB (1.2%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 70.9 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: radeon temp: 71.0 C device: radeon temp: 50.0 C
Info:      Processes: 253 Uptime: 26m wakeups: 1 Memory: 6.69 GiB used: 4.43 GiB (66.2%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1400 lib: 346
Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.04

Output of my inxi, This is getting really frustrating now

First thing to do is always test at least 4 alternate kernels when experiencing any type of freezes.

Search the forum with the terms "test alternate kernels" for the most often recommended versions to test.

6 Likes

What tbg said first.
I feel to give you another advice. As you are using a laptop and I see your CPU temperature is a bit high, I strongly recommend you to follow this guide:

High CPU temperature can be an issue related to system freezing.

3 Likes

And what about a BIOS update? Your last installed one is 2016.

(This suggestion may or may not be important but it cannot be ignored.)

regards

3 Likes

That was the last update my company provided sadly even tho i bought it in 2015

1 Like

I have followed this, this temps are regular for me

1 Like

Have you tested with the linux-lts kernel? You can install it with Garuda Settings Manager.

I do have it installed but this prob is sporadic hasnt happened for the past hour, I am not trying to use linux lts cuz pc gets real slow when i am doing some coding and have dsicord open

What is the output of cat /proc/sys/vm/swappiness?

1 Like
File: /proc/sys/vm/swappiness
10

You may want to try running sudo sysctl vm.swappiness=60 and see if that helps.

3 Likes

No need to reboot for this to work. Keep in mind that the setting will be reset after rebooting.

1 Like

Why don't you try using amdgpu.
I think it's better.

4 Likes

The computer manufacturer (Dell, Lenovo, etc.) is who releases BIOS updates. You have a Lenovo Ideapad so go to Lenovo's website, click on Support, find the make & model of your laptop, and search for updates.

2 Likes

I am well aware, the last bios update was in 2016 which I updated

1 Like

sorry? Use the dgpu u mean? how would i do that

That definitely helped, What is swappiness? the swap file?

No, sorry, I just meant to change the driver for your current GPU.
I think the easiest way to do it should be via the relevant Garuda Assistant tool (Hardware)

1 Like

I am in the garuda assistant i dont see Hardware option

Sorry, I'm not on the PC today, only on mobile.
Maybe there is something in settings manager -> Hardware, but I don't remember by heart
If there is nothing there, I just found a good procedure via a quick search:
https://bbs.archlinux.org/viewtopic.php?id=267208
Or even better:
https://wiki.archlinux.org/title/AMDGPU#Selecting_the_right_driver
Since your amdgpu driver seems to be already available, most likely it is only a matter of:
Make sure amdgpu has been set as first module in the Mkinitcpio#MODULES array, e.g. MODULES=(amdgpu radeon) and
sudo mkinitcpio -P

2 Likes

This is what i have right now

MODULES=(intel_agp i915 amdgpu radeon nouveau)

Why is there an intel there I don't have anything related to intel not the gpu or the cpu all amd

Edit - Never mind intel_agp is the driver for the port which is designed for gpu's by intel Source