OBS Studio Keine Sound Aufnahme möglich

Hallo liebe Community.

Ich hab folgendes Problem. Mein OBS Studio kann keinen Desktop Sound Aufnehmen. Also der Desktop Sound kommt erst gar nicht an ,in OBS Studio. Ich habe erst das Originale OBS Studio Ausprobiert und dann eins vom Arch und beide bekommen keinen Sound vom Desktop in OBS.

Die Sound Einstellungen sind auch alle richtig gesetzt. Eigentlich sollte alles ohne Probleme Funktionieren.

Ich habe einem Freund Bescheid gegeben, der er auch mal gucken soll ob sein OBS Studio den Sound aufnimmt und das tut es auch nicht. ( Ist auch auf Garuda Linux)

Ich habe extra noch Garuda Linux als VM Aufgesetzt und es dann nochmal Kontrolliert und es geht immer noch nicht.

Extra habe ich auch noch einmal Manjaro Linux getestet und da Läuft es ohne Probleme.

Ich hoffe ihr habt eine Lösung für mich.

Hier noch ein paar Daten vom PC

Betriebssystem: Garuda Linux

KDE-Plasma-Version: 5.23.3

KDE-Frameworks-Version: 5.88.0

Qt-Version: 5.15.2

Kernel-Version: 5.15.2-zen1-1-zen (64-bit)

Grafik-Plattform: X11

Prozessoren: 32 × AMD Ryzen 9 3950X 16-Core Processor

Speicher: 23,5 GiB Arbeitsspeicher

Grafikprozessor: NVIDIA GeForce RTX 2080/PCIe/SSE2

OBS Studio Varriante 1: https://obsproject.com/

OBS Studio Tytan652 Variante 2: AUR (en) - obs-studio-tytan652

Hier noch ein Video dazu: NextCloudPi

Ich danke allen für die Hilfe.

Da gibt es dann immer noch drei Möglichkeiten?
unstable, stable und noch etwas, vergessen :smiley:

Warum postest du nicht einfach dein inxi -Faz, wie im template gefordert?
Bitte nachholen.

Starte OBS vom Terminal um eventuelle Fehlermeldungen zu erhalten.

1 Like

Sorry. Also es war Manjaro Linux Stable.

OBS Studio output

Icon theme "gnome" not found.
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/locale/de-DE.ini
Attempted path: /usr/share/obs/obs-studio/locale/de-DE.ini
info: Using preferred locale 'de-DE'
Attempted path: share/obs/obs-studio/themes/Dark.qss
Attempted path: /usr/share/obs/obs-studio/themes/Dark.qss
info: CPU Name: AMD Ryzen 9 3950X 16-Core Processor
info: CPU Speed: 4032.630MHz
info: Physical Cores: 16, Logical Cores: 32
info: Physical Memory: 24021MB Total, 7184MB Free
info: Kernel Version: Linux 5.15.2-zen1-1-zen
info: Distribution: "Garuda Linux" Unknown
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.21.1
info: Portable mode: false
Attempted path: share/obs/obs-studio/themes/Dark/no_sources.svg
Attempted path: /usr/share/obs/obs-studio/themes/Dark/no_sources.svg
QMetaObject::connectSlotsByName: No matching signal for on_tbar_position_valueChanged(int)
QMetaObject::connectSlotsByName: No matching signal for on_actionShowTransitionProperties_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_actionHideTransitionProperties_triggered()
info: OBS 27.1.3-tytan652-6 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
samples per sec: 48000
speakers:        2
info: ---------------------------------
info: Initializing OpenGL...
info: Loading up OpenGL on adapter NVIDIA Corporation NVIDIA GeForce RTX 2080/PCIe/SSE2
info: OpenGL loaded successfully, version 3.3.0 NVIDIA 495.44, shading language 3.30 NVIDIA via Cg compiler
info: ---------------------------------
info: video settings reset:
base resolution:   1920x1080
output resolution: 1280x720
downscale filter:  Bicubic
fps:               30/1
format:            NV12
YUV mode:          709/Partial
info: NV12 texture support not available
info: Audio monitoring device:
name: Standard
id: default
info: ---------------------------------
warning: Failed to load 'en-US' text for module: 'decklink-captions.so'
warning: Failed to load 'en-US' text for module: 'decklink-ouput-ui.so'
libDeckLinkAPI.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
warning: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
info: No blackmagic support
warning: v4l2loopback not installed, virtual camera disabled
info: [obs-browser]: Version 2.16.3
info: [obs-browser]: CEF Version 87.1.14+ga29e9a3+chromium-87.0.4280.141
info: NVENC supported
info: FFMPEG VAAPI supported
info: VLC found, VLC video source enabled
info: ---------------------------------
info:   Loaded Modules:
info:     vlc-video.so
info:     text-freetype2.so
info:     sndio.so
info:     rtmp-services.so
info:     obs-x264.so
info:     obs-vst.so
info:     obs-transitions.so
info:     obs-outputs.so
info:     obs-libfdk.so
info:     obs-filters.so
info:     obs-ffmpeg.so
info:     obs-browser.so
info:     linux-v4l2.so
info:     linux-pulseaudio.so
info:     linux-jack.so
info:     linux-decklink.so
info:     linux-capture.so
info:     linux-alsa.so
info:     image-source.so
info:     frontend-tools.so
info:     decklink-ouput-ui.so
info:     decklink-captions.so
info: ---------------------------------
info: ==== Startup complete ===============================================
info: All scene data cleared
info: ------------------------------------------------
info: pulse-input: Server name: 'PulseAudio (on PipeWire 0.3.40) 15.0.0'
info: pulse-input: Audio format: s16le, 48000 Hz, 2 channels
info: pulse-input: Started recording from 'alsa_output.usb-Kingston_HyperX_Virtual_Surround_Sound_00000000-00.analog-stereo.monitor'
info: [Loaded global audio device]: 'Desktop-Audio'
info: pulse-input: Server name: 'PulseAudio (on PipeWire 0.3.40) 15.0.0'
info: pulse-input: Audio format: s16le, 48000 Hz, 2 channels
info: pulse-input: Started recording from 'alsa_input.usb-Kingston_HyperX_Quadcast_4110-00.analog-stereo'
info: [Loaded global audio device]: 'Mikrofon-/AUX-Audio'
info: xshm-input: Geometry 1920x1080 @ 1920,0
info: Switched to scene 'Szene'
info: ------------------------------------------------
info: Loaded scenes:
info: - scene 'Szene':
info:     - source: 'Bildschirmaufnahme (XSHM)' (xshm_input)
info: ------------------------------------------------
Attempted path: share/obs/obs-studio/images/overflow.png
Attempted path: /usr/share/obs/obs-studio/images/overflow.png
info: adding 21 milliseconds of audio buffering, total audio buffering is now 21 milliseconds (source: Desktop-Audio)

info: adding 64 milliseconds of audio buffering, total audio buffering is now 85 milliseconds (source: Mikrofon-/AUX-Audio)

Stable hält updates zurück, wenn es auch mit unstable = stable arch (Garuda) funktioniert bräuchten wir das OBS log vom terminal, ahh ja, pulse audio, könnte daran liegen, das Garuda auf pipewire umgestiegen ist.

Wir bräuchten die Ein- und Ausgabe von inxi -Faz, nicht nur

If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.

Kannst du eventuell auch mal mit unstable und dem anderen testen?

Ansonsten suche hier im Forum nach pipewire pulsaudio und lies ggf. auch

inxi -Faz

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=6272bc55-6684-4922-ad75-1c6b39958a53
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: Micro-Star product: MS-7B86 v: 1.0 serial: <filter>
Mobo: Micro-Star model: B450 GAMING PLUS (MS-7B86) v: 1.0 serial: <filter>
UEFI: American Megatrends LLC. v: 1.H4 date: 10/08/2021
CPU:       Info: 16-Core (2-Die) model: AMD Ryzen 9 3950X bits: 64 type: MT MCP MCM arch: Zen 2
family: 17 (23) model-id: 71 (113) stepping: 0 microcode: 8701021 cache: L2: 8 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 223983
Speed: 4129 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz): 1: 4129 2: 4206
3: 3443 4: 4102 5: 3936 6: 3467 7: 4067 8: 4283 9: 4074 10: 4300 11: 3853 12: 3686 13: 3788
14: 3633 15: 3534 16: 3869 17: 3586 18: 4288 19: 3647 20: 3329 21: 3774 22: 3850 23: 3690
24: 3691 25: 4114 26: 3685 27: 3952 28: 4289 29: 3990 30: 3601 31: 3603 32: 3497
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 Rev. A] vendor: ZOTAC driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 29:00.0 chip-ID: 10de:1e87 class-ID: 0300
Device-2: AVerMedia AVerMedia USB Device type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 4-2:105 chip-ID: 07ca:0570 class-ID: 0102 serial: <filter>
Device-3: Logitech StreamCam type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
bus-ID: 6-2:2 chip-ID: 046d:0893 class-ID: 0300 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 81 s-size: 1204x331mm (47.4x13.0") s-diag: 1249mm (49.2")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7")
diag: 604mm (23.8")
Monitor-2: DP-3 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
OpenGL: renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus-ID: 29:00.1
chip-ID: 10de:10f8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus-ID: 2b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Kingston HyperX 7.1 Audio type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 1-8:3 chip-ID: 0951:16a4 class-ID: 0300 serial: <filter>
Device-4: AVerMedia AVerMedia USB Device type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 4-2:105 chip-ID: 07ca:0570 class-ID: 0102 serial: <filter>
Device-5: Logitech StreamCam type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
bus-ID: 6-2:2 chip-ID: 046d:0893 class-ID: 0300 serial: <filter>
Device-6: Kingston HyperX QuadCast type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 7-2:3 chip-ID: 0951:16df class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.19 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
driver: r8169 v: kernel port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 5.24 TiB used: 16.66 GiB (0.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD40EZRZ-22GXCB0 size: 3.64 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0A80 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: HD502HJ size: 465.76 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 0001
scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: DB6Q
scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital model: WDS100T2G0A-00JH30 size: 931.52 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
scheme: GPT
ID-5: /dev/sde maj-min: 8:64 type: USB vendor: SMI (STMicroelectronics) model: USB
size: 7.5 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1100
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 16.66 GiB (1.8%) fs: btrfs
dev: /dev/sdd2 maj-min: 8:50
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/sdd1 maj-min: 8:49
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 16.66 GiB (1.8%) fs: btrfs
dev: /dev/sdd2 maj-min: 8:50
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 16.66 GiB (1.8%) fs: btrfs
dev: /dev/sdd2 maj-min: 8:50
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 16.66 GiB (1.8%) fs: btrfs
dev: /dev/sdd2 maj-min: 8:50
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 23.46 GiB used: 4.8 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 537 Uptime: 1h 40m wakeups: 2 Memory: 23.46 GiB used: 9.12 GiB (38.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1371 lib: 429 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Sorry bin leider Linux Anfänger und hab keine Ahnung wie das ganze hier geht...

Bin aber fleißig am Üben :slight_smile:

1 Like

Was meinst du genau mit unstable ? Meinst du jetzt Manjaro oder Garuda?

Ich habe mir mal den Post angeguckt und bei mir stimmen die Pakete alle.

Garuda habe ich erst vor ein paar Tagen Installiert.

Bei uns gibt es nur stable Arch, Manjaro nennt dieses aber unstable

Stable, unstable, testing? - Paketverwaltung - Manjaro Linux Forum
archived.forum.manjaro.org › Deutsch › Paketverwaltung
](Stable, unstable, testing? - Paketverwaltung - Manjaro Linux Forum)

Hallo, wie kann ich herausfinden, ob ich stable, unstable oder testing Updates beziehe?

Also im Stable Kanal geht alles.

Im Unstable Kanal geht es auch.

Den Konsolen Input von OBS habe ich schon einmal geschickt.

Habe jetzt auch noch Heraus gefunden. Das wenn man Garuda Linux komplett neu Installiert und noch keine Updates macht. Der Sound in OBS eingespeist werden kann. Updatet man aber das System. Dann geht es nicht mehr..

Was gibt pacman -Qs wireplumber?

1 Like
local/wireplumber 0.4.5-2
Session / policy manager implementation for PipeWire

Wenn du Garuda benutzt könntest du ja mal Testen ob dein Sound in OBS geht oder Empfangen wird ?

Bin gerade nicht am PC fürs testen :smiley:
Eine Vermutung habe ich aber, könntest versuchen wireplumber mit pipewire-media-session zu wechseln :eyes:
sudo pacman -S pipewire-media-session (bestätigen & reboot)

1 Like

Ob du es glaubst oder nicht. Das habe ich gestern leider versucht an meinem Richtigen PC und nicht an der VM und leider habe ich mir dadurch alles Zerschossen. Der hat anscheinend noch andere Pakete Gelöscht und die Grafiken und alles andere war weg. Habe dann den PC Neu Gestartet und konnte mich sogar nicht mehr anmelden.

Ich weiß jetzt ehrlich nicht ob ich den Befehl Ausführen sollte :confused:

Wenn das genau so passiert ist wie beschrieben ist vermutlich was anderes echt nicht in Ordnung :sweat_smile: auf jeden Fall sichergehen, dass Pacman keine benötigen Pakete entfernt! Das wird auch vorher extra nochmal zum bestätigen angezeigt :thinking:

1 Like

OK jetzt geht es!

Der Befehl hat auch ohne Probleme geklappt und wo liegt jetzt der Fehler? :smiley:

Aber danke schonmal <3

1 Like

Wireplumber scheinte bei einigen Nutzern nicht zu 100% zu funktionieren, weshalb das auf jeden Fall etwas zum Ausprobieren ist :eyes:

2 Likes

PEBKAC :wink: :sunglasses:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.