Obs Flatpak won't run after latest Garuda dragonized update

Hello.
I used obs studio trough flatpak since the pacman version is missing features that I need.
I updated my system yesterday, before it obs ran fine but now it will crash on opening with this error message:

Failed to initialize video.  Your GPU may not be supported, or your graphics drivers may need to be updated.

This is what the terminal reports after I run obs

Icon theme "adwaita" not found.
Icon theme "ubuntu-mono" not found.
Icon theme "yaru" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /app/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /app/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Dark.qss
Attempted path: /app/share/obs/obs-studio/themes/Dark.qss
info: CPU Name: Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz
info: CPU Speed: 3797.487MHz
info: Physical Cores: 6, Logical Cores: 6
info: Physical Memory: 7821MB Total, 2549MB Free
info: Kernel Version: Linux 5.17.3-zen1-1-zen
info: Distribution: "KDE Flatpak runtime" "5.15-21.08"
info: Session Type: x11
info: Window System: X11.0, Vendor: The [X.Org](http://X.Org) Foundation, Version: 1.21.1
info: Qt Version: 5.15.3 (runtime), 5.15.3 (compiled)
info: Portable mode: false
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
Attempted path: share/obs/obs-studio/themes/Dark/no_sources.svg
Attempted path: /app/share/obs/obs-studio/themes/Dark/no_sources.svg
QMetaObject::connectSlotsByName: No matching signal for on_tbar_position_valueChanged(int)
QMetaObject::connectSlotsByName: No matching signal for on_actionShowTransitionProperties_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_actionHideTransitionProperties_triggered()
info: OBS 27.2.3 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
samples per sec: 48000
speakers: 2
info: ---------------------------------
info: Initializing OpenGL...
error: ARB_GLX_create_context not supported!
error: Failed to create context!
error: device_create (GL) failed
error: Failed to initialize video. Your GPU may not be supported, or your graphics drivers may need to be upd
ated.
qt.glx: qglx_findConfig: Failed to finding matching FBConfig for QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alpha
BufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, co
lorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
No XVisualInfo for format QSurfaceFormat(version 2.0, options QFlagsQSurfaceFormat::FormatOption(), depthBuf
ferSize -1, redBufferSize 1, greenBufferSize 1, blueBufferSize 1, alphaBufferSize -1, stencilBufferSize -1, sa
mples -1, swapBehavior QSurfaceFormat::SingleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSp
ace, profile QSurfaceFormat::NoProfile)
Falling back to using screens root_visual.
^Cinfo: ==== Shutting down ==================================================
info: All scene data cleared
info: ------------------------------------------------
Failed to unregister window menu, reason: org.freedesktop.DBus.Error.Disconnected ("Not connected to D-Bus ser
ver")

Garuda inxi:

System:
Kernel: 5.17.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=a5e2e2df-0d5c-4bb8-b258-cf884294fc62 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop System: LENOVO product: 90JL00KTIX v: Legion T530-28ICB
serial: <filter> Chassis: type: 3 serial: <filter>
Mobo: LENOVO model: 36E7 v: SDK0J40700 WIN 3258131453720 serial: N/A
UEFI: LENOVO v: O3LKT17A date: 10/23/2018
CPU:
Info: model: Intel Core i5-8400 socket: U3E1 bits: 64 type: MCP
arch: Coffee Lake family: 6 model-id: 0x9E (158) stepping: 0xA (10)
microcode: 0xEC
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 3894 high: 3914 min/max: 800/4000 base/boost: 2800/4000
scaling: driver: intel_pstate governor: performance volts: 0.9 V
ext-clock: 100 MHz cores: 1: 3877 2: 3887 3: 3900 4: 3914 5: 3901 6: 3887
bogomips: 33599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Lenovo
driver: i915 v: kernel ports: active: none empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:3e92 class-ID: 0380
Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI
driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: i915,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
s-diag: 693mm (27.28")
Monitor-1: DP-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.54x13.23")
diag: 686mm (27.01") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Device-3: Razer USA RZ19-0229 Gaming Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:4 chip-ID: 1532:0511
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.17.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 8086:3166 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.03 TiB used: 360.9 GiB (34.3%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: HFM128GDHTNG-8310B size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: 80070C00 temp: 42.9 C scheme: GPT
SMART: yes health: PASSED on: 105d 3h cycles: 1,918
read-units: 91,143,152 [46.6 TB] written-units: 49,597,443 [25.3 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-08WN4A0 family: Blue size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: 1A02 temp: 36 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 286d 14h cycles: 1908
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 114.82 GiB (96.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 114.82 GiB (96.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 114.82 GiB (96.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 114.82 GiB (96.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.64 GiB used: 1.33 GiB (17.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 57.0 C pch: 62.0 C mobo: N/A gpu: nvidia
temp: 51 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Info:
Processes: 272 Uptime: 49m wakeups: 0 Memory: 7.64 GiB
used: 3.54 GiB (46.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: 1820 pacman: 1813 lib: 543 flatpak: 7
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.15
Garuda (2.6.1-1):
System install date:     2022-03-23
Last full system update: 2022-04-15
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:


I also have tried to search up fixes but I can't find anything for linux.

Have you tried uninstalling/re installing the flatpack

5 Likes

Thanks, it fixed the issue now obs runs as well as before.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.