NVMe not recognized for new install of Garuda

Hello Garuda users.

I downloaded a fresh Garuda Dragonized from the Website (checked checksum)

garuda-inxi command

Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
  clocksource: tsc available: hpet,acpi_pm
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=en
  tz=UTC misobasedir=garuda
  root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet systemd.show_status=1
  ibt=off driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: X470 GAMING PLUS MAX (MS-7B79) v: 3.0
    serial: <superuser required> UEFI: American Megatrends v: H.40
    date: 11/06/2019
  Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2375 high: 3600 min/max: 2200/4426 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
    3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 3600 10: 2200 11: 2200
    12: 2200 13: 2200 14: 3600 15: 2200 16: 2200 bogomips: 115197
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] driver: nvidia v: 530.41.03
    alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-08) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 27:00.0 chip-ID: 10de:1e84 class-ID: 0300
  Device-2: Microdia Terra HD1080PC Camera driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 7-3.4:6
    chip-ID: 0c45:636b class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 11520x2160 s-dpi: 162 s-size: 1806x341mm (71.10x13.43")
    s-diag: 1838mm (72.36")
  Monitor-1: DP-0 pos: primary,left res: 3840x2160 hz: 60 dpi: 164
    size: 596x335mm (23.46x13.19") diag: 684mm (26.92") modes: N/A
  Monitor-2: DP-2 pos: center res: 3840x2160 hz: 60 dpi: 163
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-3: DP-4 pos: right res: 3840x2160 hz: 60 dpi: 140
    size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
  API: OpenGL v: N/A renderer: N/A direct-render: N/A
  Device-1: NVIDIA TU104 HD Audio driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 27:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 29:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SteelSeries ApS Arctis Pro Wireless
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 7-3.2.3:8 chip-ID: 1038:1294 class-ID: 0300
  Device-4: Microdia Terra HD1080PC Camera driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 7-3.4:6
    chip-ID: 0c45:636b class-ID: 0102 serial: <filter>
  API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 14.65 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Intenso model: Rainbow size: 14.65 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
    lanes: 1 mode: 2.0 tech: N/A serial: <filter> scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.29 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 47.2 C mobo: N/A gpu: nvidia temp: 59 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
  Processes: 321 Uptime: 25m wakeups: 0 Memory: total: 32 GiB
  available: 31.29 GiB used: 14.84 GiB (47.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1231 libs: 323 tools: octopi,paru Shell: fish v: 3.6.1
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-09-14
  Last full system update: 2023-09-14 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       <superuser required>
  Failed units:            snapper-cleanup.service

I have a NVMe drive that works perfectly for a Windows and Ubuntu install, but Garuda does not recognize it. In Windows and Ubuntu are no additional drivers necessary. I already tried to format that drive with GParted and set a new partition table (gpt) and formatting with btrfs. But no recognition.

Details to the NVMe: Lexar NM790 M.2 2280 Gen4x4 4TB

I tried garuda-update and garuda-update remote fix in the live booted garuda, but then the Installation program fails with this output

╭─garuda@garuda in ~ as 🧙 took 1s
╰─λ /usr/bin/calamares_polkit %f -style kvantum
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
01:00:12 [1]: void bail(const QString&, const QString&)
    ERROR: FATAL in "/usr/share/calamares/branding/garuda/branding.desc"
     bad conversion

The weird thing is, that my old NVMe (INTEL 660p SERIES; 1TB) is recognized, but I want to install it on the 4TB drive. Also (as mentioned) Windows and Ubuntu have no problems.
I do not know what to do further to fix this. I am no newbie to Linux, but to Garuda (specifically Arch).
Thanks in advance.

PS: UEFI SATA is set to AHCI

Use gnome-disk-utility (start with disks or in terminal gnome-disks . (I like it if they can’t use one name for all :grimacing: )

Click the volume, extra settings, get owner.

Use button from Welcome or

sudo -E calamares -D8

Got gnome-disks running, but the NVMe or the volume is not listed.

I looked into the command the Icon Garuda Linux Installation executes, then I tried this command in the terminal.

This command creates the error

╭─garuda@garuda in ~ as 慄 took 12ms
╰─λ sudo -E calamares -D8
Warning: fallback to QtQuick software backend.
02:24:25 [6]: Calamares::Settings::Settings(const QString&, bool)
    Using Calamares settings file at "/etc/calamares/settings.conf"
    .. Required settings.conf key hide-back-and-next-during-exec is missing.
02:24:25 [6]: void Logger::setupLogfile()
    Using log file: "/home/garuda/.cache/calamares/session.log"
02:24:25 [6]: void CalamaresApplication::init()
    Calamares version: 3.3.0-alpha3
    .. languages: ("ar", "as", "ast", "az", "az_AZ", "be", "bg", "bn", "ca", "ca@valencia", "cs_CZ", "da", "de", "el", "en", "en_GB", "es", "es_MX", "et", "eu", "fa", "fi_FI", "fr", "fur", "gl", "he", "hi", "hr", "hu", "id", "is", "it_IT", "ja", "ko", "lt", "ml", "mr", "nb", "nl", "oc", "pl", "pt_BR", "pt_PT", "ro", "ru", "si", "sk", "sl", "sq", "sr", "sr@latin", "sv", "tg", "th", "tr_TR", "uk", "vi", "zh_CN", "zh_TW")
02:24:25 [6]: bool CalamaresUtils::initQmlModulesDir()
    Using Calamares QML directory "/usr/share/calamares/qml"
02:24:25 [6]: Calamares::Branding::Branding(const QString&, QObject*)
    Using Calamares branding file at "/usr/share/calamares/branding/garuda/branding.desc"
02:24:25 [2]: void CalamaresUtils::explainYamlException(const YAML::Exception&, const QByteArray&, const QString&)
    WARNING: YAML error bad conversion in "/usr/share/calamares/branding/garuda/branding.desc" .
02:24:25 [1]: void bail(const QString&, const QString&)
    ERROR: FATAL in "/usr/share/calamares/branding/garuda/branding.desc"
     bad conversion

Just try the newer LTS version.

Maybe you can post also the name from the ISO you used?
garuda-dr460nized-linux-zen-230501.iso ?

I move it from Newbies to KDE

Where do I find these links officially? Do you have a checksum?

This was the ISO I used. This is the official downloadable on the website.

I build this ISO and save it in the cloud.

There is no official link, it’s just a service for people they have trouble with zen kernel and NVIDIA GPU


Thank you, this ISO worked out of the box. Would be helpful for people to make this ISO publicly available on the site as an alternative.
This helped me a lot. <3

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.