Nvidia troubles with installing propietary drivers

We are having problems with getting the proprietary nvidia drivers installed and working. The open source drivers are not allowing us to play the majority of games we’d like to play

So the main thing we have tried is installing the nvidia 525 utils and settings packages which when installed caused a samba error on boot, we don’t need samba so we uninstalled it and with the nvidia 525xx-settings package installed it just got stuck on the boot screen. We ended up restoring from a snapshot. The particular game we are trying to run is listed as platinum on protondb (and is native to linux from gog) but is running very poorly under the current drivers.

  Kernel: 6.6.16-x64v-xanmod1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod
    root=UUID=8119a388-b5e5-4d32-8490-b32855e4a1e8 rw rootflags=subvol=@ quiet
    resume=UUID=b85cd719-e7e3-4b8b-9946-b7c118af39bc loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks v: 5.115.0 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda base: Arch Linux
  Type: Laptop System: ASUSTeK product: G75VW v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: G75VW v: 1.0 serial: <superuser required> part-nu: ASUS-NotebookSKU
    uuid: <superuser required> BIOS: American Megatrends v: G75VW.218 date: 08/21/2012
  ID-1: BAT0 charge: 50.6 Wh (100.0%) condition: 50.6/66.0 Wh (76.7%) volts: 16.7 min: 14.8
    model: ASUSTek G75--52 type: Li-ion serial: N/A status: full
  Info: model: Intel Core i7-3630QM bits: 64 type: MT MCP arch: Ivy Bridge gen: core 3 level: v2
    built: 2012-15 process: Intel 22nm family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 3244 high: 3400 min/max: 1200/3400 scaling: driver: intel_cpufreq
    governor: performance cores: 1: 3180 2: 3400 3: 3311 4: 3195 5: 3225 6: 3255 7: 3191 8: 3195
    bogomips: 38311
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities: <filter>
  Device-1: NVIDIA GK107M [GeForce GTX 660M] vendor: ASUSTeK driver: nouveau v: kernel
    alternate: nvidiafb non-free: series: 470.xx+ status: legacy-active (EOL~2024-09-xx) arch: Kepler
    code: GKxxx process: TSMC 28nm built: 2012-2018 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports:
    active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:0fd4 class-ID: 0300
    temp: 46.0 C
  Device-2: Sunplus Innovation ASUS Webcam driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-1.3:4 chip-ID: 1bcf:2885 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,nouveau,nv,vesa dri: nouveau gpu: nouveau display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: LVDS-1 model: Chi Mei Opto 0x1720 built: 2011 res: 1920x1080 hz: 60 dpi: 128
    gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3") ratio: 16:9 modes: max: 1920x1080
    min: 640x350
  API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 drv: nouveau device: 1 drv: swrast
    gbm: drv: nouveau surfaceless: drv: nouveau x11: drv: nouveau inactive: wayland
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 23.3.5-arch1.1 glx-v: 1.4 direct-render: yes
    renderer: NVE7 device-ID: 10de:0fd4 memory: 1.94 GiB unified: no
  API: Vulkan v: 1.3.276 layers: 10 device: 0 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits)
    driver: mesa llvmpipe v: 23.3.5-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  API: ALSA v: k6.6.16-x64v-xanmod1-1 status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: AzureWave driver: ath9k
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID
: 168c:0032 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: ASUSTeK driver: atl1c v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0 chip-ID: 1969:1083
    class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter driver: btusb v: 0.8 type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.1:3 chip-ID: 13d3:3362 class-ID: e001
    serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.0 lmp-v: 6 status:
    discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 937.11 GiB used: 65.45 GiB (7.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 2B6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS727575A9E364 size: 698.64 GiB
    block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: A200 scheme: MBR
  ID-1: / raw-size: 225.67 GiB size: 225.67 GiB (100.00%) used: 65.45 GiB (29.0%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 225.67 GiB size: 225.67 GiB (100.00%) used: 65.45 GiB (29.0%) fs: btrfs
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 225.67 GiB size: 225.67 GiB (100.00%) used: 65.45 GiB (29.0%)
    fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 225.67 GiB size: 225.67 GiB (100.00%) used: 65.45 GiB (29.0%)
    fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100) zswap: no
  ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 12.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
    maj-min: 8:2
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nouveau temp: 46.0 C
  Fan Speeds (rpm): cpu: 2100
  Memory: total: 16 GiB available: 15.58 GiB used: 2.43 GiB (15.6%)
  Processes: 352 Power: uptime: 13m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 6.22 GiB
    services: org_kde_powerdevil,upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1838 libs: 553 tools: octopi,paru Compilers: gcc: 13.2.1
    Client: shell wrapper v: 5.2.26-release inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2024-02-10
  Last full system update: 2024-02-12 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            

Also, I need to add, when we go to the garuda settings assistant and go to hardware configuration, we do not see the option to autoinstall the proprietary drivers

Try the normal zen & LTS kernels. Be sure to reboot into them.

The ‘swoosh’ indicates you need to reboot since your last update. That needs to happen before the system can proceed.


rebooted into zen, is there something we can do to check to see if it is all working? still not seeing the button for autoinstall, should we just try to run the game? or try to install the same packages again?

Sorry, I’m not a gamer and I don’t have nVidia (thank Gawd). But yeah, try to run the game. Re-installing the same pkgs again is normally futile, so no on that.

The ideal is to let Garuda handle drivers.

1 Like

Tried switching to the zen kernel, the menu ran slightly better but the game itself wouldn’t run well at all. Probably going to need to run with the like proprietary drivers but still no idea how to get them to like work.

With your model you have to install the 470 series.
Try with:

sudo pacman -S nvidia-470xx-dkms nvidia-470xx-dkms-utils

Thank you so much, this worked.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.