Nvidia-smi can't communicate with GPU

Installed the nvidia driver through garuda which is 390 something.

I am trying to play games on steam but despite using the prime-run command or in my case since it worked in the terminal the DRI_PRIME=1. Games don’t launch with my dedicated nvidia GPU still and when I try running “nvidia-smi” I get this output: " NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running."

garuda-inxi results for the GPU:

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5e165b7a-0c3e-41f7-80a8-faa865da1bba rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Micro-Star product: GT70 2PE v: REV:0.C
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-1763 v: REV:0.C serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends v: E1763IMS.51D
date: 04/17/2015
ID-1: BAT1 charge: 69.6 Wh (100.0%) condition: 69.6/73.3 Wh (95.0%)
volts: 12.2 min: 11.1 model: MSI BTY-M6D type: Li-ion serial: N/A
status: full
Info: model: Intel Core i7-4810MQ bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2794 high: 2795 min/max: 800/2800 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2794 2: 2794 3: 2794
4: 2794 5: 2795 6: 2794 7: 2794 8: 2794 bogomips: 44698
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel 4th Gen Core Processor Integrated Graphics
vendor: Micro-Star MSI driver: i915 v: kernel arch: Gen-7.5
process: Intel 22nm built: 2013 ports: active: eDP-1 empty: VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
Device-2: NVIDIA GK104M [GeForce GTX 880M] vendor: Micro-Star MSI
driver: nouveau v: kernel alternate: nvidia_drm,nvidia non-free:
series: 470.xx+ status: legacy-active (EOL~2024-09-xx) arch: Kepler
code: GKxxx process: TSMC 28nm built: 2012-2018 pcie: gen: 1
speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
active: none empty: DP-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1198
class-ID: 0300 temp: 56.0 C
Device-3: Bison MSI Integrated Webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-9:8 chip-ID: 5986:014c
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,nouveau,nv,vesa dri: crocus,nouveau gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Chi Mei Opto 0x1720 built: 2011 res: 1920x1080
hz: 60 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3")
ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel crocus drv: nvidia nouveau platforms:
device: 0 drv: nouveau device: 1 drv: crocus device: 2 drv: swrast gbm:
drv: nouveau surfaceless: drv: nouveau x11: drv: crocus inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.3 vendor: intel mesa v: 23.3.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4600 (HSW
GT2) device-ID: 8086:0416 memory: 1.46 GiB unified: yes
API: Vulkan Message: No Vulkan data available.
Device-1: Intel 8 Series/C220 Series High Definition Audio
vendor: Micro-Star MSI 8 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
Device-2: NVIDIA GK104 HDMI Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0e0a
class-ID: 0403
Device-3: C-Media USB Advanced Audio Device
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-2:3 chip-ID: 0d8c:016c class-ID: 0300
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 1969:e091 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Rivet
Networks Killer Wireless-N 1202 Half-size Mini PCIe Card driver: ath9k
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0
chip-ID: 168c:0034 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Qualcomm Atheros AR3012 Bluetooth 4.0 driver: btusb v: 0.8
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-11:6
chip-ID: 0cf3:3004 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.1
lmp-v: 7 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 1.03 TiB used: 717.86 GiB (68.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD6SF1M128G
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 200 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-1: / raw-size: 150.28 GiB size: 150.28 GiB (100.00%)
used: 79.34 GiB (52.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
used: 56.2 MiB (19.0%) fs: vfat dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 150.28 GiB size: 150.28 GiB (100.00%)
used: 79.34 GiB (52.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
ID-4: /var/log raw-size: 150.28 GiB size: 150.28 GiB (100.00%)
used: 79.34 GiB (52.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
ID-5: /var/tmp raw-size: 150.28 GiB size: 150.28 GiB (100.00%)
used: 79.34 GiB (52.8%) fs: btrfs dev: /dev/sdb4 maj-min: 8:20
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 11.6 GiB used: 2.92 GiB (25.2%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 67.0 C mobo: N/A gpu: nouveau temp: 57.0 C
Fan Speeds (rpm): N/A
Memory: total: 12 GiB available: 11.6 GiB used: 4.12 GiB (35.5%)
Processes: 303 Power: uptime: 2h 33m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 4.63 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1963 libs: 573 tools: gnome-software, octopi,
pamac, paru, yay Compilers: gcc: 13.2.1 Shell: garuda-inxi default: fish
v: 3.7.0 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-02-13
Last full system update: 2024-02-13 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


I ran this and it seems like the 390 driver didn’t get installed after all despite it going through the nvidia setup during the update portion. I see noveau driver is on there and I know this is the one I need to replace with proprietary nvidia driver.

Do not kid me? Please, we need the complete garuda-inxi.

It does not contain any compromising or personal data.


With your model you have to install the 470 series.
Try with:

sudo pacman -S nvidia-470xx-dkms nvidia-470xx-dkms-utils

I have updated the inxi to include everything now.

@filo I tried the code you sent in the terminal and got this:

error: target not found: nvidia-470xx-dkms-utils

I see that the dependencies installed right now are the 390 ones, however the inxi says I should be getting version 470. Maybe this is the issue.

This is probably some remnant from the previous installation of the 390 series.
Rather than getting into a fight to remove those packages, maybe you can restore a snapshot that before that installation, reboot, update your system and then install the right drivers?


I went back to the earliest snapshot before the update and didn’t let nvidia installation do its thing. I’m now following this guide: GitHub - korvahannu/arch-nvidia-drivers-installation-guide: A repository that holds a simple guide on how you can install and configure proprietary NVIDIA drivers for Arch Linux.

When I get to the part of driver install it seems to work however I get a lot of these warning messages like this: warning: warning given when extracting /usr/lib32/libnvidia-tls.so (Can't set permissions to 0777)
Do I need to do this from root?

There’s an update: nvidia-smi now communicates like it should with the GPU:

Tue Feb 13 23:07:38 2024
| NVIDIA-SMI 470.223.02   Driver Version: 470.223.02   CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 N/A |                  N/A |
| N/A   53C    P8    N/A /  N/A |      6MiB /  4037MiB |     N/A      Default |
|                               |                      |                  N/A |

| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|  No running processes found                                                 |

However steam games still will not launch and says they require DX11 version 10 to play. I do have DXVK installed as well using winetricks dxvk

Do you launch steam games with prime-run like here?

1 Like

Yes, in fact when I use prime-run in launch options the games won’t run, even when using PROTON_USE_WINED3D=1 %command% . When I remove prime-run it launches but uses my internal card and runs really bad. We’re talking 4fps with extreme graphical error. If I don’t include the proton command above I get the “DirectX 11 needed” error. I also want to add I installed the nvidia prime stuff after typing prime-run in the terminal. That lead to installing this. I can use the command succesfully to run glxgears for example.

Auch, sometimes I wish I was a gamer, or at least an nvidia user :wink:.
Maybe you are missing the lib32 drivers?
Looking at some topics in the forum, I think in the end you need all of these:


I included all those on step 2 where the drivers get installed in the tutorial I followed. nvidia.hook gave an error during this. I also tried editing nvidia.conf file to use the dedicated GPU as primary. Still no luck though. Maybe my graphics card is just too outdated.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.