Nvidia settings not working

System:
  Kernel: 5.19.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=866e0b23-19e5-43ac-802b-ce0f5de6cac2
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required> UEFI: INSYDE v: 1.07.10TFB24
    date: 12/06/2021
Battery:
  ID-1: BAT0 charge: 47.3 Wh (100.0%) condition: 47.3/47.2 Wh (100.4%) volts: 16.4 min: 14.4
    model: Notebook BAT type: Li-ion serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB desc: d-6x48
    KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2182 high: 4189 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 1224 2: 800 3: 4189 4: 4181 5: 799 6: 800 7: 800 8: 4017 9: 4098
    10: 801 11: 3686 12: 800 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: CLEVO/KAPOK driver: N/A
    alternate: nouveau, nvidia_drm, nvidia non-free: 515.xx+ status: current (as of 2022-07)
    arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:2 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080 hz: 144
    dpi: 128 gamma: 1.2 size: 380x210mm (14.96x8.27") diag: 437mm (17.2") ratio: 16:9
    modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.19.6-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:43f0 class-ID: 0280
  IF: wl

nvidia-settings application does not open and does not return any errors

Add ibt=off kernel parameter

1 Like

How can I do that?

In addition to the suggestion above, whose how-to could be easily found in the forum, anyway reported below:

  • sudo micro /etc/default/grub, add ibt=off at the end of the line starting with GRUB_CMDLINE_LINUX_DEFAULT, save and exit
  • sudo update-grub and reboot

I see in your inxi's that you changed a lot of kernels (e.g. lts, xanmod, zen) so your dkms might be in troubles. So you could try a:
sudo dkms autoinstall and, in case of errors, check the log file indicated by the results.

3 Likes

I did but it still doesn't work. Could it be a problem with the drivers?

Did what? ibt=off, dkms autoinstall or both?
For the dkms autoinstall it would be useful to see the terminal output and, if applicable, the error log.

1 Like

I added ibt=off and did dkms autoinstall, no errors.

But still nvidia setting is not working.

2022-09-06_18-11
Shouldn't he have other options?

Your driver is not loaded. That's the problem in my opinion. But I don't have other suggestions...

2 Likes

Can you help me how to download?

Try with the HW assistant (Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration) and autoinstall drivers.
Altrrnatively the same command executed by the HW assistant:

sudo mhwd -a pci nonfree 0300

PLease, read.

3 Likes

Skipping already installed config 'video-nvidia-prime-render-offload' for device: 0000:01:00.0 (0300:10de:1f
9d) Display controller nVidia Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q]
Skipping already installed config 'video-nvidia-prime-render-offload' for device: 0000:00:02.0 (0300:8086:9a

  1. Display controller Intel Corporation TigerLake-H GT1 [UHD Graphics]

I think I did something wrong while deleting or installing the drivers.

Who knows? I don't have deep knowledge of Nvidia stuff, I don't use Nvidia. Until someone else jumps in, maybe recheck the ibt=off process, since it was not shown in the inxi in the recently trashed topic.

1 Like

Lead me to

1 Like

If you start KDE on Nvidia graphics instead of Intel you should get more options. Also send garuda-inxi again.

1 Like

Did you try with prime-run?

1 Like

Worked with lts kernel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.