Nvidia-settings ERROR: NVIDIA driver is not loaded

Could you try adding ibt=off to your kernel parameters? This shouldn't be necessary because you use LTS kernel but it is still worth trying.

This is not the full output. Please don't trim or truncate output.

Run dkms autoinstall and read the output carefully.

3 Likes

Dear jonathon,

Your recommnded command 'dkms autoinstall' (which had to be done as sudo/root) appears to have delivered the proper fix for the issue. I will need to reboot to be certain.

Here is the output:

[[email protected] ~]#dkms autoinstall
Sign command: /usr/lib/modules/5.15.62-1-lts/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
'make' -j16 IGNORE_PREEMPT_RT_PRESENCE=1 NV_EXCLUDE_BUILD_MODULES='__EXCLUDE_MODULES' KERNEL_UNAME=5.15.62-1-lts modules........
Signing module /var/lib/dkms/nvidia/515.65.01/build/nvidia.ko
Signing module /var/lib/dkms/nvidia/515.65.01/build/nvidia-uvm.ko
Signing module /var/lib/dkms/nvidia/515.65.01/build/nvidia-modeset.ko
Signing module /var/lib/dkms/nvidia/515.65.01/build/nvidia-drm.ko
Signing module /var/lib/dkms/nvidia/515.65.01/build/nvidia-peermem.ko
Cleaning build area...

nvidia.ko.zst:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /usr/lib/modules/5.15.62-1-lts/updates/dkms/

nvidia-uvm.ko.zst:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /usr/lib/modules/5.15.62-1-lts/updates/dkms/

nvidia-modeset.ko.zst:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /usr/lib/modules/5.15.62-1-lts/updates/dkms/

nvidia-drm.ko.zst:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /usr/lib/modules/5.15.62-1-lts/updates/dkms/

nvidia-peermem.ko.zst:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /usr/lib/modules/5.15.62-1-lts/updates/dkms/
depmod...

Thank you very much!

There is something elese I would like to address....

One thing that we all know is our own experiences. On my system and linux installation, the command 'dkms status' showed exactly what I posted, nothing more and nothing less. And it didn't matter whether it was run as regular user or as root user. I did not truncate anything. Please keep in mind that you do not know what I have experienced, only what you have experienced. I do not appreciate being accused of something that I have not done or am not doing. I hope you can understand that. Anyway...

Again, thank you jonathon! Take care and cheers

That would not be output that I'm used to - dkms status should show the kernel version too, e.g.

nvidia/515.49.10, 5.19.3-lqx1-1-lqx, x86_64: installed
nvidia/515.49.10, 5.19.3-zen1-1-zen, x86_64: installed

I guess "added" is some intermediate broken state...

1 Like

Looks like DKMS itself is broken:

Install regular linux kernel and the precompiled driver for it:

sudo pacman -S linux linux-headers nvidia

then reboot and choose "linux" kernel, not "linux-lts"

The problem was fixed by triggering a DKMS moduyle build - there's no need to install another kernel and the pre-compiled driver module (which will conflict with nvidia-dkms and so break NVIDIA for the other kernels)

Well jonathon, from the looks of the result of your command, I thought the fix was in. But no, the issue persists. However, the 'dkms status' command now has full output and states that it is now 'installed' rather than 'added'.

'nvidia-settings'
ERROR: NVIDIA driver is not loaded

'nvidia-smi'
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

[[email protected] ~]# modprobe nvidia
modprobe: ERROR: could not insert 'nvidia': Invalid argument

'dkms status'
nvidia/515.65.01, 5.15.62-1-lts, x86_64: installed

Thank you for your efforts

Hello mrvictory,

The reason I am using the LTS Kernel is because there has been some "issues" on my end ever since the introduction of the 5.18.x kernel.

Here is what I will do. I already have the latest Zen Kernel installed. I will boot into it, which works ok. But I have no 3D Accelerated output when using that kernel, and when I exit Steam there is a strange issue. We will see what happens with this new installation I am running, but I expect to have the same problem(s) I was having the last time I tried using it.

I will let you know what happens fairly soon. Thank you for trying to help!

Then run this:

sudo pacman -S --needed linux-lts-headers nvidia-lts

Hello again mrvictory,

I was just looking over that bug report. After getting the kernel module built thanks to jonathon's help, this bug report looks like it is the bug I have encountered.

Now that the kernel module is installed, when I do 'modprobe nvidia' as root, I get...

[[email protected] ~]# modprobe nvidia
modprobe: ERROR: could not insert 'nvidia': Invalid argument

I will need to take some time to try the bug reporter's[Matt M. (9numbernine9)] script/fix.

Cheers

The fix was to update pahole, so just update your system.

2 Likes

Ok jonathon,

I will do that and be right back. Thanks

Isn't it downgrade pahole?

1 Like

OT :smiley:

egal = no matter :grin:

2 Likes

Hello again folks,

The issue still persists.

You are correct mrvictory, it was a downgrade. pahole went from version 1.24 to 1.23.


I am wondering if I need to uninstall dkms nvidia kernel module, and build it again since the change to the pahole package.

It looks like Arch devs did timely fix the bug​:partying_face:
I am glad I didn't set off the alarms this time :sweat_smile:

1 Like

Howdy,

It's getting a little hairy, but nothing I can't handle. Here's what's going on at this time:

After the downgrade to pahole, I rebooted.
Then I ran the following command as root...

[[email protected] pkg]# dkms remove nvidia/515.65.01
Module nvidia-515.65.01 for kernel 5.15.62-1-lts (x86_64).
Before uninstall, this module version was ACTIVE on this kernel.

nvidia.ko.zst:
- Uninstallation
- Deleting from: /usr/lib/modules/5.15.62-1-lts/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

nvidia-uvm.ko.zst:
- Uninstallation
- Deleting from: /usr/lib/modules/5.15.62-1-lts/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

nvidia-modeset.ko.zst:
- Uninstallation
- Deleting from: /usr/lib/modules/5.15.62-1-lts/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

nvidia-drm.ko.zst:
- Uninstallation
- Deleting from: /usr/lib/modules/5.15.62-1-lts/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

nvidia-peermem.ko.zst:
- Uninstallation
- Deleting from: /usr/lib/modules/5.15.62-1-lts/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.
depmod...
Deleting module nvidia-515.65.01 completely from the DKMS tree.

I rebooted.
When I ran the commands 'dkms status' and 'dkms autoinstall'(as root), they returned nothing.
So, I went to 'Garuda Settings Manager' --> 'Hardware Configuration', right-clicked on 'video-nvidia-prime-render-offload' and chose 'Reinstall'.
Rebooted.
Then I ran 'dkms status' and it returned...

'dkms status'
nvidia/515.65.01: added

I have now run the 'sudo dkms autoinstall' command which completed sucessfully and am going to reboot.

Cheers

2 Likes

OMG! OMG! :grinning:



'dkms status'
nvidia/515.65.01, 5.15.62-1-lts, x86_64: installed

╭─[email protected] in ~ took 132ms
╰─λ nvidia-smi
Wed Aug 24 09:54:02 2022
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.65.01    Driver Version: 515.65.01    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   36C    P0    N/A /  N/A |      5MiB / 16384MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      1412      G   /usr/lib/Xorg                       4MiB |
+-----------------------------------------------------------------------------+

╭─[email protected] in ~ took 1s
╰─λ prime-run glxinfo -B | grep "OpenGL vendor string"
OpenGL vendor string: NVIDIA Corporation

And the command 'prime-run glxgears' works!

Looks like success. Thank you jonathon and mrvictory for your help!

Cheers,

Jimmy Richards
Proud and Happy to use Garuda :slightly_smiling_face:

4 Likes

Thanks so much for this thread! Fixed my issues also! :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.