Nvidia GTX 660M mac edition

Hello everyone,
I have been using garuda for several months now and I am delighted. everything works perfectly except...VGA compatible controller: NVIDIA Corporation GK107M [GeForce GTX 660M Mac Edition] (rev a1)
I solved almost all the problems I encountered except with this damn graphics card which is about ten years old. I cannot therefore adjust the brightness of the screen and it is very annoying. Would there be a solution? Who develops the drivers? On trisquel which I installed on an external hard drive, I do not have this problem. Why?

Thanks for your help.

Please, please, please.

Follow the template.

Post your garuda-inxi log as text.

1 Like

like that ?

 ╰─λ garuda-inxi 
  Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=696fa981-d84b-4f28-9087-dc7b1f707539 rw rootflags=subvol=@
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    nvidia-drm.modeset=1 ibt=off
  Desktop: GNOME v: 44.4 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Apple product: iMac13,2 v: 1.0
    serial: <superuser required> Chassis: type: 13 v: Mac-FC02E91DDD3FA6A4
    serial: <superuser required>
  Mobo: Apple model: Mac-FC02E91DDD3FA6A4 v: iMac13,2
    serial: <superuser required> UEFI: Apple v: 424. date: 09/13/2021
  Info: model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2265 high: 3600 min/max: 1600/3600 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 1733 2: 1597 3: 2131
    4: 3600 bogomips: 23146
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GK107M [GeForce GTX 660M Mac Edition] vendor: Apple
    driver: nouveau v: kernel non-free: series: 470.xx+
    status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-18 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: DP-1 empty: DP-2,DP-3
    bus-ID: 01:00.0 chip-ID: 10de:0fe0 class-ID: 0300 temp: 42.0 C
  Device-2: Apple FaceTime HD Camera (Built-in) driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.1:3
    chip-ID: 05ac:8511 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: with: Xwayland v: 23.2.0
    compositor: gnome-shell driver: X: loaded: nvidia gpu: nouveau display-ID: 0
  Monitor-1: DP-1 res: 2560x1440 size: N/A modes: N/A
  API: EGL/GBM Message: No known Wayland EGL/GBM data sources.
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.78 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe vendor: Apple
    driver: tg3 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A
    bus-ID: 03:00.0 chip-ID: 14e4:1686 class-ID: 0200
  IF: enp3s0f0 state: down mac: <filter>
  Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 14e4:4331 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-3: TP-Link Archer T3U [Realtek RTL8812BU] driver: rtl88x2bu
    type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1.4:5
    chip-ID: 2357:012d class-ID: 0000 serial: <filter>
  IF: wlp0s20u1u4 state: down mac: <filter>
  Device-1: Apple Bluetooth USB Host Controller driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-
    chip-ID: 05ac:828b class-ID: fe01
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
  Device-2: ASUSTek ASUS USB-BT500 driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1.3:4 chip-ID: 0b05:190e
    class-ID: e001 serial: <filter>
  Report: ID: hci1 rfk-id: 2 state: up address: <filter> bt-v: 5.1 lmp-v: 10
    status: discoverable: no pairing: no class-ID: 6c0104
  Local Storage: total: 931.51 GiB used: 150.36 GiB (16.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
  ID-1: / raw-size: 926.51 GiB size: 926.51 GiB (100.00%)
    used: 149.74 GiB (16.2%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-2: /boot/efi raw-size: 1022 MiB size: 1020 MiB (99.80%)
    used: 634.8 MiB (62.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 926.51 GiB size: 926.51 GiB (100.00%)
    used: 149.74 GiB (16.2%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-4: /var/log raw-size: 926.51 GiB size: 926.51 GiB (100.00%)
    used: 149.74 GiB (16.2%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-5: /var/tmp raw-size: 926.51 GiB size: 926.51 GiB (100.00%)
    used: 149.74 GiB (16.2%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 23.41 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: nouveau temp: 42.0 C
  Fan Speeds (rpm): N/A
  Processes: 350 Uptime: 4m wakeups: 0 Memory: total: 24 GiB
  available: 23.41 GiB used: 3.64 GiB (15.6%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1729 libs: 424 tools: octopi,pamac,paru,yay pm: appimage
  pkgs: 0 pm: flatpak pkgs: 0 Shell: fish v: 3.6.1 running-in: gnome-terminal
  inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-08-26
  Last full system update: 2023-09-01
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Check my modifications, please.

Hi Cytise, check this page here: NVIDIA - ArchWiki

For the Kepler (NVE0/GKXXX) series, install the nvidia-470xx-dkmsAUR package.

This package is in the Chaotic-AUR, so you can just install it with Pacman.

sudo pacman -S nvidia-470xx-dkms

Thank you very much, I'll do it right away and let you know what happens.

ok, the image may be finer but still no easy way to find the brightness setting. Too bad, I'll do with the adjust display brightness extension even if it's not very practical.
In any case, thank you for your responsiveness.

Perhaps one of these suggestions from the ArchWiki Mac article would be worth a shot:




For the backlight to work properly you may need the nvidia-bl-dkmsAUR package. If backlight control does not work afterwards, you should blacklist the apple_bl kernel module. If backlight control does not work even this way, try setting options nvidia_bl max_level=0x1ffff shift=11 in /etc/modprobe.d/nvidia_bl.conf.

Alternatively, you can choose to use the pommed-lightAUR package. If you do so, you may wish to change the step settings in /etc/pommed.conf.mactel to something around 5000-10000 depending on how many levels of brightness you desire (the max brightness is around 80000).

If the brightness does not function correctly through pommed, make sure you have installed the nvidia-bl-dkmsAUR package and insert

$ find . -name "*" -exec sed -i 's/mbp_backlight/nvidia_backlight/' '{}' \;

into the second line of the pommed PKGBUILD build() function and rebuild the package. See the following forum post for details.

Another possible solution is:

$ find . -name "*" -exec sed -i 's/nvidia_backlight/apple_backlight/' '{}' \;

Alternatively, run nvidia-settings, edit /etc/X11/xorg.conf and add this line into the Device section:

Option "RegistryDwords" "EnableBrightnessControl=1"

Save, reboot and check if the backlight control works. See Ubuntu’s Wiki page for the MacBookPro5,5 for details.

1 Like

none of this works. After a black screen on reboot and a forced restart in snapshot because, I prefer to let it go :slightly_smiling_face:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.