Nvidia drivers can't be installed or not working

Hi, I use grauda dragon edition latest but I am trying to install nvidia drivers on it.

I have tried auto install option which is build in.
But I was unable to boot so I came back through snapshot then tried nvidia package a said in arch wiki. Same results so I came back from it again it's a fresh install just installed today. I am using zen kernel I tried driver form nvidia site too but. Shows error saying can't build kernel modules

I have nvidia GeForce GTX 705

Hi there, welcome!
There are being several similar issues recently, in relations to recent kernel an nvidia driver updates.
My initial suggestion would be to restore again from snapshot, install the linux-lts kernel

sudo pacman -S linux-lts linux-lts-headers

and try updating again (the system and the built-in nvidia drivers provided by the Garuda Assistant / Installation)

In case of further booting issues, you could try following this tutorial.
Computer doesn’t boot, boots to a black screen, or stops at a message

PS: please always provide your inxi -Faz according to the new topic template

1 Like

Also keep in mind that this card is not supported by the nvidia-dkms driver, so you will need to use nvidia-390xx-dkms instead.


I was just installing nvidia dkms so should I uninstall it

Is there any extra step to do

Did that but now I am struck at starting terminate Plymouth boot screen what to do know😅

Try CTRL+ALT+F2 to see if you can boot to a TTY (terminal).
If you do, then login and try startx

1 Like

It says no screen found

Try also other Fx (with CTRL+ALT) or Esc.
If nothing works, switch off and on and in the Grub menu select the linux-zen kernel instead of the linux-lts.

1 Like

Same with Zen kernel

So you have to restore a previously working snapshot from grub.
Then try to unistall from the garuda assstant any proprietary drivers and install nvidia-390xx-dkms

1 Like

Okay , going to try that

1 Like

I successfully booted now how to check if drivers are workign

Thankyou very muchh

1 Like

Now it's time to post the output of
inxi -Faz
With ~~~ before and after the text block

But the ui is still glitching sometimes the whole ui hangs

Wait let me do that
i cant make any more posts
but where is my latte dock <======

System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=09ecefa7-b2ae-4911-8b60-2a3bf52594be  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop System: Dell product: Inspiron 3250 v: X00 serial: <filter> Chassis: type: 3
serial: <filter>
Mobo: Dell model: 0DNMV1 v: A01 serial: <filter> UEFI: Dell v: 3.0.2 date: 12/30/2015
CPU:       Info: Quad Core model: Intel Core i5-6400 bits: 64 type: MCP arch: Skylake-S family: 6
model-id: 5E (94) stepping: 3 microcode: EA cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599
Speed: 3190 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 3190 2: 3287 3: 3287 4: 3194
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GF119 [GeForce GT 705] vendor: Dell driver: nvidia v: 390.144
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:104c class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 93 s-size: 524x321mm (20.6x12.6") s-diag: 615mm (24.2")
Monitor-1: HDMI-0 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8")
diag: 611mm (24.1")
OpenGL: renderer: GeForce GT 705/PCIe/SSE2 v: 4.6.0 NVIDIA 390.144 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: NVIDIA GF119 HDMI Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:0e08 class-ID: 0403
Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169
v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be v: kernel
port: c000 bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-3:4
chip-ID: 0bda:b739 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 15.48 GiB (1.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC43 scheme: GPT
Partition: ID-1: / raw-size: 400 GiB size: 400 GiB (100.00%) used: 15.48 GiB (3.9%) fs: btrfs
dev: /dev/sda8 maj-min: 8:8
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
dev: /dev/sda5 maj-min: 8:5
ID-3: /home raw-size: 400 GiB size: 400 GiB (100.00%) used: 15.48 GiB (3.9%) fs: btrfs
dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 400 GiB size: 400 GiB (100.00%) used: 15.48 GiB (3.9%) fs: btrfs
dev: /dev/sda8 maj-min: 8:8
ID-5: /var/tmp raw-size: 400 GiB size: 400 GiB (100.00%) used: 15.48 GiB (3.9%) fs: btrfs
dev: /dev/sda8 maj-min: 8:8
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.71 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 20 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda6
maj-min: 8:6
Sensors:   System Temperatures: cpu: 57.0 C mobo: 29.8 C
Fan Speeds (RPM): cpu: 1748 fan-2: 1814
Info:      Processes: 194 Uptime: 2m wakeups: 0 Memory: 7.71 GiB used: 1.09 GiB (14.1%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1135 lib: 285
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Lts is also working

1 Like

The driver seems correct now.
I don't see the initial part of the inxi with the kernel version.
I don't know the possible reasons for hangs and stuttering.
Maybe check in the Garuda assistant -> btrfs if a btrfs balance is suggested.
You could also give a look at the compositor in the settings to see if there is a notification of an error...

For the latte dock, try to open Garuda assistant, there's a flag Latte and a button to restore default settings

Now that the driver seems to be the right one for your GPU, it could be the right time to try again with the linux-lts kernel to see if the freezes appear also there.
Be patient :wink: