Nvidia Driver not working?

Basically I have been running normal arch and now tried out Garuda. Minecraft would only run on Intel Integrated Graphics, so I installed the nvidia package, according to my hardware (Quadro K2100M). I then used the X config file creation tool (nvidia-xcofig) . Then on Bootup I got into a Blakscreen, I was able to log into TTY2 though. I then blacklisted the Intel driver, as suggested on the Arch wiki (
created /etc/modprobe.d/blacklist.conf
with contents:
install i915 /usr/bin/false
install intel_agp /usr/bin/false
Still, I got a Blackscreen. The weird Thing is, that I saw the Garuda splash screen shortly, before it goes back to black. How can i get the Nvidia Drivers to run?

Edit: Running Garuda Dragonized KDE edition, I am using a Lenovo Thinkpad W540 with the i5 and Quadro K2100M, Mesa DRI Intel(R) HD Graphics 4600 (HSW GT2)

Have you tried going into setting and Hardware configuration and auto installed Proprietary drives


If that doesn't work, try installing nvidia-lts and linux-lts and booting into that.