NVIDIA driver: N/A

Hi everyone, I have an Asus laptop with an Intel processor and an Nvidia graphics card, which is correctly detected by the system, but no drivers are loaded at all

inxi -Fxxxza

System:    Kernel: 5.11.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=f3a1c241-fa43-494e-8140-758f529935a7 rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 mitigations=off 
           Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Laptop System: ASUSTeK product: X550LD v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X550LD v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: X550LD.308 date: 04/17/2019 
Battery:   ID-1: BAT0 charge: 28.4 Wh condition: 28.4/37.4 Wh (76%) volts: 14.4/14.4 
           model: ASUSTeK X550A26 type: Li-ion serial: N/A status: Not charging cycles: 168 
CPU:       Info: Dual Core model: Intel Core i7-4500U bits: 64 type: MT MCP arch: Haswell 
           family: 6 model-id: 45 (69) stepping: 1 microcode: 26 L2 cache: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19155 
           Speed: 1796 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 1796 2: 1858 3: 1881 
           4: 1954 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: vulnerable 
           Type: mds status: Vulnerable; SMT vulnerable 
           Type: meltdown status: Vulnerable 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy 
           barriers only; no swapgs barriers 
           Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
           Type: srbds status: Vulnerable 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: ASUSTeK driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 class ID: 0300 
           Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] 
           vendor: ASUSTeK driver: N/A alternate: nouveau, nvidia_drm, nvidia bus ID: 04:00.0 
           chip ID: 10de:1140 class ID: 0302 
           Device-3: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 2-5:2 
           chip ID: 04f2:b40a class ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
           s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
           diag: 389mm (15.3") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.3.4 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 chip ID: 8086:0a0c class ID: 0403 
           Device-2: Intel 8 Series HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9c20 class ID: 0403 
           Sound Server: ALSA v: k5.11.6-zen1-1-zen 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: e000 bus ID: 02:00.1 chip ID: 10ec:8168 class ID: 0200 
           IF: enp2s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
           vendor: AzureWave driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
           chip ID: 168c:0036 class ID: 0280 
           IF: wlp3s0 state: up mac: <filter> 
Bluetooth: Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus ID: 2-6:4 
           chip ID: 13d3:3408 class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 931.52 GiB used: 14.4 GiB (1.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
           block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD 
           serial: <filter> rev: 4B6Q scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 1J scheme: GPT 
Partition: ID-1: / raw size: 100 GiB size: 100 GiB (100.00%) used: 14.38 GiB (14.4%) fs: btrfs 
           dev: /dev/sda5 maj-min: 8:5 
           ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) used: 25.5 MiB (26.5%) 
           fs: vfat dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw size: 100 GiB size: 100 GiB (100.00%) used: 14.38 GiB (14.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-4: /var/log raw size: 100 GiB size: 100 GiB (100.00%) used: 14.38 GiB (14.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-5: /var/tmp raw size: 100 GiB size: 100 GiB (100.00%) used: 14.38 GiB (14.4%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 
           dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 
           dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 
           dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 
           dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2500 
Info:      Processes: 224 Uptime: 17m wakeups: 1 Memory: 7.65 GiB used: 2.68 GiB (35.0%) 
           Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1439 
           lib: 348 Shell: fish v: 3.1.2 running in: alacritty inxi: 3.3.01 

Prime render offload is installed, but if I can't prime-run no applications.

prime-run nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

Then I tried sudo modprobe -v nvidia:

sudo modprobe -v nvidia

insmod /lib/modules/5.11.6-zen1-1-zen/kernel/drivers/video/nvidia.ko.xz "NVreg_DynamicPowerManagement=0x02"
modprobe: ERROR: could not insert 'nvidia': No such device

I tried creating a Xorg config file, specifying the BusID for both Intel and Nvidia card:

Section "Device"
  Identifier "iGPU"
  Driver "modesetting"
  BusID "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "iGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "dGPU"
  Driver "nvidia"
  BusID "PCI:4:0:0"
EndSection

but it didn't have any effect, inxi -Fxxxza is still showing "driver: N/A". My BIOS doesn't have any graphics switch options. Any help please?

1 Like

Which NVIDIA driver series support your GPU?

1 Like

It supports 390xx if it's what you mean

Yes; so, do you have the 390xx drivers installed?

pacman -Qs 390xx
dkms status
3 Likes
pacman -Qs 390xx

local/mhwd-nvidia-390xx 390.141-1
      mhwd-nvidia-390xx PCI ID database

dkms status

nvidia, 460.56, 5.11.6-zen1-1-zen, x86_64: installed

This means you have the nvidia driver installed, so swap those packages for nvidia-390xx:

sudo pacman -Syu nvidia-390xx-dkms nvidia-390xx-settings

Or, probably more easily, look in Garuda Hardware Manager and install the appropriate 390xx driver profile.

3 Likes

I tried installing from hardware manager but it says it conflicts with prime render offload. I tried to uninstall prime render offload a few days ago but it f***ed up my whole system. Guess I'll give up

Sure. Or you could try the other option I mentioned. :man_shrugging:

3 Likes

I tried installing from terminal too, using the commands you posted. This is the output:

sudo pacman -Syu nvidia-390xx-dkms nvidia-390xx-settings
[sudo] password di ayesse:
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
 chaotic-aur è aggiornato
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
:: nvidia-390xx-utils e nvidia-utils vanno in conflitto. Vuoi rimuovere nvidia-utils? [s/N] s
:: nvidia-390xx-settings e nvidia-settings vanno in conflitto. Vuoi rimuovere nvidia-settings? [s/N] s
:: libxnvctrl-390xx e libxnvctrl vanno in conflitto. Vuoi rimuovere libxnvctrl? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: la rimozione di nvidia-utils interrompe la dipendenza 'nvidia-utils=460.56' richiesta da nvidia-dkms

It tells me that some packages already installed conflict with the ones I want to install, and even if I accept to remove the old packages it ultimately says that I can't remove them because it will interrupt the dependencies

The idea is to replace all "nvidia" packages with "nvidia-390xx" packages. Therefore, you may need to remove these manually first.

Of course, Garuda Hardware Manager is also supposed to do this for you automatically, so if you could provide details about why that doesn't work it would help development of that tool.

3 Likes

As I wrote in the earlier post, if I try to install video-nvidia-390xx-dkms from the Hardware Manager it fails, giving me this error:

Error: config 'video-nvidia-390xx-dkms' conflicts with config(s): video-nvidia-prime-render-offload

I even tried to uninstall video-nvidia-prime-render-offload in an earlier Garuda installation but it f***ed up my whole system forcing me to do a clean installation

OK, with that error the information is more useful.

The 390xx driver doesn't have a render offload profile because the driver doesn't support render offloading - it needs something like Bumblebee or optimus-manager.

Hmm. Needs some thought, or a change to garuda-mhwd.

3 Likes

This is normal. You have to uninstall 1st the previous nvidia config (video-nvidia-prime-render-offload). Then install the right one.
You should have used the Auto-install proprietary drivers button. Selecting the wrong one manually created all this mess.
Use the terminal

sudo mhwd -r pci video-nvidia-prime-render-offload
sudo mhwd -i pci hybrid-intel-nvidia-390xx-dkms-bumblebee

Read usage instructions

mhwd -h
3 Likes

I tried using the auto install button, but it outputs this:

Starting

> Skipping already installed config 'video-nvidia-prime-render-offload' for device: 0000:00:02.0 (0300:8086:0a16) Display controller Intel Corporation Haswell-ULT Integrated Graphics Controller


Completed ...

I'll try with the terminal commands

1 Like