Nvidia coolbits have no effect - Overclock / Fanspeed not working

I am using Garuda KDE Dr460nized.

After looking at Overclocking and cooling and following the official instructions coolbits seem to have no effect.

Running this from the offical docs:

sudo nvidia-xconfig -a --cool-bits=28

/etc/X11/xorg.conf is updated

I reboot my computer but I still can't control my GPU with GWE - Green With Envy.

1 Like

After looking at the /etc/X11/xorg.conf file:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "28"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

this seems odd. Is this part for Coolbits even correct?
It's not wokring, so I started the hunt.

TL;DR

Go edit /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and add the Coolbits option.

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"
    Option     "Coolbits" "28"
EndSection

Why 28 you may ask? For further information read Overclocking and cooling

Reboot :arrows_clockwise:


@petsam
Sorry I just noticed this problem my self and came back to this issue to do some copy-pasta and saw your comment. :grimacing:

I will try adding the coolbits option to the /etc/X11/xorg.conf.d/90-mhwd.conf file and report back if this worked as expected.

oh and I can't edit my solution :thinking: guess because I did not touch this post in X time it got archived (kinda of?)

The /etc/X11/xorg.conf.d/90-mhwd.conf file after I added the coolbits option.

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"
    Option     "Coolbits" "28"
EndSection
4 Likes

Thanks for posting your solution, but when posting code, styling is not really a major concern. What is paramount is that the code be accurate IMO. I think introducing stylistic changes is only inviting errors from users who don't read carefully or perhaps aren't fluent in English.

Nice research.

Edit:

Thank you for removing the stylistic inclusions.

4 Likes

And fixed.

3 Likes

hi what i did was make a file in the dir called 10-nvidia.conf
with this in it:
Section "OutputClass"
Identifier "nvidia"
MatchDriver "nvidia-drm"
Driver "nvidia"
Option "AllowEmptyInitialConfiguration"
Option "Coolbits" "12"
ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection
and i can change my fan settings and was able to use green with envy but as long as i can set at startup my fan to 50-51% i'm good so i do it all the time after boot and login

This is not a permanent (and thus suggested against) change. After the next driver update, this file will be overwritten by the new package file.
Instead, edit /etc/X11/xorg.conf.d/ relevant files to add your coolbit settings.
Do so and test. Then change the "Solved" post, so future users don't do the same mistake, please.

1 Like

@petsam
Sorry I just noticed this problem my self and came back to this issue to do some copy-pasta and saw your comment. :grimacing:

I will try adding the coolbits option to the /etc/X11/xorg.conf.d/90-mhwd.conf file and report back if this worked as expected.

oh and I can't edit my solution :thinking: guess because I did not touch this post in X time it got archived (kinda of?)


The /etc/X11/xorg.conf.d/90-mhwd.conf file after I added the coolbits option.

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"
    Option     "Coolbits" "28"
EndSection
2 Likes

I am the copy and paste master after Theodor von und zu G. :smiley:

2 Likes

I can conclude that /etc/X11/xorg.conf.d/90-mhwd.conf is the file to go.

Could someone from the @staff be so nice to either allow me to edit my solution or edit it for me?
That be really great.

Thanks!

1 Like

What do you mean?
Your post is marked as Solution.
Check 1st post in topic.
Maybe a forum cache issue? Refresh your page or clean browser cache?


and

It looks like I can only edit posts that are not older then 24 hours.
For example the post where I mentioned you in the first place, I also can no longer edit.

I really don't understand.
Is it not the correct solution?
If you think it's not, write your supposed solution to a post and mark it as solution, or I can do it, if the forum configuration stops you from it. Just say it.

There are some forum restrictions set from forum admins, that I cannot change myself.
If you like, you may complain at #feedback category about forum functionality.
Sorry for that.

No you got me totally wrong, I suppose. :grimacing:

So I had an issue and supposedly fixed it. So I marked my own reply as a solution.
So far so good.

Now after X time I had the same issue again and noticed that YOU told me that my solution is only partly correct.

With the current discourse (forum) settings / restrictions I as a user have three options when this happens. (or do I miss something?)

  1. I write a new reply with the new solution and mark the response as solution
    contra is, that the old reply is still there and could confuse future readers.
  2. I copy the old solution, delete the old reply, create a new reply paste and edit it and mark it again as solution. (Which shifts the whole topic discussion and can lead to a discussion without context)
    contra also not so nice since now there is a "Post got deleted by user" message
  3. I ask the staff to please fix the solution with the new one.
    contra I have to annoy the staff to do the edit

So whats next time when variable X changes and I need to edit the solution again?
Well... back to the three options I guess?

I did not intend to complain, not at all!
I just noticed I cant edit it and tried my best to keep the forum clean. :dizzy_face:

2 Likes

This is a protective function against spammers who first post normally and then post advertisements or other things weeks later.
Depending on your Trust Level (TL), the number of days you can do this increases.
The more often you visit the forum and actively participate, the higher the TL.

1 Like

It seems you are new on Discourse workflow :wink:

Anyone (I think) can view post changes, or recent deleted posts, so can see the difference.
Post deleted is not a crime.

Correct. Don't do what you can do yourself :laughing:

The correct one.
Users are not confused, as they see the solution post, linked in the 1st topic post.
Whoever is confused with this, there is no salvation... :rofl:

2 Likes

this setting is not persistent you have to set it after every boot .
I'm not aware /how to make it so

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.