Nvidia and Hybrind graphical issues

Ongoing issues with new install image regardless of which image version to install.
I got an Alienware x17r1.
CPU: 11th Gen Intel i7-11800H (16) @ 4.6GHz
GPU: NVIDIA GeForce RTX 3070 Mobile / Max-Q and
GPU: Intel TigerLake-H GT1 [UHD Graphics]
Memory: 5.32GiB / 30.99GiB
GUI: KDE (tried with other images same issue)

Issue 1:

You last working image to even make it to the install screen was 220308. Any image version after this hangs after selecting boot with open source or proprietary regardless witch option I pick. I read it in your earlier post the Nvidia Optimus Manager was removed from the install image. Can there be a connection? Was image 220308 the last one using it? Is there a connection here? Not sure what Garuda team did after this image but non of them even make it to the install screen. I was hoping to wait a few new images to see if it will be resolved but non of them fix it.

Issue 2: Alienware x17R1 have a hybrid video card system as shows in the above specs detail. I also tried switching off the the hybrid graphics in my BIOS so only the dedicated graphics my NVIDA RTX 370 shows up. Same problem, Garuda image after 220308 won't even boot.

Issue 3: I never deleted the last working image 220308 from the beginning of the year and that's how I can still use Garuda on my laptop. The problem is using the last working image Garuda seem to only use my onboard: Intel TigerLake-H GT1 [UHD Graphics] while when I check in the system the RTX card also shows up but never switches for me to able to use them. Anything I run only uses the Intel GPU. When the system already installed and fully updated going into BIOS and switching hybrid graphics off the system won't even boot just hangs like it did on the install image until I turn BIOS hybrid graphics back on again. I also ran Manjaro and Ubuntu on this system both boots and works with hybrid graphics on Garuda looks like a very dedicated team to make a top Linux but it's pretty sad being advertised as a gaming Linux while Manjaro and Ubuntu runs my hardware flawlessly yet Garuda not only haven't been able to identify this issue but going backwards as it won't work at all after image 220308.

As I said, I installed from last working image 220308 and been using Garuda like this hoping one of the updates in the future will fix the GPU issue. Meanwhile when I play on steam I need to boot into Manjaro or Ubuntu that switches to my dedicated gpu when I play games which Garuda still doesn't do.

I'm reaching out here to see how the community response as I love Garuda Linux looks and speed (KDE) and I love to make it as my main OS but having a "gaming" Linux which can't handle my vidoe cards kind of defeats the purpose. Doesn't it? Gaming Linux which doesn't work with a gaming laptop (Alienware) what a joke.

Please guys look into it. Looking forward to the responses I get to see how the Garuda community response to users.

Kind Regards
BlackSheep

Hi there, welcome to the forum.
I would pass over the ISO image issue for now, as I understand that you currently have your system installed (using the old image) and I believe updated.
If the current problem with the installed system is that you cannot boot with proprietary drivers, you should take a look here (add the ibt=off kernel boot parameter, due to a known Nvidia problem with the latest Intel processors) any many other releated topics.
On the other hand, if you have problems installing proprietary drivers, you should provide more information, like what error messages you get.

This is fine, however you should familiarize yourself with the forum and search functions. You will definitely find a lot of useful information. In fact, your profile shows that you have not searched much...
immagine

3 Likes

filo wrote a nice and detailed response but IMO all of the problems have the same cause. Open the file /etc/default/grub with a text editor, add ibt=off to the end of the lines which start with GRUB_CMDLINE_LINUX and GRUB_CMDLINE_LINUX_DEFAULT, save, run

grub-mkconfig -o /boot/grub/grub.cfg

and reboot.

I prefer to blame Nvidia who couldn't be bothered to fix this issue which is known and has a known solution for 3 months.

4 Likes

Thank you Filo for the nice quick response,

I have tried your suggestion added the ibt=off, updated then restart.
The computer briefly showed my Garuda loading screen but before it fully loaded for me to log in the screen when black and crashed. It bricked my system. Luckily I booted into Manjaro reversed the added line, restarted Garuda and quickly switched to CLI updated grub again hit restarted and saved my OS now back to square one. To clarify some of your points.

  • Yes, the system up to date and I been running it like this from the last working Image from Late May.
    My system is running 4 OS Garuda, Manjaro, Ubuntu and Windows 11 and having my hybrid graphics setting ON in the BIOS. As all operating system except Garuda running it smoothly.
  • As I mentioned I briefly turned hybrid off to check if the existing Install and the newest downloaded image could handle with only the dedicated graphics on only. I'm afraid both failed the newest image would get pass the installation select screen. Regardless selecting proprietary or nouveau both stuck even before making it to the loading screen. With the existing install also stuck the same way until I go and turn the hybrid graphics back on. Assuming the system only able to use the onboard Intel driver. Note this is only the case with using the old 220308 image. Anything newer image won't even start regardless of hybrid graphics ON or OFF in the BIOS settings.
  • My working install is running the proprietary driver at the moment but I'm pretty sure it only runs the onboard Intel GPU very likely ignoring the dedicated RTX 370.
  • If you can give me a detailed breakdown step by step what to do to fish out the error messages you looking for very happy to do so.
  • It would be my pleasure to help improving the Garuda experience by giving as much info as I can.
  • I been a Manjaro users for years but started heavily favoring Garuda the end goal would be that we make Garuda handles the Alienware hardware as smooth as Manjaro or Ubuntu without eventually needed to open up the terminal. Until we get there where happy to give you feedback especially over Manjaro as it also based on Arch Linux therefore a lot of bugs can't be blamed on Arch if it works well under Manjaro. Lastly I have looked at some Garuda forums before with my friend in Germany also using Garuda Linux but had almost no activity on this account yet. I appreciate your professionalism and kindness.

to answer to mrvictory,

I really appreciate your step by step instructions how on how to try to fix it, unfortunately it brick the system and the fallback kernel didn't work either. Had to log into Manjaro re-edit the grub back to where it was. Rest of the story in my above reply.

As for the Nvidia issues YESSSS, the big finger still applies to Nvidia from Linus Tolvalds. They mess up the driver updates and still a nightmare if you trying to use wayland. The thing is that Manjaro and Ubuntu seem to somehow still make it work. I prefer using AMD CPU,GPU because of Linux support. My home PC is all AMD. However Alienware X series only come with Nvidia GPU and the moment. Staying overseas for this year only having the Alienware X17 I need to make this Nvidia work which in most cases started to work better and better with Linux distros given only with baby steps as Nvidia poor support. Despite Nvidia shortcomings let's make Garuda the best of Linuxes that can handle any hardware.

Okay, please for the moment provide, from Garuda, your garuda-inxi.
That way, someone more technical than me (I am essentially a moderator and do not use Nvidia cards) can suggest the next steps.
In addition, I believe that

prime-run glxinfo -B | grep "OpenGL vendor string"

might clarify whether your discrete GPU is using with Nvidia drivers, and perhaps if so try running a game with prime-run. See:

2 Likes

Thank you Filo,

I will look into it when I get home.

Good morning Filo, here is my inxi

System:
Kernel: 5.19.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c10ac857-ce28-451b-ae70-ddb59e6df037 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Alienware product: Alienware x17 R1 v: 1.11.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Alienware model: Alienware x17 R1 v: A00
serial: <superuser required> UEFI: Alienware v: 1.11.0 date: 07/07/2022
Battery:
ID-1: BAT1 charge: 71.3 Wh (100.0%) condition: 71.3/87.0 Wh (81.9%)
volts: 12.6 min: 11.4 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: full
CPU:
Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
model-id: 0x8D (141) stepping: 1 microcode: 0x40
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 2213 high: 2300 min/max: 800/4600 scaling:
driver: intel_pstate governor: performance cores: 1: 2300 2: 2300 3: 2300
4: 923 5: 2300 6: 2300 7: 2300 8: 2300 9: 2300 10: 2300 11: 2300 12: 2300
13: 2300 14: 2300 15: 2300 16: 2300 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
bus-ID: 0000:00:02.0 chip-ID: 8086:9a60 class-ID: 0300
Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Dell
driver: N/A alternate: nouveau, nvidia_drm, nvidia non-free: 515.xx+
status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:24dd
class-ID: 0300
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 3-7:4 chip-ID: 0c45:6d18 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
s-diag: 1165mm (45.88")
Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x2892 built: 2021
res: 3840x2160 hz: 60 dpi: 257 gamma: 1.2 size: 380x210mm (14.96x8.27")
diag: 437mm (17.2") ratio: 16:9 modes: 3840x2160
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: Dell
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:43c8 class-ID: 0401
Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228b class-ID: 0403
Sound Server-1: ALSA v: k5.19.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169 v: kernel
port: 3000 bus-ID: 0000:3b:00.0 chip-ID: 10ec:3000 class-ID: 0200
IF: enp59s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 0000:3c:00.0 chip-ID: 8086:2725
class-ID: 0280
IF: wlp60s0 state: up mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-14:6 chip-ID: 8087:0032 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
class-ID: 0104
Drives:
Local Storage: total: 2.75 TiB used: 298.99 GiB (10.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus
2TB size: 1.82 TiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7
temp: 52.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Micron model: 2300 NVMe 1024GB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 23000030
temp: 49.9 C scheme: GPT
Partition:
ID-1: / raw-size: 428.8 GiB size: 428.8 GiB (100.00%) used: 298.11 GiB
(69.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%) used: 900.2 MiB
(90.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 428.8 GiB size: 428.8 GiB (100.00%) used: 298.11
GiB (69.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 428.8 GiB size: 428.8 GiB (100.00%) used: 298.11
GiB (69.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 428.8 GiB size: 428.8 GiB (100.00%) used: 298.11
GiB (69.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.99 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.18 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 365 Uptime: 11m wakeups: 3 Memory: 30.99 GiB used: 4.19 GiB
(13.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pacman: 2091 lib: 566
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-12
Last full system update: 2022-09-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:
McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cmd_tpl to commands (duplicate column name: cmd_tpl)', src/history/schema.rs:41:17
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

I edited your post to format the text from terminal.

This means that the driver is installed but not loaded.
Maybe you could try a

sudo dkms autoinstall

and check the status and the referenced logs in the (likely) case of errors.
Maybe reboot before that, since the last symbol here indicates that the system has not yet been rebooted after the last update.

Finally, always in the logic of providing information to those I hope will follow in the troubleshooting :wink:, could you please specify how the Nvidia were installed (e.g. HW assistant (Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration) or what?
If the sudo dkms autoinstall doesn't help, and untill we get better technical support, my last suggestion would be to try reinstalling with the same command executed by the HW assistant:

sudo mhwd -a pci nonfree 0300
4 Likes

Sorry Filo I just copy paste from terminal. Let me know what is the best way to paste it here.
To Answer your questions:

  • I have installed Garuda from last working image 220308 by selecting the option "Boot allowing proprietary drivers (NVIDIA)
  • When Garuda started the first time Assistant went through the usual software I want to install with Garuda. This process included with a message that system will install latest NVIDIA proprietary drivers. clicked yes.
  • From this point when I updated on a daily basis with command garuda-update if there was a new driver available it was automatically loaded and I can still see to this day when a newer version comes through the update.
  • trying sudo dkms autoinstall - getting this error message:

Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/515.57/source/dkms.conf does not exist.
McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cmd_tpl to commands (duplicate column name: cmd_tpl)', src/history/schema.rs:41:17
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

- When I tried sudo mhwd -a pci nonfree 0300 here is what I got:

Using config 'video-nvidia-prime-render-offload' for device: 0000:01:00.0 (0300:10de:24dd) Display controlle
r nVidia Corporation GA104M [GeForce RTX 3070 Mobile / Max-Q]
Using config 'video-nvidia-prime-render-offload' for device: 0000:00:02.0 (0300:8086:9a60) Display controlle
r Intel Corporation TigerLake-H GT1 [UHD Graphics]
Installing video-nvidia-prime-render-offload...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-prime-render-offload/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
community downloading...
multilib downloading...
chaotic-aur downloading...
blackarch downloading...
resolving dependencies...
looking for conflicting packages...
:: garuda-nvidia-prime-config and garuda-optimus-manager-config are in conflict. Remove garuda-optimus-manager
-config? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

:: garuda-nvidia-prime-config and garuda-optimus-manager-config are in conflict
Error: pacman failed!
Error: script failed!
McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cm
d_tpl to commands (duplicate column name: cmd_tpl)', src/history/schema.rs:41:17
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

- clearly garuda-nvidia-prime-config and garuda-optimus-manager-config are in conflict
naturally you would say just remove optimus-manager-config that will reinstall you driver. However to my understanding from past forums Garuda Image 220308 was the last one that loaded in optimus-manager by default. Every new Garuda image after 220308 I try to install, does not even make it to the boot screen regardless of me leaving hybrid graphics ON or OFF in BIOS. Based on this I have a feeling removing optimus-manager and let the driver reinstall will break my system as it always done in the past with every new Garuda Image after 220308.

Happy to upload pictures how my hardware configurations show at the moment also some install errors to help the team with the answers. Unfortunately I get the message New users can't upload pictures.

Thank you Filo, Here is the image how my hardware configuration looks at the moment. Really had to dumb down the picture to be accepted by the upload. Still visible enough.

I also gave a quick try to the latest Garuda Image 220822 to see if there is any improvements with MHWD. Fails as any other Image after 220308 to make it to the boot screen.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.