"nvidia-390xx-settings" package missing when installing the GPU drivers


Before I begin with anything, I want to state that I am a complete newbie to the Linux environment, so I may have done something wrong or may not exactly understand what to do.

So, this is the first time ever I have installed a Linux OS on my old laptop with a 3rd gen i7 and a GT-635M, and have been struggling to get the GPU drivers to install on this system. Whenever I use the setup assistant, the prompt for installing drivers in the terminal always ends with the script being stopped, because one of the packages is missing- it's the"nvidia-390xx-settings" package, just like it is shown below. I also tried installing the drivers from the settings manager manually, but it ended with the same result.
Here is what the terminal says:

Waiting for user input...


> Installing video-hybrid-intel-nvidia-390xx-dkms-bumblebee...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-390xx-dkms-bumblebee/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

:: Synchronizing package databases...

garuda downloading...

core downloading...

extra downloading...

community downloading...

multilib downloading...

chaotic-aur downloading...

warning: nvidia-390xx-utils-390.157-3 is up to date -- skipping

error: target not found: nvidia-390xx-settings

warning: nvidia-390xx-dkms-390.157-3 is up to date -- skipping

warning: nvidia-390xx-dkms-390.157-3 is up to date -- skipping

warning: nvidia-390xx-dkms-390.157-3 is up to date -- skipping

Error: pacman failed!

Error: script failed!

I have no idea what to do to fix it. Any kind of help will be greatly appreciated.

The post form also said to attach the system information, so here it is:

Kernel: 6.2.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0489f185-f54f-455f-8b64-efdafaebc217 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: K75VJ v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: K75VJ v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: 230 date: 01/24/2013
ID-1: BAT1 charge: 43.2 Wh (90.0%) condition: 48.0/48.0 Wh (100.0%)
volts: 11.7 min: 10.9 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: discharging
Info: model: Intel Core i7-3630QM bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2795 high: 3400 min/max: 1200/3400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2496 2: 1197 3: 3400
4: 3400 5: 3400 6: 3400 7: 3400 8: 1671 bogomips: 38313
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK driver: i915
v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GF108M [GeForce GT 635M] vendor: ASUSTeK driver: nvidia
v: 390.157 alternate: nouveau,nvidia_drm non-free: series: 390.xx+
status: legacy-active (EOL~late 2022) arch: Fermi code: GF1xx
process: 40/28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:0de3 class-ID: 0300
Device-3: Suyin UVC HD Webcam type: USB driver: uvcvideo bus-ID: 2-1.4:5
chip-ID: 064e:d213 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau failed: nvidia
alternate: fbdev,intel,nv,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
s-diag: 485mm (19.11")
Monitor-1: LVDS-1 model: AU Optronics 0x149e built: 2011 res: 1600x900
hz: 60 dpi: 106 gamma: 1.2 size: 382x214mm (15.04x8.43") diag: 438mm (17.2")
ratio: 16:9 modes: 1600x900
API: OpenGL v: N/A renderer: N/A direct-render: N/A
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0bea class-ID: 0403
API: ALSA v: k6.2.11-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter
vendor: AzureWave driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:0032 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-1: IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter type: USB
driver: btusb v: 0.8 bus-ID: 2-1.1:6 chip-ID: 13d3:3362 class-ID: e001
serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 810.43 GiB used: 25.22 GiB (3.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: POLION 120GB size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 3G50 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD7500BPVT-80HXZT3 size: 698.64 GiB block-size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: GPT
ID-1: / raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 25.22 GiB (22.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 25.22 GiB (22.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 25.22 GiB (22.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 25.22 GiB (22.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.56 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 6280.4 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 242 Uptime: 7m wakeups: 1 Memory: 11.56 GiB
used: 2.39 GiB (20.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1862
libs: 545 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-18
Last full system update: 2023-04-19 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Can you try again, please? :eyes:


Maybe it couldn't find it because its just in the AUR from what I can tell.
Not sure of its current state other than there is a recent post there about a failed build attempt. Looks like somebody has been trying to keep it going since Jonathon's passing though.

You can try it yourself to see how it goes.
Open up Konsole.
paru -S nvidia-390xx-settings
enter "Y" to review. Then hit "Q" to exit the review. Then "Y" to install.


It actually worked! The hybrid drivers installed with no issues. Thank you so much :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.