Numlock on bootup

Hello!
Enjoying my stay on Garuda so far. Thank you to all the devs for all the hard work they have sacrificed for this project so far.

I recently ran into a little problem and it seems like I won't be able to solve it on my own. So I'd love to ask if you have any tips on how to enable numlock after booting.

What I've tried:
Enabling numlock in UEFI
I don't have any numlock options in UEFI setup, so this won't actually lead anywhere.

Enabling numlock in KDE settings
This option works fine, but only after logging in.

Enabling numlock using systemd service
I did everything according to the Arch wiki page and the result was pretty funny. It turned on the numlock LED indicator but not the numlock itself

Enabling numlock using mkinitcpio-numlock package
Has the same problem as the systemd service option. LED light is on but numlock isn't.

Enabling numlock using numlockx package
The numlockx command works perfectly fine when I run it in terminal, but when I put numlockx & before the exec plasma-x11 in ~/.xinitrc, nothing happens after boot.

Hi there, welcome to the community.
You should try editing /etc/sddm.conf and in general section, put Numlock=on

Also post output of

inxi -Faz 

As text.

5 Likes

Omg, thank you! I didn't realize it can be done this easily. I remember I used to do it using the systemd service but there's this weird bug now.

Here's the output:

System: Kernel: 5.12.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ca268938-4149-4f7d-80db-fb15024c1169
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=f4cd6133-e692-4c46-844f-cd1cf151ceab loglevel=3
Desktop: KDE Plasma 5.22.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine: Type: Laptop System: Acer product: Aspire A515-51G v: V2.02 serial:
Mobo: KBL model: Charmander_KL v: V2.02 serial: UEFI: Insyde v: 2.02 date: 01/03/2019
Battery: ID-1: BAT1 charge: 44.7 Wh (100.0%) condition: 44.7/48.9 Wh (91.4%) volts: 16.8 min: 15.2
model: LG 004B384234314341 type: Li-ion serial: status: Full
CPU: Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake
note: check family: 6 model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599
Speed: 3101 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3101 2: 3101 3: 3100 4: 3100
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Acer Incorporated ALI driver: nvidia v: 465.31
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:134d class-ID: 0302
Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:6 chip-ID: 04f2:b5f7
class-ID: 0e02
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.3 direct render: Yes
Audio: Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.12.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.30 running: no
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI
driver: r8169 v: kernel port: 3000 bus-ID: 02:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0f1 state: down mac:
Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: 3000
bus-ID: 03:00.0 chip-ID: 8086:24fb class-ID: 0280
IF: wlp3s0 state: up mac:
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-5:5
chip-ID: 8087:0aa7 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address:
Drives: Local Storage: total: 1.14 TiB used: 35.82 GiB (3.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial:
rev: 3B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B rotation: 5400 rpm serial: scheme: GPT
Partition: ID-1: / raw-size: 145.83 GiB size: 145.83 GiB (100.00%) used: 32.94 GiB (22.6%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 257 MiB size: 253 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 78.03 GiB size: 78.03 GiB (100.00%) used: 2.88 GiB (3.7%) fs: btrfs
dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 145.83 GiB size: 145.83 GiB (100.00%) used: 32.94 GiB (22.6%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 145.83 GiB size: 145.83 GiB (100.00%) used: 32.94 GiB (22.6%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap: Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8.77 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4
maj-min: 8:4
ID-2: swap-2 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors: System Temperatures: cpu: 53.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info: Processes: 242 Uptime: 5m wakeups: 1 Memory: 7.64 GiB used: 2.67 GiB (35.0%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1743 lib: 547
Shell: fish v: 3.2.2 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.04

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.