NTFS read only, yet can make new folders

I have tried ntfsfix and after it could not remount the drives. So booted into Hirens Boot Cd to run chkdsk and drives automounted as I want. Still no full write access for existing files, yet I can create a new folder and add new files and read and write in new folders.

device                 fs_type    label       mount point                UUID
-------------------------------------------------------------------------------------------------------------
/dev/sdc1              btrfs                  (in use)                   b4e3b216-a092-473e-8800-311bb9cd5561
/dev/sdb1              ntfs       The stuff of dreams /mnt/The\x20stuff\x20of\x20dreams 01CADF1A7CD5A380
/dev/sdc2              swap       swap        [SWAP]                     0a35d60e-8805-41fb-8ce2-ebab30994957
/dev/sda1              ntfs       About time  /mnt/About\x20time         0CA111DE0CA111DE
/dev/zram0             swap       zram0       [SWAP]                     6b229e81-c7cd-41ac-83da-156a34275bfb
sudo umount /dev/${DRIVE}
sudo ntfsfix /dev/${DRIVE}
sudo mount -a
System:
  Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b4e3b216-a092-473e-8800-311bb9cd5561 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=0a35d60e-8805-41fb-8ce2-ebab30994957 loglevel=3
  Desktop: GNOME v: 42.0 tk: GTK v: 3.24.33 info: cairo-dock
    wm: gnome-shell dm: GDM v: 42.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Dell product: Inspiron 530 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 0FM586 serial: <superuser required> BIOS: Dell
    v: 1.0.18 date: 02/24/2009
CPU:
  Info: model: Intel Core2 Quad Q6600 bits: 64 type: MCP arch: Core Merom
    family: 6 model-id: 0xF (15) stepping: 0xB (11) microcode: 0xBA
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1597 high: 1600 min/max: 1600/2400 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1596 2: 1596 3: 1596
    4: 1600 bogomips: 19151
  Flags: ht lm nx pae sse sse2 sse3 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GT200 [GeForce GTX 260] vendor: eVga.com. driver: nouveau
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports: active: DVI-I-2
    empty: DVI-I-1 bus-ID: 01:00.0 chip-ID: 10de:05e2 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: nouveau unloaded: modesetting
    alternate: fbdev,nv,vesa gpu: nouveau display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: DVI-I-2 model: LG (GoldStar) TV serial: <filter> built: 2010
    res: 1920x1080 dpi: 305 gamma: 1.2 size: 160x90mm (6.3x3.54")
    diag: 184mm (7.2") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 82801I HD Audio vendor: Dell Inspiron 530
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:293e
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
  Device-1: Intel 82562V-2 10/100 Network vendor: Dell Inspiron 530
    driver: e1000e v: kernel port: ff00 bus-ID: 00:19.0 chip-ID: 8086:10c0
    class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Realtek 802.11ac NIC type: USB driver: rtl8821cu bus-ID: 1-6:4
    chip-ID: 0bda:c811 class-ID: 0000 serial: <filter>
  IF: wlp0s26f7u6 state: up mac: <filter>
Drives:
  Local Storage: total: 2.27 TiB used: 1.6 TiB (70.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD1001FALS-40U9B0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 4F20
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD1001FALS-00J7B1 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 0K05
    scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: PNY model: CS900 500GB SSD
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 0615 scheme: MBR
Partition:
  ID-1: / raw-size: 457.34 GiB size: 457.34 GiB (100.00%)
    used: 13.2 GiB (2.9%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
  ID-2: /home raw-size: 457.34 GiB size: 457.34 GiB (100.00%)
    used: 13.2 GiB (2.9%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
  ID-3: /var/log raw-size: 457.34 GiB size: 457.34 GiB (100.00%)
    used: 13.2 GiB (2.9%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
  ID-4: /var/tmp raw-size: 457.34 GiB size: 457.34 GiB (100.00%)
    used: 13.2 GiB (2.9%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.83 GiB used: 141.2 MiB (3.6%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.42 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdc2 maj-min: 8:34
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 212 Uptime: 22m wakeups: 0 Memory: 3.83 GiB
  used: 2.35 GiB (61.4%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1227 lib: 315 Shell: fish v: 3.4.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.1-3):
  System install date:     2022-04-24
  Last full system update: 2022-04-25
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:

Open terminal, check /dev/sdb1

ls -la

for owner

Check

pacman -Qi ntfsprogs

1 Like
 ╰─λ ls -la /dev/sdb1
brw-rw---- 8,17 root 25 Apr 16:05  /dev/sdb1


 ╰─λ pacman -Qi ntfsprogs
Name            : ntfsprogs-ntfs3
Version         : 2021.8.22-9
Description     : NTFS filesystem utilities without NTFS-3G driver. For system with kernel >= 5.15
Architecture    : x86_64
URL             : https://www.tuxera.com/company/open-source/
Licenses        : GPL2
Groups          : None
Provides        : ntfsprogs  ntfs-3g
Depends On      : util-linux
Optional Deps   : None
Required By     : None
Optional For    : udisks2
Conflicts With  : ntfsprogs  ntfs-3g
Replaces        : ntfsprogs
Installed Size  : 1576.78 KiB
Packager        : Nico Jensch <[email protected]>
Build Date      : Sun 27 Feb 2022 04:46:19 AM CST
Install Date    : Mon 28 Mar 2022 10:59:58 PM CDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Walk in terminal to the file you want to edit and check owner.

root files you can only use with root, but ntfs files I think do not needed.
What tell the arch wiki and the web about?

1 Like

Test out the older ntfs3g package, or better yet just deep six ntfs on Linux.

1 Like

I don't even know how to try the older NTFS3g package nor deep six.

Install ntfs3g:

sudo pacman -Syu ntfs3g
2 Likes
error: target not found: ntfs3g

ntfs-3g :slight_smile:

1 Like

Try a search in your package manager. I don't use ntfs, and if you were smart you wouldn't either.

sudo pacman -Syu ntfs-3g
5 Likes

That worked going back to the older package of ntfs-3g. The drives are older storage drives and sometimes are used in windows boxes. I need more drives or need to change the file system. I am trying to break free from winblows and stay on linux.

I do most certainly appreciate all the help.

1 Like

So if there is an update I will have to revert back this ntfs-3g again?

The devs have just reverted to using ntfs-3g, as ntfsprogs has been having issues since its adoption.

No worries.

2 Likes

I really should get a new storage drive and keep it away from NTFS. Just need the funds. As you can see I am using some old hardware. Even my better PC is still old. Hopefully next few months I can build a new pc. Thanks for being helpful either way.

1 Like

how old is your comp

I also keep backups in NTFS on an old external spinner that hasn't been shut down for the past 15 years except when power has failed. It's handy, since Linux reads/writes about anything, and also since Paragon's Ext drivers suck ass.

Guess what other filesystems Paragon maintains, anyone?

Yes, Paragon's NTFS driver seems to be having a lot of problems since its inclusion in the kernel. @librewish reverted back to the old ntfs-3g driver yesterday as there has been too many reports of problems with the new Paragon NTFS driver.

4 Likes

This PC is from 2009, but it does well with linux. Not gonna be gaming on it but for daily things it's perfect. Not my only PC though. Yet I do not own anything from the last 5 years.

Has that change been made to the .ISO down load already? I like to keep them on a ventoy USB.