Nothing works after booting

Hello, I just booted my PC and almost nothing was loaded. The menu bar, the dock, etc. Even pressing the windows key don't work.

This happened to me a few times in the past, and I just reinstalled Garuda and it worked again, but I want to fix this problem once and for all without reinstalling every time.

Thanks

With issues like that we are really going to need the output of the inxi -Faz command.

1 Like

Here is the output:

System:
Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2388a6d1-7c1f-4a3a-a706-424269cd9d94 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: A320M-HD serial: <superuser required>
UEFI: American Megatrends v: P5.40 date: 07/09/2019
CPU:
Info: model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen/Zen+ note: check family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108102
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2814 high: 2975 min/max: 1400/3600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2365 2: 2959
3: 2959 4: 2975 bogomips: 28799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: ASRock
driver: amdgpu v: kernel bus-ID: 03:00.0 chip-ID: 1002:7340 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.5x11.5") diag: 598mm (23.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 03:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel bus-ID: 09:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel port: e000 bus-ID: 08:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 47.58 GiB (4.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-75WN4A1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 7113 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Lexar model: 256GB SSD
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 505 scheme: GPT
Partition:
ID-1: / raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 22.17 GiB (9.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 22.17 GiB (9.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 22.17 GiB (9.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 22.17 GiB (9.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.61 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 35.0 C mem: 0.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 266 Uptime: 0m wakeups: 0 Memory: 15.61 GiB
used: 2.37 GiB (15.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1193 lib: 301 Shell: fish
v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.11
McFly: Upgrading McFly DB to version 3, please wait...thread 'main' panicked at 'McFly error: Unable to add cm
d_tpl to commands (duplicate column name: cmd_tpl)', src/history/schema.rs:41:17
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace

Please post always in- and output from terminal text. No problem for inxi, but for other inputs it is important. :slight_smile:

If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.
greetings SGS

Could you post your Journal Errors as well? You can get those from Garuda Assistant > Other Diagnostics tab> Journal Errors button, then hit the Copy for Forum button. (if there is nothing much there currently, try grabbing them again when your issues start cropping up; there could be HDD issues or something).

Open garuda assistant, go down to where it says reset configs, select latte dock and then apply. Reboot and now your UI should be back.

2 Likes

This is probably the only part that may be helpful, the other logs were related to sudo commands

jan 14 10:11:10 imperium kernel: usb 3-2: device descriptor read/64, error -71

jan 14 10:11:10 imperium kernel: usb 3-2: device descriptor read/64, error -71

jan 14 10:11:10 imperium kernel: usb 3-2: device descriptor read/64, error -71

jan 14 10:11:10 imperium kernel: usb 3-2: device descriptor read/64, error -71

jan 14 10:11:10 imperium kernel: usb 3-2: device not accepting address 4, error -71

jan 14 10:11:10 imperium kernel: usb 3-2: device not accepting address 5, error -71

jan 14 10:11:10 imperium kernel: usb usb3-port2: unable to enumerate USB device

I tried this command: cp -rf /etc/skel/. ~/ rebooted, and it worked. I think that sometimes, for some reason, my PC removes some dot files from my home directory, does that make sense?

That's what I told you to do, except without deleting all other configs:

But the problem was not only with latte dock, but with other things as well

The menu bar, dock, windows key and stuff are all part of latte-dock in this case. You didn't mention anything else so I assumed latte dock was the problem.

1 Like

usb usb3-port2: unable to enumerate USB device

I find this error is usually corrected by adding the iommu=soft kernel parameter. Search the forum or the Archwiki for the procedure involved in changing a kernel parameter.

1 Like

Oh... this might explain the lack of responsiveness after a reboot if its related to an issue I helped with recently.
I helped a Garuda user troubleshoot an issue a while back (not on the forums) that had this error in the logs and found out it was because it was trying to connect to a wireless keyboard first after login (keyboard that was off and using a 2.4ghz wireless USB receiver), and the user had also a wired keyboard connected. While the issue was going, after logging in the system would be very unresponsive for a long period of time.
I would check for anything like that on your setup (powered down devices using a wireless receiver, etc).

As a trouble shooting step unplug your wireless USB receivers (or similar) when you shut down. After you log in plug them back in.

1 Like