Not showing all of my ram in htop and the GiB to GB isnt correct

  Kernel: 6.8.6-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
    root=UUID=db05dcca-0eb3-4066-b78a-e89b17fc3fed rw rootflags=subvol=@
    resume=UUID=17fa688b-fb04-4e51-a854-7a52cce563f3 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.1.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
  Type: Laptop System: LENOVO product: 82UH v: Legion 7 16ARHA7 serial: <superuser required>
    Chassis: type: 10 v: Legion 7 16ARHA7 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN serial: <superuser required>
    part-nu: LENOVO_MT_82UH_BU_idea_FM_Legion 7 16ARHA7 uuid: <superuser required> UEFI: LENOVO
    v: K9CN42WW date: 03/10/2023
  ID-1: BAT0 charge: 89.4 Wh (90.0%) condition: 99.3/99.9 Wh (99.4%) power: 22.5 W volts: 16.9
    min: 15.5 model: S�nwoa L21D4PC2 type: Li-poly serial: <filter> status: discharging cycles: 9
  Info: model: AMD Ryzen 9 6900HX with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x44 (68)
    stepping: 1 microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 977 high: 1739 min/max: 400/4935 scaling: driver: amd-pstate-epp
    governor: powersave cores: 1: 400 2: 400 3: 1575 4: 400 5: 1334 6: 400 7: 1385 8: 1380 9: 400
    10: 400 11: 1349 12: 400 13: 1364 14: 1352 15: 1739 16: 1369 bogomips: 105442
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT] vendor: Lenovo
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1, DP-2, HDMI-A-1, Writeback-1,
    eDP-1 bus-ID: 03:00.0 chip-ID: 1002:73df class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu v: kernel arch: RDNA-2
    code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: eDP-2 empty: DP-3, DP-4, DP-5, DP-6, DP-7, DP-8, Writeback-2 bus-ID: 37:00.0
    chip-ID: 1002:1681 class-ID: 0300 temp: 37.0 C
  Display: wayland server: v: with: Xwayland v: 23.2.6 compositor: kwin_wayland
    driver: X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu,amdgpu display-ID: 0
  Monitor-1: eDP-2 res: 1969x1231 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi device: 1
    drv: radeonsi device: 2 drv: swrast gbm: drv: radeonsi surfaceless: drv: radeonsi wayland:
    drv: radeonsi x11: drv: radeonsi
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.5-arch1.1 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi rembrandt LLVM 17.0.6 DRM 3.57
    6.8.6-AMD-znver3) device-ID: 1002:1681 memory: 3.91 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 13 device: 0 type: integrated-gpu name: AMD Radeon Graphics
    (RADV REMBRANDT) driver: mesa radv v: 24.0.5-arch1.1 device-ID: 1002:1681
    surfaces: xcb,xlib,wayland device: 1 type: discrete-gpu name: AMD Radeon RX 6800M (RADV NAVI22)
    driver: mesa radv v: 24.0.5-arch1.1 device-ID: 1002:73df surfaces: xcb,xlib,wayland device: 2
    type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.5-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28 class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 sp
eed: 16 GT/s lanes: 16 bus-ID: 37:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 37:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.8.6-AMD-znver3 status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter vendor: Lenovo
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 14c3:0616
    class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Lenovo driver: r8169 v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: 4000 bus-ID: 06:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: Foxconn / Hon Hai Bluetooth Adapter driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 0489:e0d8 class-ID: e001
    serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
    hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11 status: discoverable: no
    pairing: no
  Local Storage: total: 2.77 TiB used: 366.96 GiB (12.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL22T0HBLB-00BL2 size: 1.86 TiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 8L1QGXB7 temp: 39.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Western Digital model: WD BLACK SN770 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 731100WD temp: 30.9 C scheme: GPT
  ID-1: / raw-size: 1.83 TiB size: 1.83 TiB (100.00%) used: 19.83 GiB (1.1%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 32.6 MiB (10.9%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.83 TiB size: 1.83 TiB (100.00%) used: 19.83 GiB (1.1%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.83 TiB size: 1.83 TiB (100.00%) used: 19.83 GiB (1.1%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.83 TiB size: 1.83 TiB (100.00%) used: 19.83 GiB (1.1%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 27.11 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 29.81 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 42.8 C mobo: 38.0 C
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 38.0 C device: amdgpu temp: 38.0 C mem: 36.0 C fan: 0 watts: 7.00
  Memory: total: 28 GiB available: 27.11 GiB used: 3.02 GiB (11.1%)
  Processes: 390 Power: uptime: 4m states: freeze,mem,disk suspend: s2idle wakeups: 0
    hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 10.84 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1915 libs: 570 tools: octopi,paru Compilers: clang: 17.0.6
    gcc: 13.2.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.25-1):
  System install date:     2024-04-11
  Last full system update: 2024-04-14
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:          

So im not sure what the issue is but htop and neofetch are both showing I have 27.11GiB of available ram. That would come out to about 29.1 GB but I have a total of 32 GB of ram and I double checked in my bios and it says 32.1. Is there a reason why this might be?

1 Like

Self-explanatory. :smiley:

Don’t Panic!

Your ram is fine!


Im aware of this and again this doesnt explain the problem. Even when I run free -m this is the output I get

               total        used        free      shared  buff/cache   available
Mem:           27765        3154       22883          76        2180       24610
Swap:          58290           0       58290

im still missing a few GiB of ram

You don’t know how to convert.

Either that or you got royally screwed. Which do you suppose it is?

Manufacturers use a different measurement standard in order to puff-up their feature lists. They always use the highest number. Always.

I got 2 1TB SSDs, right? Not so!

True size is 931.5 GB ea.

1 Like

I understand the conversion and I did them correct. I also know when buying an SSD that you dont actually get the full amount. Its always less thats why im not talking about my 1.8 TB SSD thats supposed to be 2 TB or my 1 TB SSD that is actually 915 GB. This strictly the RAM im having the issue with and something seems off. Again in my bios is specifically reads as 32,xxx memory. I know that GB is different frim GiB but the conversion isnt adding up and even when running free -m you can see the total isnt what it should be.

I have garuda running on my other machine with 32GB or ram and it isnt having this issue

Again, either Linux Ate Your RAM (fanciful thinking), or you got screwed.

Go complain to whomever you bought it from!

I’ve been running Linux for more than a day–more than 9,125 days–and this I know about.

1 Like

Thank you for such a charming appellation. I’m also known around the Arch flora & fauna as @c00ter.

But–hey–I can add, subtract, multiply, etc.

A great skillset you should think hard on acquiring! :wink:


Please tell me more about yourself. You seem like the kinda guy that just loves to talk about himself all the time. I bet you do wonders at birthday parties.

Sorry, Mr. Boring. I only tell “And then I ate the bear” Alaskan stories to non-boring friends.

Ever had one in your living room? I had Mama & 2 cubs.

They’re scary. :smiley:

1 Like

You know what you call a Bear with no ears?

I booted up a live USB of Manjaro just to see if it would spit out something different…it didnt. Gonna go with the case of manufacturer skimped on the RAM. Honestly it threw me off cause this was the first time ive experienced this with RAM. Might just swap it out in the future but I dont think 2-3 GB will be an issue for me.

Truly, it’s a manufacturers gambit. Here’s an example from way back…

Manufacturers use 1,000,000 bytes to represent 1 MB. So, say my old IBM Mod. 30-286 had 1 MB of RAM, and I added another to make it 2 MB, right? 'Cause 2 x 1,000,000 equals 2,000,000 bytes or 2 MB. And this is the manufacturing standard all computer & peripheral manufacturers use for RAM, HDD, SDD, NvME, you name it.

But not so because a true MB is 1,048,756 bytes. And a true 2 MB would equal 1,0488,756 x 2 or 2,097, 512 bytes.

So, from a user-standard, it looks like I got screwed. But from a manufacturer’s standpoint, I got exactly what I paid for.

So that was the real world for @Bro in 1988.

Same for the 2 IBM Blue 1 TB SSDs I bought this year. They’re actually only 931.5 GB SSDs. :wink:

Oh… and “B.”. :wink:


Yeah I understand this and know how manufacturers like to use different metrics. Honestly I know you deal with a lot of people that probably dont know this and so it came off a little condisending. My issue was that on my rig at home ive got 31020 MiB of memory but my laptop with supposedly the same amount of ram has significantly less. 27.11GiB. I was thinking either my ram might be bad or it wasnt reading it correctly. In the end I think the manufactuer just skimped out on the ram even more so than youd expect. Ive got 4x8GB corsair vengence in my rig, not sure what brand is used in the laptop im having the issue with but im gonna take it apart and find out so I avoid it in the future.

1 Like

Lmfao yeah its “B”. Heard that joke this past Friday during Primus, APC, and Puscifer. Maynard had all the dad jokes, idk why but that one tickled me

1 Like

I may have invented dad jokes. I have a great grandchild.

The cornier the better. If they don’t elicit a groan, they’re not real.

It took me years to figure out why my dad loved Professional Wrestling.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Received in system msg from @Alkaizer & reposted with their permission.

Either good research or a great late night brain fart. Either way, @Alkaizer self-solved. :slight_smile: