Not able to install Garada

Hi all,

I just tried to install Garuda kde gaming edition and well I didn’t get very far. Before booting from the usb which I had created using balena etcher I had made sure secure boot was disabled and SATA controller was set to AHCI. I booted into the intial menu where I changed date, language etc and then booted using propriety drivers for nvidia. Everything looked good and there weren’t any errors everything said [OK] but it wouldn’t continue. I was stuck with the flashing cursor and nothing else happened for like 10 mins. I hit Ctrl + Alt + Del and rebooted back into fedora.

I would love to try out Garuda especially as I want to be able to use this pc for gaming. Any help would be much appreciated.

inxi -b
  Host: fedora Kernel: 6.4.14-200.fc38.x86_64 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.7 Distro: Fedora release 38 (Thirty Eight)
  Type: Desktop System: Alienware product: Alienware Area-51 R5 v: N/A
    serial: <superuser required>
  Mobo: Alienware model: 0N4R4N v: A00 serial: <superuser required>
    UEFI: Alienware v: 2.0.6 date: 08/05/2022
  Info: 8-core Intel Core i7-9800X [MT MCP] speed (MHz): avg: 3475
    min/max: 1200/4500:4400
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] driver: nouveau
    v: kernel
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: nouveau gpu: nouveau resolution: 2560x1440
  API: OpenGL v: 4.3 Mesa 23.1.7 renderer: NV162
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet driver: alx
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet driver: alx
  Device-3: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    driver: ath10k_pci
  Local Storage: total: 3.25 TiB used: 167.62 GiB (5.0%)
  Processes: 451 Uptime: 4m Memory: total: 16 GiB available: 15.48 GiB
  used: 3.27 GiB (21.1%) Shell: Bash inxi: 3.3.29

Garuda offer garuda-gamer, so install KDE dragonized and install later all the games …
Has already been addressed several times in the forum, just use the forum search.
Maybe you must use LTS kernel


Okay, will give that a try and check out the link you posted.

Thank you and apologies for asking a repeat question.

So far I’ve tried the installation twice with the zen kernel gaming and non gaming version. I’m going to try for the final time (unless anyone has any ideas) now with the lts kernel.

Update: I finally managed to download the lts iso but still wasn’t able to install Garuda. After the initial boot I was just left at a black screen.

If anyone has any recommendations it’d be much appreciated. I think I’ve changed my mind and will give another distro a go.

I was wondering how they found this solution!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.