Not able to execute this command: sudo echo balanced > /sys/class/drm/card0/device/power_dpm_state

sudo echo balanced > /sys/class/drm/card0/device/power_dpm_state

I tried it with sudo -i , su , sudo su
and when I search from dolphin, there is nothing in the /sys directory

This is what I get:

   ╰─λ sudo -i
[root@Austin-Inspiron-15-3567 ~]# sudo echo battery > /sys/class/drm/card0/device/power_dpm_state
-bash: /sys/class/drm/card0/device/power_dpm_state: Permission denied

I don't see an error :thinking:
What does sudo cat /sys/class/drm/card0/device/power_dpm_state give you?

3 Likes

Sorry I just forgot to copy my error part, I have corrected it above

EDIT:

 ╰─λ sudo cat /sys/class/drm/card0/device/power_dpm_state 
cat: /sys/class/drm/card0/device/power_dpm_state: No such file or directory

 ╭─austin@Austin in ~ took 1s
[🔴] × sudo touch /sys/class/drm/card0/device/power_dpm_state
touch: cannot touch '/sys/class/drm/card0/device/power_dpm_state': Permission denied

Thanks

To be sure, try also to execute it when the game is on, to be sure that the GPU is being used (that's why maybe that directory is not existing).
And as said, confirm the value with cat.

2 Likes

sorry for the confusion please have a look above, I get error when I try to execute it.
I tried but as you asked(while running the game) but still doesn't work!

EDIT:

 pwd
/sys/class/drm/card0/device

this shows that the directory exits, and I can also access it through terminal, but even root previleges don't seem to work in that directory, and /sys dir appears empty in dolphin

In addition to the test above, trying when a game is on, you could try this one
https://askubuntu.com/questions/1226853/set-power-dpm-state-to-low-with-amdgpu-on-xubuntu-18-04

2 Likes

Yes I tried as you suggested while running the game but still I get same errors.
Thanks for the link.
Actually I was suggest to do this who had the same GPU and was running Arch: https://www.reddit.com/r/archlinux/comments/pelxaw/amdgpu_driver_issue/hbjn6po/?context=3

Thank You

Forgive me for this stupid test, but better than nothing ...
(too) long ago I had a similar permissions problem for something else, I don't remember exactly what, but it worked misteriously going to the directory and launching the command without path for the file (and without sudo, I'd say, since you're already root)

cd /sys/class/drm/card0/device/
echo balanced > power_dpm_state

Sadly it also didn't work, I also tried moving it.
Could you please check if it is the case with you too in the same directory?
The entire /sys directory has the same issue, this is how the /sys directory looks in the dolphin:

But you can access the directory through terminal.

Thanks

Everything seems OK in Dolphin for me:


But..

Also, when I do it as root, no error message but no change
image
Edit: my bad, pasted screenshots instead of text for terminal. I'm tired... :yawning_face:

2 Likes

This is the root cause of the issue - you can't write to a file that doesn't exist.

Things being absent from /sys means that sysfs isn't loaded or available - are you running a hardened kernel, for example, or have you made some other random change to your system?

You also forgot some pertinent information in your post that would tell us about your system. Hint: it begins with inxi .

2 Likes
 ╰─λ inxi -Faz
System:    Kernel: 5.14.0-4-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule root=UUID=e665afea-6249-46e2-a56a-9037924055c3 rw 
           rootflags=subvol=@ cgroup_enable=memory swapaccount=1 quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 radeon.si_support=0 amdgpu.si_support=1 
           amdgpu.dpm=0 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.14.1 date: 05/06/2021 
Battery:   ID-1: BAT0 charge: 14.7 Wh (74.2%) condition: 19.8/41.4 Wh (47.8%) volts: 15.4 min: 14.8 model: SMP DELL VN3N047 
           type: Li-ion serial: <filter> status: Discharging 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6 
           model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
           Speed: 600 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 600 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5916 
           class-ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Dell driver: amdgpu 
           v: kernel alternate: radeon bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380 
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:5769 class-ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting unloaded: amdgpu display-ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.0-4-cacule running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: e000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
           bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-8:5 chip-ID: 0cf3:e009 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 79.93 GiB (8.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block-size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 3D scheme: GPT 
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 19.89 GiB (19.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 51.9 MiB (5.1%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 3.8 GiB (3.8%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 
           ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 19.89 GiB (19.9%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 19.89 GiB (19.9%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 11.44 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
           ID-2: swap-2 type: partition size: 6 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7 maj-min: 8:7 
Sensors:   System Temperatures: cpu: 43.0 C mobo: 42.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 318 Uptime: 9h 49m wakeups: 4 Memory: 11.44 GiB used: 3.03 GiB (26.5%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1532 pacman: 1514 lib: 390 flatpak: 9 snap: 9 
           Shell: fish v: 3.3.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.06

EDIT:

I am just using linux-cacule

Guess what I'm going to ask you to try next. :wink:

1 Like

Try a different kernel? :rofl:

Try a standard kernel, e.g. linux or linux-lts.

1 Like
                  __,,,,,,,_                         austin@Austin-Inspiron-15-3567 
            _╓╗╣╫╠╠╠╠╠╠╠╠╠╠╠╠╠╕╗╗┐_                  ------------------------------ 
         ╥╢╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╥,               OS: Garuda Linux x86_64 
       ╗╠╠╠╠╠╠╠╝╜╜╜╜╝╢╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠┐             Host: Inspiron 15-3567 
      ╣╠╠╠╠╠╠╠╠╢╣╢╗╕ , `"╘╠╠╠╠╠╠╠╠╠╠╠╠╠╠╔╥_          Kernel: 5.13.13-arch1-1 
    ╒╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╕╙╥╥╜   `"╜╠╬╠╠╠╠╠╠╠╠╠╠╠╥,       Uptime: 4 mins 
    ╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╗╥╥╥╥╗╗╬╠╠╠╠╠╠╠╝╙╠╠╣╠╠╠╠╢┐     Packages: 1515 (pacman), 9 (flatpak), 9 (snap) 
   ╣╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╥╬╣╠╠╠╠╠╠╠╠╗    Shell: zsh 5.8 
  ╒╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╗   Resolution: 1366x768 
  ╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠   DE: Plasma 5.22.5 
  ╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╬     ```"╜╝╢╠╠╡   WM: KWin 
 ╒╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╣,         ╘╠╪    WM Theme: Lightly 
 ╞╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╢┐        ╜     Theme: Breeze Dark [Plasma], Dracula [GTK3] 
 `╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╗             Icons: Fluent-dark [Plasma], Fluent-dark [GTK2/3] 
 ,╬╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠"╕            Terminal: konsole 
 ╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╗              Terminal Font: Roboto Mono [GOOG] 10 
 ╝^╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╝╣╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╠╡              CPU: Intel i5-7200U (4) @ 3.100GHz 
  ╔╜`╞┘╢╛╜ ╡╢╠"╚╠╠╜╝┌╞╞"╢╠╠╠╠╠╠╠╠╠╠╣╩╢╪              GPU: AMD ATI Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile 
     ╜╒"   `╜    `      ╜╙╕  └╣╠╠╠╠╕ ╞╙╖             GPU: Intel HD Graphics 620 
                                ╠╠╠                  Memory: 1511MiB / 11710MiB 
                                 ╜
                                                                             
                                                                             



 ╭─austin@Austin in ~ 
 ╰─λ sudo -i
[sudo] password for austin:      
[root@Austin-Inspiron-15-3567 ~]# sudo mv power_dpm_state /sys/class/drm/card0/device/
mv: cannot create regular file '/sys/class/drm/card0/device/power_dpm_state': Permission denied
[root@Austin-Inspiron-15-3567 ~]#  mv power_dpm_state /sys/class/drm/card0/device/
mv: cannot create regular file '/sys/class/drm/card0/device/power_dpm_state': Permission denied
[root@Austin-Inspiron-15-3567 ~]# cd /sys/class/drm/card0/device/
[root@Austin-Inspiron-15-3567 device]# echo balanced > power_dpm_state
-bash: power_dpm_state: Permission denied
[root@Austin-Inspiron-15-3567 device]#

But the /sys directory does show up in Dolphin

Thank you

It shows up, but does it contain anything?

The /sys dir was there in the Dolphin already, but the contents didn't show up,
bu now after installing linux, all the contents show up!

But apparently I just rechecked now and found it empty in Dolphin empty,
it seems that after just boot the contents are visible, but after some time they vanish away in the dolphin,
And same is with linux-cacule !
But still I can't do anything in that dir even with root permissions?

/sys is the kernel's settings domain. you can't create files or directories there, even as root, because there aren't files and directories there - just the kernel.

Seems you're trying to adjust performance for your discreet GPU. That would likely be card1, not card0. If there's no 'file' for power_dpm_state, then the driver doesn't have that setting. I have an AMD Vega 54 and it does not have a power_dpm_state setting (because it's not a mobile variant, I imagine), for instance.

Wish I could explain Dolphin's behavior. That's just weird.

5 Likes