Not able to boot installing as dual boot

Having trouble with installing Garuda dual boot with Windows 10 and Linux Mint.
Both LM and WIndows boot fine after installing Garuda, but grub does not show Garuda in the menu.
One disk, 1 Windows NTFS partition, 1 Linux ext4 partition, and unformated free space that I’m trying to install Garuda on.
I have tried four times installing, tried installing along side, replace partition, installing grub on both partitions.
I use Grub customizer but it doesn’t show Garuda.
Garuda runs fine as live install so I don’t think it’s a hardware issue.
I have never had this much trouble installing any other OS.
Don’t understand why OS-prober is not seeing it.

Garuda’s GRUB should be the one used. It’s an Arch thing. OS Prober may help, I dunno. Garuda does not officially support dual-booting, much less multi. You’re on your own to a large degree. However, unofficial support will probably be coming your way soon.

1 Like

Please post the output of garuda-inxi for all topics in the Issues & Assistance category as requested by the topic template.

Also post lsblk -f and sudo parted -l.

1 Like
keith@Aspire-7741:~$ lsblk -f
│    ntfs         Windows
│                       144A0DAD5F5EC11C                                    
     ext4   1.0   Linux Mint
                        19cbbfd4-118e-4fa6-b87a-df59e5df9a8e  149.8G    17% /
keith@Aspire-7741:~$ sudo parted -l
[sudo] password for keith:        
Model: ATA SPCC Solid State (scsi)
Disk /dev/sda: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      32.3kB  195GB  195GB  primary  ntfs
 2      195GB   405GB  210GB  primary  ext4

In addition there is a 576 GB un-formatted partition, that when Installing Garuda comes back with the btrfs format and a small un-partitioned space following.
After restart I see no entry in grub or grub customizer.
Have install many linux and windows distro’s countless times, never had this issue.
Most Linux distro’s find other OS’s and give option to install along side or full install overwriting.

Now this is in Linux Mint after deleting the btrfs partition again,
as there is no boot. Can I do those commands in Garuda live?
Or any other diagnostics…even try installing again and run something.
I did notice whenI came back to grub customizer in LM that there where a lot of
hidden and script instances.

is a no go.

Arch grub find all other OS. Garuda use Btrfs. In your logs are no Btrfs.
BTW, you can edit your last post until someone replies.

1 Like

Yes, you can run garuda-inxi from the live ISO.

How did you prepare the USB drive for installation?

Please insert the USB drive, then run the commands again:

lsblk -f
sudo parted -l
lsblk -f
NAME   FSTYPE FSVER LABEL                  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0  squash 4.0                                                                     0   100% /run/miso/sfs/livefs
loop1  squash 4.0                                                                     0   100% /run/miso/sfs/mhwdfs
loop2  squash 4.0                                                                     0   100% /run/miso/sfs/desktopfs
loop3  squash 4.0                                                                     0   100% /run/miso/sfs/rootfs
├─sda1 vfat   FAT32                        FC9B-0F7D                                           
├─sda2 ext4   1.0                          8587a49a-7b01-43e1-8a81-3a21412bc628                
├─sda3 btrfs                               e265e6e5-85c8-428e-ba0b-b9c6463d76f2  601.7G     1% /tmp/calamares-root-te5ztzp5/var/tmp
│                                                                                              /tmp/calamares-root-te5ztzp5/var/log
│                                                                                              /tmp/calamares-root-te5ztzp5/var/cache
│                                                                                              /tmp/calamares-root-te5ztzp5/srv
│                                                                                              /tmp/calamares-root-te5ztzp5/root
│                                                                                              /tmp/calamares-root-te5ztzp5/home
│                                                                                              /tmp/calamares-
│                                                                                              root-te5ztzp5
├─sda6 ext4   1.0                          344a1808-d534-4c82-9a88-db6117499768                
└─sda7 ext4   1.0                          1c753e11-c5e5-40ce-9925-75f03e2f69fa                
sdb    iso966 Jolie GARUDA_CINNAMON_RAPTOR 2023-10-29-08-27-17-00                              
├─sdb1 iso966 Jolie GARUDA_CINNAMON_RAPTOR 2023-10-29-08-27-17-00                     0   100% /run/miso/bootmnt
└─sdb2 vfat   FAT12 MISO_EFI               68C0-F177                                           
zram0                                                                                          [SWAP]

sudo parted -l
Model: ATA Samsung SSD 870 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  538MB   537MB   fat32        EFI System Partition  boot, esp
 2      538MB   222GB   222GB   ext4         Linux Mint
 6      222GB   286GB   63.2GB  ext4         Kali Linux
 7      286GB   349GB   62.9GB  ext4         Kodachi
 3      349GB   1000GB  652GB   btrfs        root                  boot, esp

Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2456MB  2460MB  4194kB  primary               esp

Model: Unknown (unknown)
Disk /dev/zram0: 7734MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system     Flags
 1      0.00B  7734MB  7734MB  linux-swap(v1)

The first several attempts installing was from Ventoy ISO which I’ve successfully installed countless OS’s off of.
But this attempt is from and individual Flash drive with Garuda ISO bootable, just to rule that out.
It’s a Linux distro, it shouldn’t be that hard to install.

Machine :
OS: Garuda Linux x86_64
            .8Xx;                    8x:.         Host: 80R4 Flex 3-1580
          .tt8x          .d            x88;       Kernel: 6.5.9-zen2-1-zen
       .@8x8;          .db:              xx@;     Uptime: 2 hours, 4 mins
     ,tSXX°          .bbbbbbbbbbbbbbbbbbbB8x@;    Packages: 1269 (pacman)[stable]
   .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;    Shell: fish 3.6.1
 ,888S                                     pd!    Resolution: 1920x1080
8X88/                                       q     DE: Cinnamon 5.8.4
8X88/                                             WM: Muffin (X11)
GBB.                                              WM Theme: Sweet-Dark (Sweet-Dark)
 x%88        d888@8@X@X@X88X@@XX@@X@8@X.          Theme: Sweet-Dark [GTK2/3/4]{?3} {3} [Plasma], {?}{7}
   dxXd    dB8b8b8B8B08bB88b998888b88x.           Icons: BeautyLine [GTK2/3/4]
    dxx8o                      .@@;.              Terminal: GNOME Terminal 3.48.2
      dx88                   .t@x.                Terminal Font: FantasqueSansMono Nerd Font Mono 12
        d:SS@8ba89aa67a853Sxxad.                  CPU: Intel(R) Pentium(R) 4405U (4) @ 2.10 GHz
          .d988999889889899dd.                    GPU: Intel HD Graphics 510
                                                  Memory: 2.18 GiB / 7.20 GiB

You have mixed UEFI installations with legacy/BIOS installations. They can never be on the same Grub menu, no matter what you do. Grub Customizer cannot change this, in fact it probably will only cause you issues down the road.

Aside from converting the Windows installation to use a UEFI bootloader, or reinstalling Linux in legacy/BIOS mode (you need to install the BIOS version of Ventoy for this), there is nothing much for it but to disable CSM/enable UEFI mode in the BIOS settings to boot the one, then switch back to boot the other every time.

Hum, ok that’s strange, as Windows was installed on it, but I installed Mint, Kodachi, Kali, and a host of others on it from time to time, and OS-prober or grub customizer always finds the new installed OS. This machine is kind of a test PC, but also my daily driver. I have tried it on others. Only thing I got it to install correctly on was my Virtualbox machine, seems to work fine on it.

  1. So if I wanted to install Garuda, I should wipe the HD and reinstall first?
  2. And use EFI or not?
  3. then can I reinstall other distro’s?

It is Windows which is throwing a wrench in the works, because it was installed in legacy mode on a MBR disk (even though you have a UEFI motherboard). If reinstalling Windows is feesible, that would be the most straightforward way to get everything on the same boot routine. The disk Windows is on would have to be reformatted GPT, so external backups would be in order.

The other installations may be fine and bootable as they are (we do not know, there is not enough information). To boot to them, you need to switch from legacy boot to UEFI boot. Typically you do this by disabling CSM or enabling “UEFI only” mode in the BIOS.

If reinstalling Windows is not on the table but you want everything on one boot menu, you will have to reinstall Linux in legacy mode (it looks like one of your Linux Mints is already installed this way).

If this is Garuda, it should not have any flags on this partition (boot, esp).

I think I put that flag in an attempt to get it to boot after it failed and didn’t show up, I don’t think it was there originally.
And yes that is the partition I used to install Garuda.

If you are not using Garuda’s Grub, this may be caused by an issue os-prober has with Btrfs. If you replace os-prober with os-prober-btrfs it may work, but I am not sure how available that package is in other distros (it’s an AUR package).

That will not address the legacy/UEFI issue though.

If you want to install Garuda on the disk with Windows you can just re-install Ventoy in BIOS mode and do a reinstall, that should work.

Hi, I consider myself a newbie but I had a similar experience and solved it with the excellent Change Root ‘chroot’ option from the Garuda live ISO booted from ventoy.

chroot finds Garuda on brtfs!
Enter its number, then do:

grub-install /dev/sda (check your drive letter)
If ok:


Worked for me on several occasions.

Then quit arguing and self-solve. Jerk.

Who you talking to Bro?

Any way, not sure what fixed it but I was going to try Maartin’s suggestion after a wing and prayer I fired up Hirens CD_PE_Win_x64. just to see if I could get into the Windows EFI… it was on the 512mb fat32. I only turned on EFI in BIOS, and returned it to Legacy. Did another attempt of installing Garuda.ISO from the Ventoy disk again and for some reason it took this time. Now I get the Garuda’s Boot menu with all the other distro’s in the menu. Which is fine, but I would like to figure out how to edit the menu to suit me, as in, Grub-Customizer lets you arrange, add and delete entries.
Thanks for the help, I’m sure I’ll have more newby questions later, now that I have it on real hardware.