Not able to boot from usb

I have tried other distro and it works but not specifically in Garuda Linux, i have tried rufus, balena, and ventoy none of these work in any of the Garuda linux images, I have tried open source and nvidia drivers all of them result in infinite black screen (i have tried upto half an hour) never boot into the setup of Garuda Linux, what can I do here?

Welcome :slight_smile:

Check shasum.
Maybe a corrupt download.
Where do you get the ISO from and what is the full ISO name.
BTW, just use ventoy.


Also make sure that secure boot is disabled in the BIOS, and in general follow the installation instructions in


seccure boot is disabled, (the last time i could boot into it) i cannot boot into bios, and i did follow the instructions, just not able to boot into it

What other distributions?

From when? If you confirm here in GRUB?

You can’t get into the BIOS, do I understand that correctly?

Please answer all questions.


yes, whenever i select whenever i confirm here in GRUB, (whatever option i choose) just results to infinite black screen, this is happening only in garuda dragonised (xfce, manjaro and neon work fine). And yes i cannot boot into my bios, (doing so will also result in infinite black screen)

Please answer all questions.

Seems garuda-inxi is not possible, so please, post from xfce

inxi -Faz

Possibly workaround, install with lts kernel could help.
Download from


What kind of computer is it (make/model/year)?

You are not able to boot to the BIOS using the ordinary F keys, before the boot splash?

1 Like

Acer Nitro 5 (2020) gtx 1650 ti i5 10300H
Yes, not able to boot into bios using F keys, whenever i press it, it gets stuck at boot splash till infinity (forcing me to force reboot)

Garuda definitely works generally on your Acer Nitro 5.
At the latest when the Acer logo appears, press F2 for the BIOS and/or F12 for the boot overide (boot menu).
If that doesn’t work, turn off the laptop and turn it over. There should be a small hole for a needle on the bottom so you can reset it. Further information can be found in the manual for your laptop on the acer homepage.


Are you using your laptop with a secondary screen attached? If so, disconnect it from the external monitor/TV and try to boot into your bios again.

Also try removing the battery and the power supply and let the computer sit for 5 minutes or so before powering up again. Try powering up without the battery, and see if you can enter your bios or boot the live disk.

1 Like

there is no hole beneath my laptop


so i have to open up the laptop to fix this right

Is that a question?
If there is no option other than removing the CMOS battery on your laptop, then yes.
If you do that, replace the CMOS battery straight away, it should be a CR2032 - they only cost a few cents :slight_smile:

If you don’t feel confident doing this, do you know someone who can help you?

1 Like

Start searching in WWW/manual for your laptop. Start with F keys, BIOS, Reset. Last way is a new CMOS battery.

the only sad part is i dont have a CMOS battery, my laptop doesnt come with one

Check if your disks are set to RAID in the bios, if they are , change them to AHCI

1 Like

Then old school: Disconnect the power supply, disassemble the laptop and unplug the power cable from the laptop-battery on the PCB. Then hold down the power button for at least 30 seconds. Then put everything back together and test whether you can get into the BIOS.

And then try the garuda-lts version, as @SGS already suggested.

1 Like