Not able to access pwm1 file (for fancontrol)

Hi there!
I'm a little new to Linux. I was trying configure the fans for my laptop using pwmconfig and fancontrol. The pwmconfig was successful in creating a config file configuring it correctly, but when I run sudo fancontrol I get the following output:

Loading configuration from /etc/fancontrol ...

Common settings:
INTERVAL=10

Settings for hwmon6/pwm1:
Depends on hwmon6/temp2_input
Controls hwmon6/fan1_input
MINTEMP=42
MAXTEMP=60
MINSTART=100
MINSTOP=60
MINPWM=0
MAXPWM=255
AVERAGE=1

Enabling PWM on fans...
Starting automatic fan control...
/usr/bin/fancontrol: line 551: read: read error: 0: Invalid argument
Error reading PWM value from /sys/class/hwmon/hwmon6/pwm1
Aborting, restoring fans...
Verify fans have returned to full speed

Here's my fancontrol configuration file:

# Configuration file generated by pwmconfig, changes will be lost
INTERVAL=10
DEVPATH=hwmon6=devices/platform/dell_smm_hwmon
DEVNAME=hwmon6=dell_smm
FCTEMPS=hwmon6/pwm1=hwmon6/temp2_input
FCFANS= hwmon6/pwm1=hwmon6/fan1_input
MINTEMP=hwmon6/pwm1=42
MAXTEMP=hwmon6/pwm1=60
MINSTART=hwmon6/pwm1=100
MINSTOP=hwmon6/pwm1=60

I probably think it's a problem with the pwm1 file and tried accessing it (it exists btw) through dolphin (using kate) and even tried cating it and it gave the following output:
cat: pwm1: Invalid argument
I searched the internet for similar topics but there were no similar topics out there.
My garuda-inxi output:

System:
  Kernel: 5.18.15-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=62709ec6-924d-44bc-9f2a-345a56fa4621 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=eec59e20-24dc-40e6-8120-46ae353f4ae2 loglevel=3
  Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 5415 v: 1.9.0
    serial: <superuser required> Chassis: type: 10 v: 1.9.0
    serial: <superuser required>
  Mobo: Dell model: 0NTNJK v: A00 serial: <superuser required> UEFI: Dell
    v: 1.9.0 date: 03/18/2022
Battery:
  ID-1: BAT0 charge: 19.5 Wh (36.1%) condition: 54.0/54.0 Wh (100.0%)
    volts: 15.9 min: 15.0 model: BYD DELL WV3K815 type: Unknown
    serial: <filter> status: charging
CPU:
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x68 (104) stepping: 1 microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1400 high: 1480 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1330 2: 1397
    3: 1480 4: 1415 5: 1396 6: 1397 7: 1402 8: 1397 9: 1397 10: 1397 11: 1397
    12: 1397 bogomips: 50308
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: Dell driver: amdgpu v: kernel arch: GCN-5.1
    code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 0c45:6725 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 140 s-size: 348x195mm (13.70x7.68")
    s-diag: 399mm (15.71")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x091d built: 2020
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.15-zen1-1-zen)
    v: 4.6 Mesa 22.1.4 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Dell
    driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.15-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-3:5 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 15.32 GiB (3.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC711 NVMe
    512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41002131
    temp: 30.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 213.5 GiB size: 213.5 GiB (100.00%) used: 15.32 GiB
    (7.2%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 628 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-3: /home raw-size: 213.5 GiB size: 213.5 GiB (100.00%) used: 15.32 GiB
    (7.2%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-4: /var/log raw-size: 213.5 GiB size: 213.5 GiB (100.00%) used: 15.32
    GiB (7.2%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-5: /var/tmp raw-size: 213.5 GiB size: 213.5 GiB (100.00%) used: 15.32
    GiB (7.2%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.12 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p7 maj-min: 259:7
Sensors:
  System Temperatures: cpu: 38.0 C mobo: 36.0 C gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): cpu: 4665
Info:
  Processes: 334 Uptime: 31m wakeups: 1111 Memory: 7.12 GiB used: 3.82 GiB
  (53.6%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.0 Packages: pacman: 1366 lib: 358 Shell: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.20
Garuda (2.6.5-1):
  System install date:     2022-07-12
  Last full system update: 2022-08-01
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

And I should say this, I'm dual booting with windows but there is a separate bootloader file for Garuda Linux (not sure if it's the right phrase) and I have not encountered a single issue regarding this. Let me know if you need any more information.
Thanks in advance!

Just a few ideas (this is not really my "terrain"):

  1. Check the BIOS. See e.g.
    Fan speed control - ArchWiki
    Do not try with i8kutils (see comment at the beginning of Dell section -> not working anymore with kernel 5.18).
  2. Try a different kernel, especially linux-lts (5.15)
  3. Did you happen to resume from sleep/suspend/hybernate before trying this?
3 Likes

Thanks for the reply filo. I probably created this post in haste. You can close this post. I'm sorry for the trouble. I'm loving Garuda btw!
Long explanation: I've been using Garuda for over a month now and I've never seen the fan turn on even once. I got to know today that I've been using the wrong temperature sensor up until now and I was panicking every time the temperature shot up according to that sensor, but it turns out that the CPU never heated that much to trigger the fan. Today the fan switched on all of a sudden and I also switched to a different temperature sensor (the correct one this time) and everything seem to fall into place XD, i.e., the fans turned on automatically at 42 deg C. Sorry again for wasting your time. This is a great community :slight_smile:

1 Like

This topic will close 2 days after the last reply. :smiley:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.