Noise in audio recording

I'm trying to record audio on my laptop's build-in microphone. It worked fine before I installed Xfce. But now the audio recording always contains a bunch of unwanted noise even when I don't make any sounds in the real world. I tried plugging in my headphones and unplugging them, and the outcome is the same. It seems to be some kind of computer-generated noise added to the sound recording.

How do I get rid of this audio recording noise?

inxi -Faz
System:    Kernel: 5.10.78-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=8d05eb79-30ef-4c21-92f0-c8c7c8baee18 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Acer product: Aspire A315-56 v: V1.15 serial: <filter>
           Mobo: IL model: Sleepy_IL v: V1.15 serial: <filter> UEFI: Insyde v: 1.15 date: 07/13/2020
Battery:   ID-1: BAT1 charge: 41.5 Wh (100.0%) condition: 41.5/47.8 Wh (86.9%) volts: 12.2 min: 11.2 model: LGC AP18C8K
           type: Li-ion serial: N/A status: Full
CPU:       Info: Dual Core model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake family: 6 model-id: 7E (126)
           stepping: 5 microcode: A6 cache: L2: 4 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 9523
           Speed: 3186 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3186 2: 3207 3: 3209 4: 3131
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Iris Plus Graphics G1 vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:8a56 class-ID: 0300
           Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-7:3 chip-ID: 0408:a061 class-ID: 0e02
           Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0.0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
           alternate: snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
           Sound Server-1: ALSA v: k5.10.78-1-lts running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: yes
           Sound Server-5: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169
           v: kernel port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp1s0 state: down mac: <filter>
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel
           bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
           IF-ID-2: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth: Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
           chip-ID: 04ca:3015 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 138.82 GiB (58.2%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: RBUSNS8154P3256GJ1 size: 238.47 GiB block-size:
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: E8FK12.3 temp: 42.9 C
           scheme: GPT
Partition: ID-1: / raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 138.82 GiB (58.3%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 138.82 GiB (58.3%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-4: /var/log raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 138.82 GiB (58.3%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 138.82 GiB (58.3%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 73.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 303 Uptime: 6m wakeups: 4 Memory: 7.56 GiB used: 3.42 GiB (45.2%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1824 lib: 411 Shell: Bash v: 5.1.8
           running-in: xfce4-terminal inxi: 3.3.08

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

From my limited experience, usually noise in recording is because your default sample rate is incorrect. You can use the Arch wiki and do some searches on that, lots of helpful solutions.

However, looking at your output above it shows;

Sound Server-4: PulseAudio v: 15.0 running: yes
Sound Server-5: PipeWire v: 0.3.39 running: yes

Mine shows Pulseaudio as: no and Pipewire as: yes. Maybe someone can chime in if there is is correct or not.

2 Likes

I tried turning off PulseAudio using the instructions on this page (How to temporarily disable PulseAudio while running a game under Wine? - Ask Ubuntu)

Or in other words: I turned off PulseAudio by inserting the following in the terminal:

systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.service

Then I tried recording audio again, but this time the audio recording was 100% silent even when I produced sounds in the real world.

Then, I turned PulseAudio back again by inserting the following into the terminal:

systemctl --user start pulseaudio.socket
systemctl --user start pulseaudio.service

I found that I can increase the signal/noise ratio by opening PulseAudio Volume Control, and then clicking the "Input Devices" tab, and then moving the upper slider to the left. But although the signal/noise ratio significantly increases, the overall volume is unfortunately small and I have to increase the volume to be able to hear what was said through the microphone.

Have you tested a decent external microphone to see if it behaves the same?

Perhaps your internal mic is of poor quality and/or is close to other components that are throwing electrical interference.

Windows is irrelevant, so please don't claim Windows works great with your internal mic.

2 Likes

I certainly agree. Sometimes, hardware manufacturers ship with software to remove noise using AI. They only ship for windows, but by default. This way, they can actually provide decent audio input from mic, without spending much on actual hardware.

2 Likes

oh, it actually makes sense. I will give it a try sometime in the future. It was a while ago that I had this issue. but I think my microphone was actually working fine when I first started using Garuda, but then for some reason it stopped working perhaps due to some update in audio driver or something, but I'm not 100% sure. Thanks!