No WiFi Access

I think it’s just relatively new and not well supported yet, as far as I know Intel stuff is generally “Linux friendly”. I see there are dozens of similar devices and sometimes it’s just a matter that the specific card is simply “unknown”.

It sounds like I may have to wait a while till someone comes up with drivers for it. The Intel NUC was discontinued and it looks like BeeLink is the new NUC. The Mini S Pro 12 seems like it hasn’t been on the market for awhile like you mentioned.

“Activate a connection” is the correct option, although it sounds like I may have misunderstood the issue (it sounded like you couldn’t see a way to connect to a WiFi network).

If you don’t have drivers for an Intel WiFi card, I would try switching to another kernel. The Zen kernel is popular here because it is stable and gives good performance:

sudo pacman -S linux-zen linux-zen-headers

Boot with your new kernel in the advanced options in the Grub menu after a reboot.


Ah, here we go, now I see my WiFi connection from my Bell Canada issued router. It asked for a password and it was connected after that

Also FYI, here is my kernal configuration…

 ╭─fenris@fenris in ~ took 113ms
 ╰─λ garuda-inxi
  Kernel: 6.6.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=576a4f6d-5c57-475b-8279-4f23d821f833 rw rootflags=subvol=@
    quiet resume=UUID=6feff68d-462f-4c25-aead-653957ef83a3 loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux

I would say this is good to go at this point. Thank you for all the help!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.