No such key “antialiasing” error

Hello.
While doing a recent update, I got this error.

No such key “antialiasing” in schema “org.gnome.settings-daemon.plugins.xsettings” as specified in override file “usr/share/glib-2.0/schemas/25_gnome-default-settings.gschema.override”; ignoring override for this key.

I searched on web, did not found anything great other than "Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'" with g-s-d 40.x (#3680) · Issues · GNOME / gtk · GitLab

But I'm not able to get any solution.
It is not making anything don't work but still .....
Do anyone know the solution.

Thanks.
:grinning:

Have you looked for bug reports? https://bugs.archlinux.org/

1 Like

Didn't looked that before.
Now seen it, but didn't find anything useful.

Is it an error or a warning? Those are different things.

Where are you seeing this message appear?

AFAIK it was a error as when I was upgrading system I got it randomly.
If I get it next I will surely copy whole thing.

Another thing I'm experiencing now is:

( 2/13) Creating temporary files...
Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted
error: command failed to execute correctly

when upgrading

Remove the lines containing antialising in usr/share/glib-2.0/schemas/25_gnome-default-settings.gschema.override and then, recompile schema,

 sudo glib-compile-schemas /usr/share/glib-2.0/schemas

Beware! This might break your schema! Make backup before performing this.

2 Likes

Thanks.
I removed the line and recompiled. It didn't gave me error while compiling.
I will see if I get the error again.
Hoping it is fixed.

Should I create a new topic for this issue?

No. You can ignore this message, nothing to do.
If you search, you find it better explained then I can do. :slight_smile:

1 Like

Thanks.
I found the pcie_aspm=force thing.
Just gonna leave this error cause this solution seems dangerous.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.