No spice support on qemu

So i have installed garuda linux on my lenovo laptop. i want to use qemu and virt-manager to install some guest but when i try to add spice server and open gl it gives an error spice server is not supported in this version of qemu. Please tell how to fix this on pop os it was working fine but its giving me a hard time on garuda linux.Any help is highly appreciated

Works fine for me, and seems like you forgot any kind of logs and also the required garuda-inxi info. Please edit your post to add such info.

2 Likes

Currently i dont have access to my laptop but i followed a installation guide for manjaro everything works but when i add a graphics hardware with spice server and opengl is says spice server is not supported by this qemu verison can u please give me a link to any guide that i can follow to install it properly with spice and open gl running

Here is the link: QEMU - ArchWiki

3 Likes

I installed qemu-desktop package with other dependencies but still in virt-manager it doesn't let me add spice server always says spice is not supported by this version of qemu

spice server is supported on my Lenovo laptop.
Either your hardware do not support it or your doing something wrong.
In post #2 you were asked for the required garuda-inxi, without it the good folks can not help you.
Good luck

3 Likes

I currently uninstalled garuda that's why i haven't send inxi info.I installed pop os and spice was working perfectly in that but after switching to garuda it stopped working.i am not understanding what am i doing wrong.i will send the inxi thing after a fresh install of garuda

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 82KU v: IdeaPad 3 15ALC6 Ub
serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 15ALC6 Ub
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0T76486WIN
serial: <superuser required> UEFI: LENOVO v: GLCN46WW date: 03/23/2022
Battery:
ID-1: BAT0 charge: 27.3 Wh (57.0%) condition: 47.9/45.0 Wh (106.5%)
volts: 11.5 min: 11.1 model: SMP L20M3PF0 type: Li-poly serial: <filter>
status: not charging cycles: 19
CPU:
Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22 process: TSMC n7
(7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
microcode: 0x8608103
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1463 high: 1715 min/max: 1400/4056 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
3: 1397 4: 1715 5: 1396 6: 1302 7: 1400 8: 1691 9: 1397 10: 1497 11: 1575
12: 1400 bogomips: 50307
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Lucienne vendor: Lenovo driver: amdgpu v: kernel
arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
class-ID: 0300 temp: 44.0 C
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-3:3 chip-ID: 04f2:b725 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x369f built: 2021
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: RENOIR (renoir LLVM 14.0.6 DRM 3.48 6.0.2-zen1-1-zen)
v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_sof_amd_renoir pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:c822
class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-4:3 chip-ID: 0bda:c123 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 506.19 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512GZL
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: C01C
temp: 30.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Blade
size: 29.25 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.13 GiB used: 942.2 MiB (12.9%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.8 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 289 Uptime: 19m wakeups: 1 Memory: 7.13 GiB used: 3.75 GiB
(52.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1262 libs: 318
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-12-09
Last full system update: 2022-12-09 ↻
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            snapper-cleanup.service


i am getting this error in every arch distro

Try the below and see what happens.
Type - Spice derver
Listen type - address
Address - localhost only
Port - Auto

I see many post with the same problem you have, have you tried any searches of the subject?

unsupported configuration spice graphics are not supported with this QEMU

Yaa i have scratched my head with all the forums related to this but with no luck that’s why at last posted this in this forum

I tried again installing and setting virt-manager in pop os and it worked falwlessly.i think pop os is using some older version of qemu which supports spice whil arch uses latest version and i think it has some issues with spice

I would recommend resolving your partially upgraded state before troubleshooting any issues you are experiencing with QEMU, or anything else.

You just updated your system, but you are still back on 6.0.2--what happened?

Reboot the system, then try to update again with garuda-update and paste any error messages you get into the thread.

3 Likes

I'm using QEMU on 3 spins of Arch and all work and are updated.
@BluishHumility is on a roll here, fix that partially upgrade.

3 Likes

Updating the system fixed the issue of spice server. But i have two new issue first my sound is not working in vm and second mouse is behaving weird i have to keep pressing the left mouse button to move cursor but adding a usb mouse fixes the issue but i have to do it everytime i boot vm so its little bit annoying.But main problem is sound it’s not working i tries searching on forums but no luck

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.