No sound input/output devices

Hello,

I'm using garuda gnome. Three days ago everything was fine, and today, my sound input/output devices disappeared.

Everything works fine in my other OS (ubuntu 18 and windows 10). I've tried updating the system, but it didn't solve the problem.

inxi --admin --verbosity=7 --filter --no-host

System:    Kernel: 5.11.7-139-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=8d84bcbf-5a2e-41ee-820d-82c7a0bec40a rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: GNOME 3.38.4 tk: GTK 3.24.27 wm: gnome-shell dm: GDM 3.38.2.1 Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170M-PLUS/BR v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 3805 
           date: 05/03/2018 
Memory:    RAM: total: 15.58 GiB used: 5 GiB (32.1%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Quad Core model: Intel Core i5-7600K bits: 64 type: MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: 9 microcode: DE L2 cache: 6 MiB bogomips: 30428 
           Speed: 4480 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4480 2: 2383 3: 4415 4: 4486 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts erms est f16c flush_l1d fma fpu 
           fsgsbase fxsr hle ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
           mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs 
           pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 sse4_1 
           sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave xsavec xsaveopt xsaves 
           xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 460.67 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
           chip ID: 10de:1c82 class ID: 0300 
           Display: x11 server: X.Org 1.20.10 compositor: gnome-shell driver: loaded: nvidia display ID: :1 screens: 1 
           Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x286mm (34.2x11.3") s-diag: 915mm (36") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") diag: 598mm (23.5") 
           Monitor-2: DP-1 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1") diag: 470mm (18.5") 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 class ID: 0403 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
           class ID: 0403 
           Sound Server: ALSA v: k5.11.7-139-tkg-bmq 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 class ID: 0200 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Bluetooth: Device-1: type: USB driver: btusb v: 0.8 bus ID: 1-2:2 chip ID: 0c10:0000 class ID: fe01 
           Message: Required tool hciconfig not installed. Check --recommends 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020 bus ID: 00:17.0 chip ID: 8086.2822 
           rev: 31 
Drives:    Local Storage: total: 447.13 GiB used: 29.49 GiB (6.6%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP510 size: 447.13 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: ECFM12.2 temp: 40.9 C scheme: GPT 
           Message: No Optical or Floppy data was found. 
Partition: ID-1: / raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
           ID-2: /boot/efi raw size: 99 MiB size: 95 MiB (95.96%) used: 32.3 MiB (34.0%) fs: vfat dev: /dev/nvme0n1p2 
           maj-min: 259:2 label: N/A uuid: A055-BC70 
           ID-3: /home raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
           ID-4: /root raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
           ID-5: /srv raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
           ID-6: /var/cache raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
           ID-7: /var/log raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
           ID-8: /var/tmp raw size: 67 GiB size: 67 GiB (100.00%) used: 29.46 GiB (44.0%) fs: btrfs dev: /dev/nvme0n1p6 
           maj-min: 259:6 label: N/A uuid: 8d84bcbf-5a2e-41ee-820d-82c7a0bec40a 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Unmounted: ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs label: Recupera\xc3\xa7\xc3\xa3o uuid: 46B05524B0551C2D 
           ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required> label: N/A uuid: N/A 
           ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 297.96 GiB fs: ntfs label: N/A uuid: 96E284C1E284A759 
           ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 81.54 GiB fs: ext4 label: N/A uuid: dd6cb209-7118-4a3d-a859-872b216f1a2a 
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
           Device-1: 1-2:2 info: N/A type: Bluetooth driver: btusb interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 0c10:0000 
           class ID: fe01 
           Device-2: 1-9:3 info: Dell Dell Universal Receiver type: Keyboard,Mouse,HID driver: hid-generic,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 413c:8505 class ID: 0300 
           Device-3: 1-10:4 info: Logitech USB Receiver type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 
           rev: 2.0 speed: 12 Mb/s chip ID: 046d:c53d class ID: 0300 
           Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 class ID: 0900 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 27.8 C gpu: nvidia temp: 39 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 40% 
Info:      Processes: 253 Uptime: 2h 26m wakeups: 0 Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1236 
           lib: 301 Shell: Bash v: 5.1.4 running in: xfce4-terminal inxi: 3.3.01 

Uh. Wrong forum maybe?

3 Likes

Ops, forgive me. I copied this part from an old post, it's actually

Kernel: 5.11.7-139-tkg-bmq x86_64

Updated above as well.

3 Likes

I've been seeing some similar issues in Arch reports, and those were down to Pipewire updates and un-merged pacnew files:

https://bugs.archlinux.org/task/70093

So, firstly check for pacnew with e.g. pacdiff and merge as necessary.

3 Likes

TL;DR

/etc/pipewire/media-session.d/*.pacnew ?

Use the .pacnew files

I've downgraded pirewire-pulse to version 0.3.22, and everything works again. Thank you for your help.

1 Like

That's not really a fix. You should instead merge your pacnew files.

3 Likes