No sound from speakers (LAPTOP)

I often suffer from sound problems in my laptop in garuda. my hardware is totally ok (it works compleatly fine in windows). once my speakers wern't producing any sound (THE SOUND ICON WAS NOT SHOWING ETHER) and videos were not playing i rebooted and reseted all the configs and it got back normal but this time in the latte dock panel, the sound icon is showing but only the mike, volume controller isn't showing . i thought it was my speaker's fault but the worked for windows. and i hope it is not any kind of driver problem. i did't make any mess except i played a game on wine last night and garud maintenance thing popuped few times and failed

please help, i have online class tomorrow :frowning_face: :frowning_face: :frowning_face:

Many solved their audio problems with this kind of all in one script.

Inxi -Faz missing...

2 Likes

Your system is hella out of date.
You gotta do sudo bash -c ". <(wget -qO- https://gitlab.com/garuda-linux/themes-and-settings/settings/garuda-common-settings/-/snippets/2147440/raw/main/remote-update)"
You should do this before doing @filo's suggestion.
Make sure it completed successfully.

5 Likes

thanks man,
now i can do my online class :grinning_face_with_smiling_eyes:

1 Like

guys i am still suffering
i am not able to use the inbuilt audio

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-11-22_10-00-22/@/boot/vmlinuz-linux-zen
root=UUID=cfeb12e8-b340-4b7c-9957-a2bc51a4bef9 quiet splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
rootflags=defaults,noatime,space_cache,autodefrag,compress=zstd,subvol=timeshift-btrfs/snapshots/2021-11-22_10-00-22/@
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: VivoBook E14 E402YA_E402YA v: 1.0 serial: <filter>
Mobo: ASUSTeK model: E402YA v: 1.0 serial: <filter> UEFI: American Megatrends v: E402YA.303
date: 09/10/2019
Battery:   ID-1: BAT0 charge: 25.0 Wh (100.0%) condition: 25.0/32.3 Wh (77.3%) volts: 7.8 min: 7.8
model: ASUSTeK E402-42 type: Li-ion serial: N/A status: Not charging cycles: 403
CPU:       Info: Dual Core model: AMD E2-7015 APU with AMD Radeon R2 Graphics bits: 64 type: MCP
arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 microcode: 7030106 cache: L2: 1024 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 5988
Speed: 1497 MHz min/max: 1000/1500 MHz Core speeds (MHz): 1: 1497 2: 1497
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Mullins [Radeon R2 Graphics] vendor: ASUSTeK driver: radeon v: kernel
alternate: amdgpu bus-ID: 00:01.0 chip-ID: 1002:9853 class-ID: 0300
Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo bus-ID: 1-1.4:5
chip-ID: 13d3:5a11 class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: ati,radeon
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8") diag: 354mm (13.9")
OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.14.14-zen1-1-zen LLVM 13.0.0) v: 4.5 Mesa 21.2.5
direct render: Yes
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
Device-2: AMD FCH Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:14.2
chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
driver: N/A modules: rtw88_8821ce port: e000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus-ID: 1-1.1.4:11
chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s18u1u1u4 state: up mac: <filter>
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 2-1.1:3
chip-ID: 13d3:3529 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 51.47 GiB (5.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J
scheme: GPT
Partition: ID-1: / raw-size: 157.84 GiB size: 157.84 GiB (100.00%) used: 51.45 GiB (32.6%) fs: btrfs
dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 25.9 MiB (10.1%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 157.84 GiB size: 157.84 GiB (100.00%) used: 51.45 GiB (32.6%) fs: btrfs
dev: /dev/sda7 maj-min: 8:7
ID-4: /var/log raw-size: 157.84 GiB size: 157.84 GiB (100.00%) used: 51.45 GiB (32.6%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-5: /var/tmp raw-size: 157.84 GiB size: 157.84 GiB (100.00%) used: 51.45 GiB (32.6%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.27 GiB used: 983.3 MiB (29.4%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 63.5 C mobo: N/A gpu: radeon temp: 63.0 C
Fan Speeds (RPM): cpu: 3800
Info:      Processes: 223 Uptime: 10h 11m wakeups: 5 Memory: 3.27 GiB used: 2.06 GiB (63.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1500 lib: 372
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.08

1 Like

Careful, you booted from a snapshot.
You should "confirm" the restore in the timeshift GUI and reboot.
Then you can do anything else, e.g. you could check if the fix of yesterday is still there...
and maybe update

since we are at 5.15.4 today.

5 Likes

yes i am updating my system

After updating. if its still not showing inbuilt speakers.

Right click volume icon. Go to configure audio devices. There you might find show inactive devices. Just enable it. or in other case it will be under profile dropdown .it will be set to off mode just change it to analog stereo.

3 Likes

still not helping
it even got worse, after updating the system, the latte dock disappered,i thought reboothing in an option but n the grub menu it is showing an new arch distro but i only have garuda and win10, anyways after garuda got my speakers runninng but after conecting to bluetooth it disappeared again! and my garuda always froze at the sweet theme splash screen some how i managed to log and cleared all the configs
anyways welcome to the forum @CZEKOSHAR

1 Like

ok so i found a solution to this problem and that is to run sudo alsactl store
worked completly for me

BUT THE FACT IS NOW I LOST MY IN-BUILT MIC

ok now it is not working again

I'm using an Acer Swift 1 laptop and I had no sound output, neither through nor built in speakers nor headphone.
I found No Audio on Acer Swift 3 - #2 by bogdancovaciu - Sound - Manjaro Linux Forum and No sound after full-upgrade | Sound Problem | Acer Swift Laptop | Linux | ParrotOS - YouTube which gave the same advice, which worked for me too.
Create or add to the file /etc/modprobe.d/alsa-base.conf and add these two lines:
options snd-hda-intel dmic_detect=0
options snd-hda-intel model=laptop-amic enable=yes

... then reboot.

The first line is to enable the speaker, the second for the internal microphone.

2 Likes

yeah these lines already exist's but it is some sord of problem with alsa or pipewire or pulseaudio my in-built analog stereo is appearing and disappearing and messing up everything, my love towards garuda is fadding out :disappointed:, i can nither play audio nor video, i am using kali since one month and today i came with some config files which further messed up and gave birth to lot more problemes






i wanna die

Are you sure everything is ok here

Cause thing like this has happened to me too, but it's mainly that these settings in the above pic just get altered automatically.

2 Likes

nah bro it's messed up


(don't worry, I MUTED THE CHROME)

2 Likes

In the screenshot you have shared, try changing the profile(which is currently set Off ) to Analog Stereo Duplex

2 Likes

hey @Austin it fixed after yesterday's update however there is only off in the profile section

1 Like

alright, again AGIN




so i am booting garuda after week or two for the sound system problem . and now it is working so i decided to call my friend and i was akwardly talking and in the system tray my mic was flickering i tried to mute and ther we go again


mic and speaker not working again (GARUDA SUPPORT!!!!!1!!)

ok now i need serious help here is my inxi -Faz

System:
Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cfeb12e8-b340-4b7c-9957-a2bc51a4bef9 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: VivoBook E14 E402YA_E402YA v: 1.0
serial: <filter>
Mobo: ASUSTeK model: E402YA v: 1.0 serial: <filter>
UEFI: American Megatrends v: E402YA.303 date: 09/10/2019
Battery:
ID-1: BAT0 charge: 13.9 Wh (55.6%) condition: 25.0/32.3 Wh (77.5%)
volts: 7.8 min: 7.8 model: ASUSTeK E402-42 type: Li-ion serial: N/A
status: Discharging cycles: 435
CPU:
Info: model: AMD E2-7015 APU with AMD Radeon R2 Graphics socket: P0
bits: 64 type: MCP arch: Puma family: 0x16 (22) model-id: 0x30 (48)
stepping: 1 microcode: 0x7030106
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
desc: d-2x32 KiB; i-2x32 KiB L2: 1024 KiB desc: 1x1024 KiB
Speed (MHz): avg: 1175 high: 1350 min/max: 1000/1500 boost: disabled
base/boost: 1500/1500 scaling: driver: acpi-cpufreq governor: schedutil
volts: 1.1 V ext-clock: 100 MHz cores: 1: 1000 2: 1350 bogomips: 5988
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Mullins [Radeon R2 Graphics] vendor: ASUSTeK driver: radeon
v: kernel alternate: amdgpu bus-ID: 00:01.0 chip-ID: 1002:9853
class-ID: 0300
Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-1.4:5 chip-ID: 13d3:5a11 class-ID: 0e02
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8")
diag: 354mm (13.9")
OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.16.8-zen1-1-zen LLVM 13.0.0)
v: 4.5 Mesa 21.3.5 direct render: Yes
Audio:
Device-1: AMD Kabini HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
Device-2: AMD FCH Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8821ce v: N/A modules: rtw88_8821ce
port: e000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 3-1:2 chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s16u1 state: up mac: <filter>
Bluetooth:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 2-1.1:3 chip-ID: 13d3:3529 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 52.79 GiB (5.7%)
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B sata: 3.3
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J temp: 32 C
scheme: GPT
SMART: yes state: enabled health: PASSED on: 122d 11h cycles: 2047
Old-Age: g-sense error rate: 519
Partition:
ID-1: / raw-size: 157.84 GiB size: 157.84 GiB (100.00%)
used: 52.76 GiB (33.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
maj-min: 8:7
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 25.9 MiB (10.1%) fs: vfat block-size: 512 B dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw-size: 157.84 GiB size: 157.84 GiB (100.00%)
used: 52.76 GiB (33.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
maj-min: 8:7
ID-4: /var/log raw-size: 157.84 GiB size: 157.84 GiB (100.00%)
used: 52.76 GiB (33.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
maj-min: 8:7
ID-5: /var/tmp raw-size: 157.84 GiB size: 157.84 GiB (100.00%)
used: 52.76 GiB (33.4%) fs: btrfs block-size: 4096 B dev: /dev/sda7
maj-min: 8:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.26 GiB used: 1.5 GiB (46.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 61.5 C mobo: N/A gpu: radeon temp: 61.0 C
Fan Speeds (RPM): cpu: 3900
Info:
Processes: 202 Uptime: 1h 41m wakeups: 1 Memory: 3.27 GiB
used: 2.39 GiB (73.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1493 lib: 356
Shell: fish (sudo) v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12

please i need help i cant reinstall it now :disappointed_relieved: