No sound Fresh Install Garuda 6.3.8

Hi all,

I have fresh install of Garuda 6.3.8 But not receiving sound through the headphone jack or hdmi of my gtx 1060-6gb. I have looked though the forum and tried a few solutions that looked similar to mine. Most of these where for laptops, where I am a desktop. I am using the analogue stereo option.

Things i have tried:
Updating Garuda
Switching to Pulseaudio and then back to pipewire

systemctl --user enable pipewire.service
systemctl --user enable pipewire-pulse.service

I installed pavucontrol, this showed me I am receiving audio via the moving volume slider, But not hearing anything.

System:
Kernel: 6.3.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=73b2b4dd-2fff-44d3-96d3-d5b0cdf1c03b rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B560M-PLUS v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 2001
date: 02/01/2023
CPU:
Info: model: 11th Gen Intel Core i5-11400F bits: 64 type: MT MCP
arch: Rocket Lake gen: core 11 level: v4 note: check built: 2021+
process: Intel 14nm family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x58
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4400 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 801 10: 800 11: 800 12: 800 bogomips: 62208
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia
v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1c03 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 91 s-size: 1070x301mm (42.13x11.85")
s-diag: 1112mm (43.76")
Monitor-1: HDMI-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 92
size: 531x298mm (20.91x11.73") diag: 609mm (23.97") modes: N/A
Monitor-2: HDMI-1 pos: right res: 1920x1080 hz: 60 dpi: 51
size: 952x536mm (37.48x21.1") diag: 1093mm (43.01") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX 1060
6GB/PCIe/SSE2 direct-render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
API: ALSA v: k6.3.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 4000 bus-ID: 03:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 540.29 GiB used: 423.27 GiB (78.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 023 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST980811AS
size: 74.53 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
tech: N/A serial: <filter> fw-rev: B scheme: GPT
Partition:
ID-1: / raw-size: 74.23 GiB size: 74.23 GiB (100.00%)
used: 14.11 GiB (19.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 74.23 GiB size: 74.23 GiB (100.00%)
used: 14.11 GiB (19.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 74.23 GiB size: 74.23 GiB (100.00%)
used: 14.11 GiB (19.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 74.23 GiB size: 74.23 GiB (100.00%)
used: 14.11 GiB (19.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.19 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 38.0 C mobo: N/A gpu: nvidia temp: 56 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 279 Uptime: 3h 2m wakeups: 3 Memory: available: 31.19 GiB
used: 4.31 GiB (13.8%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1824
libs: 524 tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-06-18
Last full system update: 2023-06-20 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

And

systemctl status --user pipewire
● pipewire.service - PipeWire Multimedia Service
Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: enabled)
Active: active (running) since Tue 2023-06-20 11:18:24 BST; 3h 21min ago
TriggeredBy: ● pipewire.socket
Main PID: 1194 (pipewire)
Tasks: 3 (limit: 38169)
Memory: 46.2M
CPU: 21.129s
CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/pipewire.service
└─1194 /usr/bin/pipewire

Jun 20 11:18:24 Interpol systemd[783]: Started PipeWire Multimedia Service.

╭─chunkee@Interpol in ~ took 4ms
╰─λ systemctl status --user pipewire-pulse
● pipewire-pulse.service - PipeWire PulseAudio
Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; enabled; preset: enabled)
Active: active (running) since Tue 2023-06-20 11:18:47 BST; 3h 21min ago
TriggeredBy: ● pipewire-pulse.socket
Main PID: 1489 (pipewire-pulse)
Tasks: 2 (limit: 38169)
Memory: 70.2M
CPU: 55.055s
CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/pipewire-pulse.service
└─1489 /usr/bin/pipewire-pulse

Jun 20 11:18:47 Interpol systemd[783]: Started PipeWire PulseAudio.

A third command from the above ending wireplumber will not finish

Thank you in advance

Hi there, welcome to the forum!
Unfortunately, audio is one of the areas where I am weakest… :slight_smile:
I would just like to say (hello and) one thing, though.

Have you tried the other profiles in Audio - System Settings?

3 Likes

Hi Filo,

Thank you for the speedy reply.

I have tried profiles:
Analog stereo duplex
Analog stereo
Digital stereo output
Digital surround 5.1
Pro Audio

Same again for the hdmi, although i've focused on the headphones as I use them often.

Reboot, please.

4 Likes

Thank you. The hdmi sound has come back. So I will mark this as solved. My headphone jack seems to have disappeared and been replaced by a digital out, But that is another problem to look into separately.

Thanks for the help

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.