No sound after connecting BOSE bluetooth headphones

It was working but then it stopped.

This is the info from blueman about my device

60:AB:D2:45:5D:47
public
Bose QC35 II
Bose QC35 II
0x240418
0x0000
audio-headphones
yes
yes
no
no
-52 dBm (0x-34)
yes
00000000-deca-fade-deca-deafdecacaff Proprietary
00001101-0000-1000-8000-00805f9b34fb Serial Port
00001108-0000-1000-8000-00805f9b34fb Headset
0000110b-0000-1000-8000-00805f9b34fb Audio Sink
0000110c-0000-1000-8000-00805f9b34fb Remote Control Target
0000110e-0000-1000-8000-00805f9b34fb Remote Control
0000111e-0000-1000-8000-00805f9b34fb Handsfree
0000112f-0000-1000-8000-00805f9b34fb Phonebook Access (PBAP) - PSE
00001200-0000-1000-8000-00805f9b34fb PnP Information
81c2e72a-0591-443e-a1ff-05f988593351 Proprietary
931c7e8a-540f-4686-b798-e8df0a2ad9f7 Proprietary
f8d1fbe4-7966-4334-8024-ff96c9330e15 Proprietary
bluetooth:v009Ep4020d0481
/org/bluez/hci0
{2305: [193, 18, 195, 44, 207, 115, 232]}
{'0000fe2c-0000-1000-8000-00805f9b34fb': [1, 0, 240]}

pavucontrol shows Bose QC35 II
profile: A2DP Sink, codec AAC
I tried other profiles but to no avail.

systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset>
     Active: active (running) since Fri 2022-09-16 11:44:04 IDT; 19min ago
       Docs: man:bluetoothd(8)
   Main PID: 612 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18969)
     Memory: 7.0M
        CPU: 277ms
     CGroup: /system.slice/bluetooth.service
             └─612 /usr/lib/bluetooth/bluetoothd

Sep 16 11:44:18 shmuel-garuda bluetoothd[612]: Endpoint registered: sender=:1.3>
Sep 16 11:44:18 shmuel-garuda bluetoothd[612]: Endpoint registered: sender=:1.3>
Sep 16 11:44:18 shmuel-garuda bluetoothd[612]: Endpoint registered: sender=:1.3>
Sep 16 11:44:18 shmuel-garuda bluetoothd[612]: Endpoint registered: sender=:1.3>
Sep 16 11:44:26 shmuel-garuda bluetoothd[612]: /org/bluez/hci0/dev_60_AB_D2_45_>
Sep 16 11:46:36 shmuel-garuda bluetoothd[612]: /org/bluez/hci0/dev_60_AB_D2_45_>
Sep 16 11:46:44 shmuel-garuda bluetoothd[612]: /org/bluez/hci0/dev_60_AB_D2_45_>
Sep 16 11:46:53 shmuel-garuda bluetoothd[612]: /org/bluez/hci0/dev_60_AB_D2_45_>
Sep 16 11:47:44 shmuel-garuda bluetoothd[612]: src/profile.c:ext_io_disconnecte>
Sep 16 11:52:35 shmuel-garuda bluetoothd[612]: /org/bluez/hci0/dev_60_AB_D2_45_>
garuda-inxi
System:
  Kernel: 5.15.68-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=1ae1827d-082e-4190-8d66-84aa16e7a79c rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B365M-A v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 1203
    date: 10/10/2019
CPU:
  Info: model: Intel Core i7-9700 bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 level: v3 built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xF0
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 4473 high: 4547 min/max: 800/4700 scaling:
    driver: intel_pstate governor: performance cores: 1: 4508 2: 4541 3: 4462
    4: 4511 5: 4547 6: 4516 7: 4208 8: 4496 bogomips: 48000
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: HDMI-A-1,HDMI-A-2 empty: DP-1 bus-ID: 00:02.0
    chip-ID: 8086:3e98 class-ID: 0300
  Device-2: Microdia USB Live camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.2:7 chip-ID: 0c45:636b
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.00x11.26")
    s-diag: 1055mm (41.55")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,right model: VG27AQ1A
    serial: <filter> built: 2020 res: 1920x1080 hz: 120 dpi: 82 gamma: 1.2
    size: 596x336mm (23.46x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-2 pos: primary,left
    model: Samsung S24B300 serial: <filter> built: 2013 res: 1920x1080 hz: 60
    dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa
    22.1.7 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel bus-ID: 1-1.2:7 v: kernel chip-ID: 0c45:636b
    bus-ID: 00:1f.3 class-ID: 0102 chip-ID: 8086:a2f0 serial: <filter>
    class-ID: 0403
  Device-2: Microdia USB Live camera type: USB
    driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.15.68-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek 802.11ac NIC type: USB driver: rtl8821cu
    bus-ID: 1-2.2:8 chip-ID: 0bda:c811 class-ID: 0000 serial: <filter>
  IF: wlp0s20f0u2u2 state: dormant mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.1:4 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.26 TiB used: 777.26 GiB (33.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: K1B3 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD120
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: ACF0 scheme: GPT
Partition:
  ID-1: / raw-size: 58.83 GiB size: 58.83 GiB (100.00%) used: 28.14 GiB
    (47.8%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 37.1 MiB
    (38.7%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 58.83 GiB size: 58.83 GiB (100.00%) used: 28.14 GiB
    (47.8%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-4: /var/log raw-size: 58.83 GiB size: 58.83 GiB (100.00%) used: 28.14
    GiB (47.8%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-5: /var/tmp raw-size: 58.83 GiB size: 58.83 GiB (100.00%) used: 28.14
    GiB (47.8%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.49 GiB used: 768 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 294 Uptime: 20m wakeups: 0 Memory: 15.49 GiB used: 4.53 GiB
  (29.3%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1406 libs: 374
  tools: pamac,paru,yay Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.21
Garuda (2.6.7-1):
  System install date:     2022-09-12
  Last full system update: 2022-09-16
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:    

Did you try other Kernel?
My inxi with zen.

  Sound Server-1: ALSA v: k5.19.8-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes

PulseAudio is on. Just a idea, but I am not a specialist for sound.

3 Likes

I was on the zen kernel originally, but I switched to lts because of my usb wifi adapter that needed a compatible driver.

1 Like

Maybe I should just activate PulseAudio? What would be the systemctl command for that?

Yesterday also I had a problem with Bluetooth and my bluetooth headphones

I use the Bluetooth configurator integrated into KDE (Plasma).
I deleted the configuration related to the headphones and I created a new one.
Headphones started to work again.

2 Likes

If you feel that this is the problem, just install pipewire-pulse

In my experience the A2DP protocol is not working at all. Some profiles played back my microphone input into my headphones, and some just do not work at all, like the afore mentioned A2DP. For me apt-x and apt-x-LL worked best, or rather at all. Are these not available to you?

2 Likes

I don't see those profiles. I attached a screenshot of the ones I see

@LorenzoHex how did you delete the config?

Do you have libreeaptx installed?

Edit: Obviously you have, it's a dependency for pipewire.

But: Does your dongle support it? I read about some trouble with different dongles not supporting it

Regarding the config deletion: see /usr/share/pipewire - You might get away with just deleting those files and reinstalling pipewire to restore them

1 Like

I got it figured out. There are three places in pavucontrol where you have to make the right choice, and it needs to be done manally.
1 Playback
2 Output devices
3 Configuration

After choosing the right devices and profiles in all three places, sound works as expected. :grinning:

I just got a several updates that were audio-related, so I don't know, maybe that helped. But probably, I just missed the right setting in one of the above-mentioned places.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.