No option to switch to HSP/HFP mode

I've successfully connected my bluetooth headphones (boat airdopes 441) to my laptop. it works fine in A2DP playback mode. but I am unable to switch it to HSP/HFP mode.
I went to settings > audio > configure > airdopes 441 > profile and it is only showing me 2 options A2DP and off. But my headphones work in HSP/HFP mode on windows.

Install pavucontrol and set it there?

4 Likes

I'm not sure but is this what you were asking me to do ??
also in HSP/HFP the available section says no. :frowning:

What happens when you install and run paprefs?

1 Like

Nope. 

I did install pavucontrol but couldn't find how to set the profile there. I'm new to this :sweat_smile:

If the profile is available it should be in the Configuration drop-down menu:

Does thet even work on KDE?

Of course it does. Instead of asking, try it yourself. I mean, it might not work on your system.

1 Like

Okay I tried switching the profile using pavucontrol but It was not showing the HFP there too, so I searched and found
https://wiki.archlinux.org/index.php/Bluetooth_headset#HFP_not_working_with_PulseAudio

Once I completed the steps there the HFP option showed up but it still dosnt work. It automatically switches from HFP to Off and I am not recieving any sound even during the short period it's in HFP.

I think this better explains where the problem is.

Have you tried installing pulseaudio-modules-bt ?

You do know what you are asking is for using a microphone and unless the mic is enabled and you are using software like facebook etc it will not work here is the Arch page you want
Bluetooth headset - ArchWiki good luck.

5 Likes

@mandog but I should be able to switch to HSP/HFP profile irrespective of weather I am using the mic or not, right ??

yes I tried pulseaudio-modules-bt and pulseaudio-modules-bt-git too.

Yes in theory you should but their is a big but, as we should be aware not much is actually Linux compatible I did a google nothing about Linux and this could be the problem it mentions compatability with android and ios but that is it. I know when i connect my ear buds i can select both. if you are using KDE I really can't help more than that it could be a compatibility problem.
Is this a laptop or desktop you are using

1 Like

Its a laptop

You could try the lts kernel maybe?