No network device detected

Hello Garuda users.

Unfortunately, My laptop fell on the ground 2 days back and I had to replace power jack. After finishing all that, when I rebooted my laptop, it is 'unable to find any network device'. I looked into older posts but didn't find any exactly same question.Output of network related drivers is as below:


Message: No device detected.
  • I tried running 'sudo pacman -Sy'.
  • Replaced intel wifi adapter.
  • Garuda network assistant is not showing up. Although, it asks me for a password.


Have you checked that you have re seated your wireless network adapter correctly after rebuilding your laptop ?

Also can you provide your full


1 Like

Yes, I tried to re-seat my adapter 2-3 times.

I used my friends' phone for USB tethering to access internet but it is not available now and I am using another laptop to post the question.

Ok maybe along shot then check your bios that it is enabled?

1 Like

The only change I made in BIOS was, I had to enable legacy boot due hard disk issue.
I see exclamation mark in front of 'Network boot' under boot options.

I don't see any other option to enable/disable network adapter under BIOS settings.

I think you may have done more damage than you thought?


That could be a possibility. My only hope was, before I switched to legacy boot, wifi was working fine. (after the laptop fell down).

Did you replace your wifi adapter with the exact same model?

Many laptop's bios versions are locked down and only permit adapters on the manufacturers whitelist to be used. Other adapters not on the whitelist likely may not work as a direct replacement.

1 Like

Yes, Same intel adapter.

Please post the output of the following command:

hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"  

Save the command's terminal output and upload it to the forum from a device that has internet connectivity.

Also please upload your full garuda-inxi.

A full factory bios reset sometimes helps in these types of cases. Resetting the BIOS back to the factory default settings may help with adapter detection. Boot into the BIOS settings utility and reset the BIOS back to the factory default. Save the default settings, then power down the laptop. Remove the battery and power plug, and let the laptop sit without power for a minute. Then, hold down the power button for approximately 30 seconds. Then restart the laptop, and see if it will boot with the factory default settings. If not, you may have to change some settings in the BIOS (such as secure boot etc) to get Linux to boot up correctly.

Use any live boot disk to check if your WiFi is working. This step will sometimes help with adapter detection and correct the problem of an undetected adapter.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.