No Kernel Image found

So right now I'm playing around with some different backup tools in the event of snapper not being enough for whatever reason that may be such as an irepairable problem or wiping the drive etc. So I have been trying to create a backup file of my system, but when it tries to find the kernel, it fails. Any ideas would be appreciated thanks.

System:
  Kernel: 5.16.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=41193397-191d-45b5-8c2b-405cf71e73b2 loglevel=3
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock
    wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: X510UA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X510UA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X510UA.312 date: 04/29/2020
Battery:
  ID-1: BAT0 charge: 28.0 Wh (100.0%) condition: 28.0/42.1 Wh (66.4%)
    volts: 11.5 min: 11.5 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Not charging cycles: 445
CPU:
  Info: model: Intel Core i7-7500U bits: 64 type: MT MCP
    arch: Amber/Kaby Lake note: check family: 6 model-id: 0x8E (142)
    stepping: 9 microcode: 0xEC
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 733 high: 766 min/max: 400/3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 732 2: 709 3: 725 4: 766
    bogomips: 23199
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916
    class-ID: 0300
  Device-2: IMC Networks VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 13d3:5a07 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.0
    compositor: kwin_wayland driver: X: loaded: intel unloaded: modesetting
    alternate: fbdev,vesa gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-8:4 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 961.34 GiB used: 139.53 GiB (14.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO M.2 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk
    model: Cruzer Force size: 29.81 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 139.5 GiB (31.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 27.9 MiB (9.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 139.5 GiB (31.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 139.5 GiB (31.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
    used: 139.5 GiB (31.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.06 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 52.0 C pch: 42.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2900
Info:
  Processes: 265 Uptime: 18m wakeups: 1 Memory: 15.51 GiB
  used: 3.22 GiB (20.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1563 lib: 388 Shell: fish
  v: 3.3.1 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
  System install date:     2022-02-23
  Last full system update: 2022-03-22 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            systemd-sysctl.service 

Relax-and-Recover 2.6 / Git
Running rear mkbackup (PID 28438 date 2022-03-22 21:47:01)
Using log file: /var/log/rear/rear-localhost.log
Running workflow mkbackup on the normal/original system
Using backup archive '/var/tmp/rear.Y2ZxpUHb7CG3VhP/tmp/isofs/backup/backup.tar.gz'
Using UEFI Boot Loader for Linux (USING_UEFI_BOOTLOADER=1)
ERROR: Cannot autodetect what to use as KERNEL_FILE, you have to manually specify it in /etc/rear/local.conf
Some latest log messages since the last called script 400_guess_kernel.sh:
  2022-03-22 21:47:02.193412737 No kernel file '/boot/vmlinux-5.16.16-zen1-1-zen' found
  2022-03-22 21:47:02.196428382 No get_kernel_version binary, skipping searching for kernel file in /boot
  2022-03-22 21:47:02.200222856 No Arch Linux kernel file '/boot/vmlinuz-linux' found
  2022-03-22 21:47:02.203787957 No Arch Linux kernel file '/boot/vmlinuz26' found
Some messages from /var/tmp/rear.Y2ZxpUHb7CG3VhP/tmp/rear.mkbackup.stdout_stderr since the last called script 400_guess_kernel.sh:
  /usr/share/rear/lib/_input-output-functions.sh: line 510: type: get_kernel_version: not found
Use debug mode '-d' for some debug messages or debugscript mode '-D' for full debug messages with 'set -x' output
Aborting due to an error, check /var/log/rear/rear-localhost.log for details
Exiting rear mkbackup (PID 28438) and its descendant processes ...
Running exit tasks
fish: Job 1, 'sudo /usr/sbin/rear -v mkbackup' terminated by signal SIGTERM (Polite quit request)

Have you tried following these instructions?

1 Like

ERROR: Cannot autodetect what to use as KERNEL_FILE, you have to manually specify it in /etc/rear/local.conf

Use debug mode '-d' for some debug messages or debugscript mode '-D' for full debug messages with 'set -x' output
Aborting due to an error, check

/var/log/rear/rear-localhost.log

for details

Yes I have tried this but no luck after specifying as still no kernel image found

Here's a link to the log as it's long thanks

https://katb.in/sijujogaval

In that case I would reach out to whoever the maintainer of that application is.

What did you put?

Can you post /etc/rear/local.conf?

I don't remember exactly as I'm on my laptop this second but it was something along the lines of

KERNEL_FILE="/boot/kernel path

Been reading through this trying to see if my problem is here like if it's related to efi stub or something else

https://fossies.org/linux/privat/rear-2.6.tar.gz/rear-2.6/doc/user-guide/relax-and-recover-user-guide.adoc

I think you are just missing the /efi/ directory in your path.

/boot/efi/vmlinux-5.16.16-zen1-1-zen

It isn't normal for the kernel to be in /boot/efi. You would have to have some custom hooks for that to work.

This also isn't the right name for the kernel. Without knowing exactly what you have in that file it is hard to say what the issue could be.

Thanks but no luck

No, but that is what the documentation for this package calls for:

1. Copy active Linux kernel and initrd files to vfat file system and configure ReaR to use alternate kernel file.

In this particular case active kernel and initrd image are represented by following files:

sp2:~ # ls -al /boot/vmlinuz-* /boot/initrd-*
-rw------- 1 root root 16365388 Aug 30 17:29 /boot/initrd-4.4.21-69-default
-rw-r--r-- 1 root root  5742352 Oct 25  2016 /boot/vmlinuz-4.4.21-69-default

To copy files to vfat file system /boot/efi:

sp2:~ # cp /boot/initrd-4.4.21-69-default /boot/efi
sp2:~ # cp /boot/vmlinuz-4.4.21-69-default /boot/efi

Now we need to tell ReaR that we have kernel on vfat file system by adding KERNEL_FILE="/boot/efi/vmlinuz-4.4.21-69-default" configuration option into /etc/rear/local.conf

1 Like

Really struggling to get the output on anything like privatebin etc.

That is pretty terrible. If your system was encrypted that would copy the decryption keys to an unencrypted space rendering your encryption pointless.

@Grimy1928, I have a new recommendation. Don't use this software. There are plenty of other backup solutions that work in a more straightforward manner.

2 Likes

Yeah I'm sure there are and I'm getting frustrated with this software haha. I just want a good solution other than rsync that gives me a bootable USB stick with my current system on and can't find any that actually work or if they do then not with btrfs or some other problem.

@Grimy1928 How about btrfs device add with the backup disk, convert to RAID1 to get an exact copy of your system disk, then run btrfs balance and remove the backup device?

It will be easy as pie compared to getting that ReaR thing set up. The steps involved are described here: Volume management — BTRFS documentation

That sounds very interesting thanks for letting me know about it. The thing is though that my external drive is 2tb. So would that work when for example wanting to clone back from 2tb drive to a 500gb drive? Like how's that tool work with that? I'll take a look through that link anyway so thank you

btrfs device add can be a partition, so in your case I would make a partition the exact size of your main partition (500 GB minus whatever the EFI partition is, or any other non-btrfs partitions you have). Then add the device and set up the RAID. EFI would have to be backed up separately I suppose...:thinking:

To restore, dd might be more practical than trying to set up a new RAID. The partition size would be exactly the same so you could just go for it.

Just curious, why the aversion to rsync?

Okay thanks for letting me know. Sounds simple enough although gets more complicated with the different size drives. Might take a look soon though as would be a nice solution.

With rsync it's not that I have a problem with it necessarily, I guess I just don't fully understand to what extent it works. Like if I have an rsync backup and wipe my Garuda install, then to what point does the restore work? Like will it restore my layout like themes, latte dock and all the individual little things like blur? Or is it more just for file backups and programs and their data? I understand it copies basically 1 to 1 from the source to the destination drive but does copying the files actually mean things are applied like symlinks, configuration's and so on? Or are those files just there where they should be but not applied? That's kinda why I wanted an identical clone that I could do to a bigger drive and then back to a smaller drive if necessary because I'm not sure to what extent an rsync restore will get me back to an identical system and how much is needed to be done after the restore.

use rufus to create bootable drive then install :grinning: