No internet password in Wayfire

Hello. Today I installed Garuda wayfire. I tried to connect to internet but it never let me introduce the password. I saw another post that found a problem with connman, but as i don't have internet there I couldn't search or look for answers here in the forum. I think it said it was solved downgrading or updating. I am writing this from another disk with manjaro.
Thank you.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

It's kind of ironic you include the topic template/help text in your post and yet have completely ignored it.

There seems to be an issue with connman. If you do not have another networking device (or e.g. an Ethernet cable) then the solution is to use a different image for the moment.


Hi, I moved the laptop to connect it to lan internet. Now I am running the assistant and updating. May be that will be enough, or I-ll search how to change connman. Sorry for not providing other information, I thought that as I was writing from manjaro it wouldn-t help. Thank you

Kernel: 5.13.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=6711e2eb-efd7-4094-b07b-229a957da761 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           Desktop: N/A vt: 1 dm: N/A Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: K53E v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: K53E v: 1.0 serial: <filter> BIOS: American Megatrends
           v: K53E.219 date: 03/06/2012
Battery:   ID-1: BAT0 charge: 37.4 Wh (86.0%) condition: 43.5/48.4 Wh (89.9%) volts: 11.4
           min: 11.1 model: ASUSTek K53--52 type: Li-ion serial: N/A status: Discharging
CPU:       Info: Dual Core model: Intel Core i3-2350M bits: 64 type: MT MCP arch: Sandy Bridge
           family: 6 model-id: 2A (42) stepping: 7 microcode: 2F cache: L2: 3 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18359
           Speed: 2295 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 2295 2: 2295 3: 2295
           4: 2295
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
           STIBP: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
           vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0116
           class-ID: 0300
           Device-2: IMC Networks UVC VGA Webcam type: USB driver: uvcvideo bus-ID: 1-1.2:4
           chip-ID: 13d3:5710 class-ID: 0e02 serial: <filter>
           Display: wayland server: X.Org compositor: wayfire driver: loaded: i915
           note: n/a (using device driver) display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
           s-diag: 414mm (16.3")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 21.1.6
           compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.9-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: AzureWave
           driver: ath9k v: kernel port: e040 bus-ID: 02:00.0 chip-ID: 168c:0032 class-ID: 0280
           IF: wlan0 state: down mac: <filter>
           Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: ASUSTeK driver: atl1c
           v: kernel port: a000 bus-ID: 04:00.0 chip-ID: 1969:1083 class-ID: 0200
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.35 TiB used: 6.65 GiB (0.5%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SV300S37A480G size: 447.13 GiB
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
           rev: BBF2 scheme: MBR
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital
           model: WD10JMVW-11AJGS3 size: 931.48 GiB block-size: physical: 512 B logical: 512 B
           type: HDD rpm: 5400 serial: <filter> rev: 1065 scheme: MBR
Partition: ID-1: / raw-size: 300.49 GiB size: 300.49 GiB (100.00%) used: 6.65 GiB (2.2%)
           fs: btrfs dev: /dev/sdb2 maj-min: 8:18
           ID-2: /home raw-size: 300.49 GiB size: 300.49 GiB (100.00%) used: 6.65 GiB (2.2%)
           fs: btrfs dev: /dev/sdb2 maj-min: 8:18
           ID-3: /var/log raw-size: 300.49 GiB size: 300.49 GiB (100.00%) used: 6.65 GiB (2.2%)
           fs: btrfs dev: /dev/sdb2 maj-min: 8:18
           ID-4: /var/tmp raw-size: 300.49 GiB size: 300.49 GiB (100.00%) used: 6.65 GiB (2.2%)
           fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.55 GiB used: 0 KiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 2900
Info:      Processes: 253 Uptime: 9m wakeups: 1 Memory: 7.55 GiB used: 2.57 GiB (34.1%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
           pacman: 1113 lib: 291 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
           running-in: alacritty inxi: 3.3.06
1 Like

It might help, but if it doesn't you can install connman-git which includes the fix, or switch over to Network Manager (which is what Garuda will be doing with future images anyway).

Fair enough. The hardware information is still the same, so at least people can check things like your wifi chipset.


We do not support manjaro but the required inxi data is identical. :wink:


* any more.

Also, I might still disagree given the features they implemented in 21.1. :joy:


I missed you all from manjaro, I am using endeavour and garuda to keep in contact through the forums


Sorry, i tried network manager and the desktop froze i removed it and left connman git, it lets me put the password but gives a mistake:

I am away from the ethernet because i needed to charge. Tomorrow i will try again. Thank you a lot for helping


You can try removing /var/lib/connman/* before reinstalling the git version, that was part of the solution for me.


Run the command
yay -S conman-git
And reboot. Try again

1 Like

It worked, i reinstalled conman-git and rebooted, now it is connected. Thank you all that helped

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.