No input or output devices found

System:
Kernel: 5.19.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c5c8b0e5-c2c7-47a3-9951-9e91c4bc9404 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=c299ee24-e17d-46a1-9481-abf64483268e loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X470 AORUS ULTRA GAMING v: N/A
serial: <superuser required>
Mobo: Gigabyte model: X470 AORUS ULTRA GAMING-CF v: x.x
serial: <superuser required> UEFI-[Legacy]: American Megatrends v: F51g
date: 07/02/2020
CPU:
Info: model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen/Zen+ note: check gen: 1 built: 2019 process: GF 12nm
family: 0x17 (23) model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 1400 min/max: 1400/3600 boost: enabled scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 1400 3: 1400
4: 1400 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT disabled
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: none bus-ID: 0a:00.0 chip-ID: 1002:15d8
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung built: 2014
res: 1366x768 hz: 60 dpi: 57 gamma: 1.2 size: 609x347mm (23.98x13.66")
diag: 701mm (27.6") ratio: 16:9 modes: max: 1366x768 min: 720x400
OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.6 DRM 3.47
5.19.2-zen1-2-zen) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: N/A
alternate: snd_hda_intel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte driver: N/A
alternate: snd_hda_intel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0a:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
chip-ID: 10ec:8179 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Drives:
Local Storage: total: 2.25 TiB used: 13.63 GiB (0.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte
model: GP-GSM2NE3256GNTD size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EDFM00.7 temp: 34.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD800JD-55JRA0 size: 74.53 GiB block-size: physical: 512 B
logical: 512 B speed: 1.5 Gb/s type: N/A serial: <filter> rev: 1C05
scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Patriot model: Burst
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 61.3 scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Kingston
model: DataTraveler 3.0 size: 14.44 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 13.63 GiB
(5.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 13.63
GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 13.63
GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 229.67 GiB size: 229.67 GiB (100.00%) used: 13.63
GiB (5.9%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.73 GiB used: 3 MiB (0.1%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
Sensors:
System Temperatures: cpu: 43.2 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 236 Uptime: 2h 10m wakeups: 0 Memory: 5.73 GiB used: 2.85 GiB
(49.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1342 lib: 351 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-31
Last full system update: 2022-08-31 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

I have a problem with audio i get red speaker icon with a minus in front of it I've searched the forum and found similar problems but i couldn't resolve it am not an advanced linux user just getting started . I don't have any speakers i have a tv screen with speakers connected on the motherboards hdmi port since i don't have a gpu and until resently i had audio after an update and an error about conflicted dependences pipewire and pulseaudio i started having this problem today i reinstalled garuda but i still get the same error

Hi there, welcome to the forum.
Most likely this is not going to solve your issue, but the last symbol indicates that your system has not been rebooted after the last update.

1 Like

Ok i'll give it a try just in case. Thanks.

now i can see in devices analog output and analog input but i still don't have audio do i need to set that i get audio from hdmi maybe

Are you using jack with pipewire? If so, my first suggestion is usually to fire up Qjackctl (install if you don't have it) and see if the devices are listed and the software is appropriately routing the audio.

You can do the same thing with console commands, but i think the routing is easier to understand in Qjackctl.

The audio should be routed through your video (AMD Radeon Vega) which cues my next thought -- do you have drivers installed for it?

2 Likes

Sometimes "un-muting" the device in
alsamixer can restore audio. It's so easy to try, it's always worth a shot.

4 Likes

i am not sure if i do have the drivers installed to be honest . How should i go about it also i installed qjackctl but i didn't found any devices listed

i only had option - (default), default:0 loopback and enter device name

I think we've found your problem. However, have you restarted since you posted? Since it's been a day you may have already.

Last full system update: 2022-08-31 <-- icon indicates you've yet to restart since latest update.

Some googling of my own, AMD does not officially support this 3200g Vega 8 for linux, however, a working driver for other users has existed in the kernel for a while (over 3 years).

Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: N/A
alternate: snd_hda_intel pcie: gen: 3 speed: 8 GT/s lanes: 16

After the restart if it still doesn't work I would try reinstalling pipewire. Honestly this shouldn't be happening on a new install, but since it is, this is worth a shot:

Remove all the configuration files in /etc/pipewire (sudo mv /etc/pipewire /tmp)

Reinstall pipewire, pipewire-pulse, and pipewire-media-session (sudo pacman -S pipewire pipewire-pulse pipewire-media-session)

Enable and start the relevant services (systemctl --user enable pipewire pipewire-pulse pipewire-media-session) and (systemctl --user restart pipewire pipewire-pulse pipewire-media-session).

I also just noticed that the default driver that has worked for other users is installed on your system, but not loaded. Before reinstalling pipewire, that might be a quicker fix, but I need to google that procedure. I edited my post to add that above in the appropriate spot.

pavucontrol (graphical application) should tell you if it's disabled, which would explain why it's not showing up and the driver isn't loaded. Try that before reinstalling pipewire and components.

I'm gonna take some ibuprofen, i just googled and forum searched myself in circles and now i have a headache.

i tried reinstalling as you suggested unfortunately didn't work either. Although you said to reinstall pipewire-media-session i got conflicted dependencies with wireplumber tried removing wireplumber but i got an error so i don't know if this has some connection with my problem .. Thanks anyways if you have other suggestion i'll try them out sorry for the headache :sweat_smile:

Pop open pavucontrol and see if anything is outright disabled. From there, I think that's the end of my technical knowledge. I'll keep looking when I get home.

i've opened up pavucontrol but i don't see something that is disabled . I've done some searching yesterday as well and is there a possibility to be a problem with wireplumber

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.