No grub menu since update


I have a big problem, since last update i had no grub menu when i boot my laptop, so i decided to check uefi settings but i can’t go to uefi so when i boot the PC, i chose uefi in grub boot option and now i have a reboot loop and can’t do anything just see the laptop turn on and off is there something i can do? i don’t have access to annything as it boot and i’m not a pro

Use live ISO, chroot, fix GRUB_TIMEOUT=

micro /etc/default/grub

I have a black screen with reboot loop on the pc can’t do anything if i coild i woild have reinstall garuda but i have access to nothing on the pc

Use live ISO

Use forum search

I put the live iso but still reboot loop the usb don’t load

On boot press F2 or F8 or what ever to edit the boot sequence.

With F2 or F8 the screen is black but no reboot so can’t do anything too

Search in the WWW or in the PC manual about this.

Solution include to access bios but i don’t jave access to it, it’s like the screzn is shut down but the bios open

Well it boot on garuda by itself can’t say how i didn’t do anyyhing special but still doesn’t have grub selection menu, is there a way to have it back?

chroot or if it boot then

sudo grub-install --no-nvram
sudo update-grub

Post output from

lsblk -f
1 Like

By-the-way, to go to the UEFI, doesn’t this work?

General situation (Before booting)

While the computer isn’t powered on yet, press and hold the F2 button of the keyboard, and then press the Power button (Do not release F2 button until the BIOS configuration display.).

Note: For certain older models of desktop computers, it may be necessary to press and hold the Del key, and then press the power button to start up, in order to access the BIOS configuration.

Apart from that, if your Garuda boots, you could open the Garuda Boot Options and make sure the Menu timeout is not set to 0.

1 Like
╰─λ efibootmgr
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0004,0000,0002
Boot0000* Windows Boot Manager  VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000064000100000010000000040000007fff0400
Boot0001* Garuda        HD(1,GPT,fb6cf1dd-f67a-4d67-959f-57f929a07941,0x1000,0x96000)/File(\EFI\GARUDA\GRUBX64.EFI)
Boot0002* Manjaro       VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0004* UEFI OS       HD(1,GPT,fb6cf1dd-f67a-4d67-959f-57f929a07941,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
╰─λ lsblk -f
NAME        FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
zram0                                                                              [SWAP]
├─nvme0n1p1 vfat   FAT32       3449-0737                             298,8M     0% /boot/efi
└─nvme0n1p2 btrfs              03cf0922-86bd-45b4-984f-4e0416a0ef5d  449,5G     6% /var/log

Why do i have a Manjaro entry? i tried it but cleaned the disk before reinstall garuda

it doen’t work but it seems a display driver issue, i think the driver that should show bios and grub screen doesn’t load, i have black screen then just before my session open, the screen it blink before the session open.

Edit: it’s definitly not a grub problem, but probably a display driver, when i logged out to select x11 session, i got a black screen too so i can’t select x11 from there or wayland or a different user if i had one.

my garuda inxi in case you need it:

Kernel: 6.7.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=03cf0922-86bd-45b4-984f-4e0416a0ef5d rw rootflags=subvol=@
quiet loglevel=3 nvidia-drm.modeset=1 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A15 FA507NV_FA507NV
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FA507NV v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: FA507NV.312 date: 08/11/2023
ID-1: BAT1 charge: 67.7 Wh (79.9%) condition: 84.7/90.2 Wh (93.9%)
volts: 16.4 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
status: not charging
Info: model: AMD Ryzen 7 7735HS with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 649 high: 1397 min/max: 400/4829 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 1397 3: 400
4: 400 5: 1397 6: 400 7: 400 8: 400 9: 1397 10: 400 11: 400 12: 400
13: 400 14: 400 15: 400 16: 1397 bogomips: 102213
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ pcie: gen: 1 speed: 2.5 GT/s lanes: 8
link-max: gen: 4 speed: 16 GT/s ports: active: none off: eDP-1
empty: DP-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:28e0 class-ID: 0300
Device-2: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-2,
DP-3, DP-4, DP-5, DP-6, DP-7, DP-8, DP-9, eDP-2 bus-ID: 35:00.0
chip-ID: 1002:1681 class-ID: 0300 temp: 53.0 C
Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:2 chip-ID: 2b7e:b685
class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: nvidia,amdgpu display-ID: 0
Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: radeonsi x11: drv: radeonsi
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.4-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
rembrandt LLVM 16.0.6 DRM 3.56 6.7.2-zen1-2-zen) device-ID: 1002:1681
memory: 500 MiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.276 layers: 10 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV REMBRANDT) driver: mesa radv v: 23.3.4-arch1.2
device-ID: 1002:1681 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 4060 Laptop GPU driver: nvidia
v: 545.29.06 device-ID: 10de:28e0 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.3.4-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 35:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 35:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 35:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.2-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:2 chip-ID: 13d3:3563
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 476.94 GiB used: 26.2 GiB (5.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2400 MTFDKBA512QFM
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: V3MA003 temp: 37.9 C
scheme: GPT
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 26.2 GiB (5.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 26.2 GiB (5.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 26.2 GiB (5.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 26.2 GiB (5.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 14.87 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
System Temperatures: cpu: 65.4 C mobo: 38.0 C gpu: amdgpu temp: 55.0 C
Fan Speeds (rpm): cpu: 0
Processes: 380 Uptime: 2m wakeups: 0 Memory: total: 16 GiB note: est.
available: 14.87 GiB used: 3.07 GiB (20.6%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1319 libs: 397 tools: octopi,paru Shell: fish v: 3.7.0
running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2023-11-25
Last full system update: 2024-02-01
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

i don’t know why it says probably to dual boot, i have only Garuda and i’ve selected clear the disk to install garuda.

But inxi cannot know this because you are running it without root rights.


I don’t know if it’s related but i have a lot of white text when i log off or reboot but it’s too fast to read, i just saw Nvidia in it

Isn’t there any solution to my problem? Updating my system broke it and even snap restore doesn’t fix it, it’s like the screen only turn on when the session open and stay off until then, right before the session open, it blink a few time before it turns on.
I can’t event reinstall or install another os as even the bios is a black screen since then

This is Plymouth, a bootsplash.
As long as there is a green OK in front of the white text, everything is fine.

The issue isn’t grub so maybe i should open another thread instead so the problem is clearer for everyone

In order not to attract help seekers unnecessarily, only to disappoint them with this post which is not a solution, I have removed the solution hook from your post.

Opening a new topic for the same problem is also not a solution and is not welcome in forums.